Поделиться через


Ошибка "Ресурс не найден" при настройке канала WhatsApp

В этой статье приводятся рекомендации по устранению ошибки "Ресурс не найден для сегмента "msdyn_UpdatePrivacyTerms", которая может возникнуть при настройке канала WhatsApp в Dynamics 365 Customer Service или Dynamics 365 Contact Center.

Симптомы

При попытке настроить канал WhatsApp в Dynamics 365 Customer Service или Dynamics 365 Contact Center вы получите следующее сообщение об ошибке:

Ресурс не найден для сегмента "msdyn_UpdatePrivacyTerms".

Причина

Эта проблема возникает, когда некоторые необходимые подключаемые модули, связанные с Omnichannel, отключены.

Резолюция

Проблему можно устранить следующим способом.

Шаг 1. Доступ к параметрам настройки

  1. Откройте приложение на основе модели Dynamics 365.

  2. Перейдите к следующему пути: Настройки>Дополнительные параметры>Настройки>Настройка системы.

Шаг 2. Поиск шагов обработки сообщений ПАКЕТА SDK

  1. В окне "Настройка системы" разверните левую панель навигации.

  2. Выберите действия по обработке сообщений ПАКЕТА SDK в разделе "Компоненты".

Шаг 3. Активация необходимых плагинов

  1. В списке SDK Message Processing Steps в столбце Имя найдите следующие подключаемые модули:

    • Microsoft.Dynamics.OmnichannelSharedBase.Plugins.PostOperationUpdatePrivacyTermsPlugin: msdyn_UpdatePrivacyTerms любой сущности.
    • Microsoft.Dynamics.OmnichannelBase.Plugins.PostOperationUpdatePrivacyTermsPlugin: msdyn_UpdatePrivacyTerms любой сущности.
  2. Проверьте столбец состояния для каждого подключаемого модуля:

    • Если подключаемый модуль отключен, выберите его, отметив флажок рядом с его названием.

    • Нажмите кнопку "Активировать " на панели инструментов.

Шаг 4. Сохранение и публикация настроек

  1. После активации необходимых подключаемых модулей нажмите кнопку "Сохранить " на панели инструментов.

  2. Затем выберите "Опубликовать все настройки" , чтобы применить изменения.