Поделиться через


Соглашение об уровне обслуживания не применяется к делу

В этой статье описываются различные сценарии, в которых соглашение об уровне обслуживания (SLA) может не применяться к делу и действия по их устранению.

Сценарий 1. Соглашение об уровне обслуживания по умолчанию не задано

Причина

Соглашения об уровне обслуживания не применяются к делу, если соглашение об уровне обслуживания по умолчанию не задано.

Решение

Убедитесь, что соглашение об уровне обслуживания по умолчанию задано как соглашение об уровне обслуживания по умолчанию, выполнив следующие действия.

  1. В Центре администрирования службы клиентов перейдите к соглашениям об уровне обслуживания.
  2. Выберите условия службы в операциях. Появится страница Условия обслуживания.
  3. В разделе Соглашения об уровнях обслуживания (SLA) выберите Управление.
  4. Выберите требуемый SLA, а затем выберите параметр Установить по умолчанию из ленты.

Сценарий 2. Значение поля "Применимо из" ключевого показателя обслуживания равно NULL

Причина

Средство миграции может не задать ключевой показатель эффективности обслуживания, применимый к полю во время миграции в единый интерфейс. Или значение ключевого показателя эффективности обслуживания, применимое к полю "Из ", устанавливается настраиваемое поле, которое не задано для какого-либо значения.

Решение

Убедитесь, что значение ключевого показателя эффективности обслуживания, применимое к полю, не имеет значения NULL. Оно должно быть задано в некоторых значениях.

Сценарий 3. Условие соглашения об уровне обслуживания "Применимо, если" условия и условия сущности не соответствуют условиям соглашения об уровне обслуживания

Причина

Элемент соглашения об уровне обслуживания применим, если условия и условия сущности не соответствуют одному из следующих проблем:

  • Строковое значение не соответствует атрибутам.
  • В элементах SLA используются различные атрибуты с одинаковым именем.
  • Текстовое значение набора параметров совпадает, но GUID отличается.

Решение

Чтобы устранить эту проблему, проверьте применимость элемента соглашения об уровне обслуживания, если условия и условия сущности, чтобы убедиться, что указанные выше проблемы не будут возникать.

Сценарий 4. Невозможно обновить условие "Применимо" элемента SLA во время миграции из устаревшего интерфейса в единый интерфейс

Причина

После миграции соглашение об уровне обслуживания из устаревшего интерфейса в единый интерфейс может завершиться ошибкой, если условие для элемента SLA не удается заполнить.

Решение

Чтобы устранить эту проблему, убедитесь, что элемент SLA применим, если условие не пусто после миграции из устаревшего интерфейса в Унифицированный интерфейс.

Сценарий 5. Возникает ошибка "Шаги SdkMessageProcessing должны находиться в активном состоянии"

Причина

Действия SdkMessageProcessing могут находиться в неактивном состоянии.

Решение

Чтобы устранить эту проблему, активируйте следующие SdkMessageProcessing шаги, если они в черновике или неактивном состоянии.

  • PreOperationIncidentCreateEntitlement (6742a2a23a-7102-e711-8112-00155db32104)
  • PreOperationIncidentUpdateEntitlement (9e158ed-62ff-e611-810f-00155db32104)
  • PostOperationIncidentUpdateEntitlement (a468c44e-c204-e711-80ca-02155dc812c3)
  • PostOperationIncidentCreateEntitlement (8fbadfbe-c104-e711-80ca-02155dc812c3)

Чтобы выполнить поиск SdkMessageProcessing шагов, выполните следующие действия.

  1. Перейдите к настройкам.
  2. Выберите "Настройка действий по обработке сообщений пакета SDK для системы>".
  3. Выполните поиск описанных SdkMessageProcessing выше шагов.
  4. Нажмите кнопку "Активировать", если шаги находятся в деактивированном состоянии.

Сценарий 6. Параметр "Отключить соглашения об уровне обслуживания" в разделе "Параметры конфигурации службы" не задано значение "Нет"

Причина

Параметр "Отключить соглашения об уровне обслуживания" в параметрах конфигурации службы может иметь значение "Да".

Решение

Установите флажок "Отключить соглашения об уровне обслуживания" в параметрах конфигурации службы. Если для него задано значение "Да" для переключателя "Нет". Дополнительные сведения см. в разделе "Параметры конфигурации службы".

Сценарий 7. Возникает ошибка "Рабочий процесс должен находиться в состоянии публикации" или "Действие должно находиться в опубликованном состоянии".

Причина

Рабочий процесс может находиться в черновике или неактивном состоянии.

Решение

Чтобы устранить эту проблему, активируйте поток для элемента SLA, если он находится в неактивном состоянии. Дополнительные сведения о том, как активировать поток, см. в разделе "Современная ошибка недействительна для ExecuteWorkflow".

Сценарий 8. "Пустое расписание календаря". Проверка правильности задания рабочих часов", возникает ошибка

Причина

Эта проблема возникает из-за того, что рабочие часы элемента SLA связаны с календарем, настроенным для использования устаревшего интерфейса веб-клиента. В результате соглашение об уровне обслуживания не применяется к резервному условию "Применимо из " в едином интерфейсе. Необходимо проверить, настроены ли рабочие часы элемента обслуживания с помощью устаревшего веб-календаря клиента.

Решение

Чтобы устранить эту проблему, создайте календарь в едином интерфейсе и измените его в элементе SLA. Или откройте устаревший календарь в едином интерфейсе, а затем нажмите кнопку "Сохранить и закрыть". Дополнительные сведения см. в разделе "Настройка календаря".