Рабочий процесс, создающий большой объем системных заданий и журналов
В этой статье описывается решение проблемы, из-за чего асинхронный рабочий процесс создает большой объем системных заданий и журналов.
Применимо к: Microsoft Dynamics 365
Исходный номер базы знаний: 4562256
Симптомы
Асинхронный рабочий процесс быстро вызывается в течение короткого периода времени, создавая большой объем системных заданий. Это напрягает асинхронную службу, вызывая всплеск невыполненной работы, который ей необходимо обработать, что приводит к снижению производительности, что в конечном итоге влияет на все системные задания. Это также приводит к увеличению размера базы данных из-за большого количества асинхронных операций и связанных журналов рабочих процессов.
Причина
При активации и активации асинхронного рабочего процесса новые задания будут помещены в очередь microsoft Dynamics 365 асинхронной службой и обрабатываться на основе доступных ресурсов.
При определенных обстоятельствах асинхронный рабочий процесс может в конечном итоге вызываться несколько раз быстро, что приводит к созданию большого количества системных заданий за короткий период времени. Это происходит из-за массовой операции, которая активирует рабочий процесс агрессивно или ошибочно в каком-либо другом рабочем процессе и (или) подключаемом модуле, который вызывает его с высокой частотой.
Ресурсы, доступные асинхронной службе, ограничены, и если ее невыполненная работа заполняется таким запущенным рабочим процессом, снижение производительности, которое в целом влияет на все системные задания, является обычным явлением. Кроме того, из-за большого объема заданий, созданных в таком сценарии, размер базы данных также будет увеличиваться.
Разрешение
В таких случаях инфраструктура асинхронных рабочих процессов может в определенной степени самовосстановляться после отключения идентифицированного рабочего процесса. Ниже приведены шаги для этого.
- Перейдите в раздел Параметры>Процессы и выберите соответствующий рабочий процесс. Кроме того, можно найти рабочий процесс с помощью расширенного поиска.
- После выбора выберите Отключить , чтобы отключить и задать для рабочего процесса состояние Черновика . При необходимости можно также удалить рабочий процесс на этом этапе.
После выполнения описанных выше действий новые задания больше не будут создаваться. Кроме того, все задания, которые уже были созданы и помещены в асинхронную очередь до деактивации, но еще не были приняты для обработки , будут немедленно отменены при их получении для обработки. Это поможет ускорить очистку асинхронной невыполненной работы.
Остальные задания, которые уже находятся в процессе выполнения , останутся без изменений и будут завершены должным образом. Невыполненная работа будет постоянно стекать в течение определенного периода времени, чтобы восстановиться до номинального уровня.
Обратная связь
https://aka.ms/ContentUserFeedback.
Ожидается в ближайшее время: в течение 2024 года мы постепенно откажемся от GitHub Issues как механизма обратной связи для контента и заменим его новой системой обратной связи. Дополнительные сведения см. в разделеОтправить и просмотреть отзыв по