Примечание.
Для доступа к этой странице требуется авторизация. Вы можете попробовать войти или изменить каталоги.
Для доступа к этой странице требуется авторизация. Вы можете попробовать изменить каталоги.
В этой статье приводятся решения, соответствующие причинам возникновения ошибки инициализации при удалении или установке диспетчера интеграции в Microsoft Dynamics GP.
Область применения: Microsoft Dynamics GP
Исходный номер базы знаний: 861816
Симптомы
При удалении или установке Диспетчера интеграции при инициализации установки могут возникнуть следующие ошибки:
- Ошибка при извлечении файлов поддержки
- Ошибка при установке Ikernel.exe (0x с любым числом)
- Доступ запрещен
- Ошибка при загрузке библиотеки типов или DLL
Причина
Ошибки инициализации установки могут быть вызваны многими факторами. Это неисчерпающий список возможных причин:
- У вас нет достаточных разрешений на компьютере.
- Если вы только что запустили установку InstallShield, по окончании установки процесс длится несколько секунд, чтобы завершить очистку.
- Ikernel.exe находится в памяти.
- В папке temp есть дополнительные файлы.
- Существует папка Program Files\Common Files\InstallShield\Engine.
- Основные файлы Windows повреждены или отсутствуют.
- Отсутствует файл Stdole32.tlb.
- У вас недостаточно разрешений COM.
Решение
Чтобы устранить эту проблему, используйте метод, соответствующий причине проблемы.
У вас нет достаточных разрешений на компьютере.
Если вы используете компьютер на основе Microsoft Windows 2000, компьютер под управлением Windows XP или компьютер под управлением Windows 2003, необходимо иметь административные разрешения для запуска установки InstallShield Professional 6.x. Убедитесь, что у вас есть правильные разрешения.
Если вы только что запустили установку InstallShield, движку требуется несколько секунд в конце установки, чтобы завершить очистку.
В течение этого времени Ikernel.exe (файл ядра) выполняется в памяти из предыдущего процесса; поэтому вы не можете запустить другую настройку. Подождите несколько секунд, а затем снова запустите программу установки.
Ikernel.exe находится в памяти.
Убедитесь, что Ikernel.exe не в памяти. Если это так, и программа установки не выполняется на тот момент, завершите задачу.
В папке temp есть дополнительные файлы.
Очистка папки temp.
Существует папка Program Files\Common Files\InstallShield\Engine.
Удалите папку Program Files\Common Files\InstallShield\Engine, а затем снова запустите программу установки.
Основные файлы Windows повреждены или отсутствуют.
Переустановка Internet Explorer 6.x или более поздней версии восстановит множество поврежденных или отсутствующих основных файлов Windows с компьютера. Поэтому рекомендуется переустановить Internet Explorer 6.x или более позднюю версию и последнюю версию пакета обновления Windows.
Отсутствует файл Stdole32.tlb.
Это основной файл Windows и должен существовать на компьютере. Убедитесь, что у вас есть этот файл или получите этот файл с другого компьютера, работающего под управлением той же операционной системы, что и целевой компьютер.
У вас недостаточно разрешений COM.
Если вы получаете ошибку при установке Ikernel.exe, доступ запрещен , выполните следующие действия, чтобы предоставить вам необходимые разрешения:
- В окне командной строки введите dcomcnfg.exe. На этом шаге откроется диалоговое окно "Свойства распределенной конфигурации COM".
- Перейдите на вкладку "Безопасность по умолчанию".
- В разделе "Разрешения доступа по умолчанию" нажмите кнопку "Изменить значение по умолчанию ".
- Убедитесь, что "Разрешить доступ" отображается рядом с именем пользователя. Если параметр "Разрешить доступ" не отображается рядом с именем пользователя, измените существующий профиль. Или создайте новый профиль с необходимыми разрешениями.
- Примените все изменения и снова запустите программу установки.