Примечание
Для доступа к этой странице требуется авторизация. Вы можете попробовать войти или изменить каталоги.
Для доступа к этой странице требуется авторизация. Вы можете попробовать изменить каталоги.
Симптомы
Когда пользователи пытаются войти в приложение, использующее проверку подлинности Идентификатора Microsoft Entra, они получают следующее сообщение об ошибке:
AADSTS50173: The provided grant has expired due to it being revoked, a fresh auth token is needed. The user might have changed or reset their password. The grant was issued on '{authTime}' and the TokensValidFrom date (before which tokens are not valid) for this user is '{validDate}'.
Причина
Эта ошибка возникает, если маркер обновления, используемый для проверки подлинности, отозван. Эта проблема возникает, если:
- Пользователь изменяет или сбрасывает пароль.
- Срок действия маркера обновления истекает.
- Администратор отменяет маркер обновления.
Дополнительные сведения см. в разделе:
- Обновление маркеров в платформа удостоверений Майкрософт
- Отмена доступа пользователей в идентификаторе Microsoft Entra
Решение
Чтобы устранить эту проблему, выполните применимые действия.
Для пользователей
В приложении, которое испытывает проблемы, попробуйте найти параметр для повторной проверки подлинности или очистки всех кэшированных сведений маркера. Вы также можете выполнить эти действия, выйдя и войдите в приложение (если этот шаг применим или доступен).
Для разработчиков приложений
Если приложение использует библиотеку проверки подлинности Майкрософт (MSAL), следуйте инструкциям по обработке ошибок и исключений в MSAL.
Если приложение не использует MSAL, выполните это руководство для обработки ошибок и исключений в MSAL и попробуйте реализовать аналогичный подход к приложению. Цель состоит в том, чтобы запросить повторную проверку подлинности пользователя и получить новый маркер.
Дополнительная информация
Полный список кодов ошибок проверки подлинности и авторизации см. в кодах ошибок проверки подлинности и авторизации Microsoft Entra.
Чтобы исследовать отдельные ошибки, перейдите к разделу https://login.microsoftonline.com/error.
Свяжитесь с нами для получения помощи
Если у вас есть вопросы или вам нужна помощь, создайте запрос в службу поддержки или обратитесь за поддержкой сообщества Azure. Вы также можете отправить отзыв о продукте в сообщество отзывов Azure.