Ошибка 80072f8f при отправке с winhttp в Smsts.log во время развертывания ОС с использованием загрузочного или предварительно подготовленного носителя
Эта статья поможет устранить проблему, из-за которой мастер последовательности задач возвращает ошибку 80004005 и Smsts.log регистрирует ошибку Отправки с winhttp; ошибка 80072f8f во время развертывания ОС, которая использует загрузочный или предварительно подготовленный носитель.
Исходная версия продукта: Configuration Manager (current branch), Microsoft System Center 2012 R2 Configuration Manager, Microsoft System Center 2012 Configuration Manager
Исходный номер базы знаний: 4551033
Симптомы
Вы создаете загрузочный носитель или предварительно подготовленный носитель в Configuration Manager. Когда носитель используется для запуска целевого компьютера, мастер последовательности задач зависает на политике извлечения для этого шага компьютера около 90 секунд, а затем возвращает следующее сообщение об ошибке:
Не удалось запустить последовательность задач
Ошибка при получении политики для этого компьютера (0x80004005). За дополнительными сведениями обратитесь к системному администратору или оператору службы технической поддержки.
Следующие сообщения об ошибках регистрируются в X:\Windows\Temp\SMSTSLog\smsts.log на компьютере, когда подсистема последовательности задач сначала пытается связаться с точкой управления для синхронизации сведений о времени:
TSMBootstrap Сведения о текущем времени:
TSMBootstrap Получение сведений о времени mp
TSMBootstrap запрашивает удостоверение клиента
TSMBootstrap — настройка средства проверки подлинности.
TSMBootstrap CLibSMSMessageWinHttpTransport::Send: WinHttpOpenRequest - URL-адрес: <MP>:443 CCM_POST /ccm_system_AltAuth/request
TSMBootstrap SSL, использующий средство проверки подлинности в запросе.
TSMBootstrap в SSL, но без сертификата клиента.
TSMBootstrap [TSMESSAGING] AsyncCallback():
-----------------------------------------------------------------
TSMBootstrap [TSMESSAGING] AsyncCallback(): WINHTTP_CALLBACK_STATUS_SECURE_FAILURE Обнаружено
TSMBootstrap [TSMESSAGING] : dwStatusInformationLength равно 4
TSMBootstrap [TSMESSAGING] : *lpvStatusInformation is 0x8
TSMBootstrap [TSMESSAGING]: WINHTTP_CALLBACK_STATUS_FLAG_INVALID_CA задано
TSMBootstrap [TSMESSAGING] AsyncCallback():
-----------------------------------------------------------------
Ошибка TSMBootstrap. Получено 0x80072f8f от WinHttpSendRequest.
Сбой отправки TSMBootstrap с winhttp; 80072f8f. Повтор.
TSMBootstrap Повторная попытка и игнорирование ошибок безопасности даты.
TSMBootstrap [TSMESSAGING] AsyncCallback():
-----------------------------------------------------------------
TSMBootstrap [TSMESSAGING] AsyncCallback(): WINHTTP_CALLBACK_STATUS_SECURE_FAILURE Обнаружено
TSMBootstrap [TSMESSAGING] : dwStatusInformationLength равно 4
TSMBootstrap [TSMESSAGING] : *lpvStatusInformation is 0x8
TSMBootstrap [TSMESSAGING]: WINHTTP_CALLBACK_STATUS_FLAG_INVALID_CA задано
TSMBootstrap [TSMESSAGING] AsyncCallback():
-----------------------------------------------------------------
TSMBootstrap hr, HRESULT=80072f8f
Сбой отправки TSMBootstrap с winhttp; 80072f8f
После первоначальной ошибки подсистема последовательности задач пытается еще четыре раза связаться с точкой управления и испытывает растущую паузу между каждой попыткой. Однако все попытки завершаются сбоем и возвращают одни и те же сообщения об ошибках, прежде чем будут возвращены последние сообщения об ошибках, как показано ниже.
Если носитель настроен как динамический, в Smsts.log регистрируются следующие окончательные сообщения об ошибках:
TSMBootstrap Send (pReply, nReplySize), HRESULT=80072f8f
TSMBootstrap не удалось отправить запрос
TSMBootstrap DoRequest (sReply, true), HRESULT=80072f8f
TSMBootstrap не удалось получить удостоверение клиента (80072f8f)
TSMBootstrap ClientIdentity.RequestClientIdentity (), HRESULT=80072f8f
TSMBootstrap не удалось запросить клиент
Сбой TSMBootstrap SyncTimeWithMP(). 80072f8f.
TSMBootstrap не удалось получить сведения о времени из MP:https://<MP>
.
TSMBootstrap MpCnt > 0, HRESULT=80004005
TSMBootstrap QueryMPLocator: допустимые расположения mp не получены
TSMBootstrap TSMBootstrapUtil::QueryMPLocator ( true, sSMSTSLocationMPs.c_str(), sMediaPfx.c_str(), sMediaGuid.c_str(), sAuthenticator.c_str(), sEnterpriseCert.c_str(), sServerCerts.c_str(), nHttpPort, nHttpsPort, bUseCRL, m_bWinPE, httpS, http, accessibleMpCnt), HRESULT=80004005
TSMBootstrap не удалось запросить указатель точки управления
TSMBootstrap выходит из TSMediaWizardControl::GetPolicy.
TSMBootstrap pWelcomePage-m_pTSMediaWizardControl-GetPolicy>>(), HRESULT=80004005
Ошибка мастера настройки TSMBootstrap: произошла ошибка при получении политики для этого компьютера (0x80004005). За дополнительными сведениями обратитесь к системному администратору или оператору службы технической поддержки.Если носитель настроен как на основе сайта, в Smsts.log регистрируются следующие окончательные сообщения об ошибках:
TSMBootstrap Send (pReply, nReplySize), HRESULT=80072f8f
TSMBootstrap не удалось отправить запрос
TSMBootstrap DoRequest (sReply, true), HRESULT=80072f8f
TSMBootstrap не удалось получить удостоверение клиента (80072f8f)
TSMBootstrap ClientIdentity.RequestClientIdentity (), HRESULT=80072f8f
TSMBootstrap не удалось запросить клиент
Сбой TSMBootstrap SyncTimeWithMP(). 80072f8f.
TSMBootstrap не удалось получить сведения о времени из MP:https://<MP>
.
TSMBootstrap sMP.length() > 0, HRESULT=80004005
TSMBootstrap TSMBootstrapUtil::SelectMP ( sSMSTSMP.c_str(), sMediaPfx.c_str(), sMediaGuid.c_str(), sAuthenticator.c_str(), sEnterpriseCert.c_str(), sServerCerts.c_str(), nHttpPort, nHttpsPort, bUseCRL, m_bWinPE, sSiteCode, sAssignedSiteCode, sMP, sCertificates, sX86UnknownMachineGUID, sX64UnknownMachineGUID), HRESULT=80004005
TSMBootstrap Не удалось выбрать MP
TSMBootstrap выходит из TSMediaWizardControl::GetPolicy.
TSMBootstrap pWelcomePage-m_pTSMediaWizardControl-GetPolicy>>(), HRESULT=80004005
Ошибка мастера настройки TSMBootstrap: произошла ошибка при получении политики для этого компьютера (0x80004005). За дополнительными сведениями обратитесь к системному администратору или оператору службы технической поддержки.
К ошибке 80072F8F относятся следующие подробные сведения:
Код ошибки: 0x80072F8F (2147954575)
Имя ошибки: WININET_E_DECODING_FAILED
Источник ошибки: Windows
Сообщение об ошибке: не удалось декодировать содержимое
Причина
Эта проблема возникает, если выполняются следующие условия:
- PKI используется в среде Configuration Manager.
- Вы создаете загрузочный носитель или предварительно подготовленный носитель на сайте центра администрирования.
- Вы настраиваете точки управления для использования ПРОТОКОЛА HTTPS.
Если вы используете PKI в среде Configuration Manager, корневой центр сертификации (ЦС) указывается на первичном сайте, но не на сайте центра администрирования. Так как на сайте центра администрирования нет сведений о корневом ЦС, созданный носитель не содержит сведения о корневом ЦС. Таким образом, запросы, отправляемые в точку управления с поддержкой HTTPS, завершаются сбоем без сведений о корневом ЦС.
Разрешение
Чтобы устранить эту проблему, создайте загрузочный носитель или предварительно подготовленный носитель на первичном сайте, а не на сайте центра администрирования.
Дополнительная информация
Для мультимедиа, который будет использоваться на нескольких сайтах, настройте его как динамический. Динамический носитель можно создать на любом сайте. Вы не ограничиваетесь созданием на сайте центра администрирования.