Примечание
Для доступа к этой странице требуется авторизация. Вы можете попробовать войти или изменить каталоги.
Для доступа к этой странице требуется авторизация. Вы можете попробовать изменить каталоги.
В этой статье описано решение об ошибке, возникающей при тестировании и включении почтового ящика в Microsoft Dynamics 365.
Область применения: Microsoft Dynamics 365
Исходный номер базы знаний: 4092736
Симптомы
При попытке проверить и включить почтовый ящик в Dynamics 365 вы получите следующее сообщение об ошибке:
При получении электронной почты произошла общая ошибка доступа к почтовому ящику. Почтовый ящик <имя_почтового_ящика> не синхронизировался. Владелец связанного профиля <> сервера электронной почты был уведомлен.
Код ошибки сервера электронной почты: сокет возвращает исключение TimedOut.
Если выбрать раздел "Сведения" , вы также можете увидеть дополнительные сведения, похожие на следующий текст:
Ошибка: System.Net.Sockets.SocketException (0x80004005): попытка подключения завершилась ошибкой, так как подключенная сторона не ответила должным образом через определенный период времени или не удалось установить подключение, так как подключенный узел не ответил <на порт IP-адресов><.>
at System.Net.Sockets.TcpClient.Connect(String hostname, int32 port)
в Microsoft.Crm.Асинхронный.EmailConnector.Pop3Client.Connect()
Причина
Эта ошибка может возникать, если значения портов в разделе "Дополнительно " профиля сервера электронной почты не верны.
Решение
Войдите в веб-приложение Dynamics 365 в качестве пользователя с ролью "Системный администратор".
Перейдите в раздел "Настройка электронной почты" и выберите "Профили сервера электронной почты>".
Откройте профиль сервера электронной почты, используемый почтовым ящиком, который получил ошибку.
Примечание.
Вы также можете выбрать имя профиля сервера электронной почты в сообщении об ошибке. Он отображается как гиперссылка, которая откроет правильную запись профиля сервера электронной почты.
Выберите Дополнительно.
Убедитесь, что значения входящих портов и исходящих портов верны в соответствии с документацией поставщика электронной почты, а затем нажмите кнопку "Сохранить".
Примечание.
Например, для Gmail входящий порт POP3 равен 995, а исходящий SMTP-порт — 587.
Выберите почтовые ящики и выберите почтовый ящик, который получил ошибку.
Нажмите кнопку "Тест и включить почтовые ящики ".
После завершения теста убедитесь, что результаты отображаются как успешные. В противном случае просмотрите раздел "Оповещения" записи почтового ящика для любых оповещений.
Заявление об отказе от ответственности за сведения о продуктах сторонних производителей
В этой статье упомянуты программные продукты независимых производителей. Корпорация Майкрософт не дает никаких гарантий, подразумеваемых и прочих, относительно производительности и надежности этих продуктов.