Поделиться через


Сводный отчет по отслеживанию уровня обслуживания может быть пустым, если для даты to date не выбрано значение "Сегодня"

Эта статья поможет устранить проблему, из-за которой отчет "Сводка по отслеживанию уровней обслуживания" в Operations Manager пуст, если вы не выбрали "Сегодня" в качестве даты.

Исходная версия продукта: System Center Operations Manager
Исходный номер базы знаний: 2567404

Симптомы

Если вы запускаете сводный отчет по отслеживанию уровней обслуживания в System Center Operations Manager и выбираете дату, отличную от текущей, она может быть пустой в зависимости от выбранной цели уровня обслуживания (SLO) и /или выбранной даты.

Причина

SLO, определенные в консоли Operations Manager, хранятся в указанном пакете управления. При изменении этого пакета управления он создаст новый выпуск пакета управления и вставляет новую запись в базу данных хранилища данных, чтобы пометить метку времени при установке этого пакета управления. При запуске отчета об отслеживании уровня обслуживания он проверяет наличие соответствующей записи пакета управления в течение указанного периода времени. Эта проверка используется для обеспечения того, чтобы все SLO были определены в соответствующей группе управления в течение отчетного периода. Это означает, что даже если пакет управления был создан давным-давно, если вы вносите изменения в объекты, содержащиеся в этом пакете управления, это изменит дату установки пакета управления. Если дата установки пакета управления выходит за пределы указанного периода времени в сводном отчете уровня обслуживания, отчет будет пустым.

Решение

Это связано с сохранением пакетов управления в хранилище данных. По умолчанию запечатанные пакеты управления хранятся в течение 400 дней после их удаления и незапечатанных пакетов управления до 400 дней, но вы также сохраняете только последние три версии каждого неуправляемого пакета управления. Если неуправляемый пакет управления содержит множество объектов (в данном случае SLO) и вы их довольно часто изменяете, скорее всего, вы можете попасть в эти ситуации. Можно рассмотреть возможность выполнения одной или всех следующих действий:

  • Пакеты управления печатью, в которых хранится slOs.

  • Храните SLO отдельно (в отдельных пакетах управления).

  • Увеличьте количество версий хранилища данных запечатанных пакетов управления. Для этого выполните следующий SQL-запрос в базе данных хранилища данных (по умолчанию ):OperationsManagerDW

    UPDATE [MaintenanceSetting] SET [NonSealedManagementPackMaxVersionCount] = 8
    

    Примечание.

    8 — это просто пример числа. Не устанавливайте слишком большое число. Мы советуем настроить это на большее число, чем 10. Вы должны попробовать меньшее число, пока оно не будет соответствовать вашей среде.