Поделиться через


Обновл. Windows зависания и новые обновления удаляются после перезагрузки

В этой статье описано решение проблемы, из-за которой после перезагрузки системы Обновл. Windows зависает и только что установленные обновления удаляются.

Исходный номер базы знаний: 3064434

Симптомы

Рассмотрим следующий сценарий:

  • У вас есть компьютер под управлением Windows.
  • Вы устанавливаете обновления из Обновл. Windows.
  • При появлении запроса перезапустите Windows.

В этом сценарии во время перезапуска отображается следующее сообщение:

Работа с обновлениями
13 % завершения
Не отключайте компьютер

Это ожидаемое сообщение. Однако система, как представляется, перестает отвечать (зависает) около 15 минут. После этого система перезапускается. Однако установленные обновления теперь удаляются.

Кроме того, запись, похожая на следующую, может быть записана в файл CBS.log в папке %SystemRoot%\Logs\CBS:

Shtd: время ожидания завершения обработки завершения работы — в последних 90000 миллисекундах не обнаружено хода выполнения.

Причина

Эта проблема возникает из-за того, что служба доверенного установщика не завершила процесс установки в течение 15 минут по умолчанию.

Обходное решение

Чтобы обойти эту проблему, задайте значение времени ожидания для большего значения в реестре, а затем повторно примените исправление. Для этого выполните следующие шаги.

  1. Откройте редактор реестра.

  2. Найдите следующий подраздел.
    HKLM\System\CurrentControlSet\Services\TrustedInstaller

  3. Щелкните правой кнопкой мыши ключ TrustedInstaller и выберите пункт "Разрешения".

  4. Предоставьте пользователю полный доступ к группе "Администраторы".

  5. Измените значение BlockTimeIncrement на 2a30 (шестнадцатеричное).

    Примечание.

    Это изменение задает значение времени ожидания в три часа. Это должно быть достаточно для большинства ситуаций. Однако может потребоваться попробовать большее значение в вашей среде.

  6. Перезапустите сервер, а затем снова примените исправление.

Состояние

Данное поведение является подтвержденной ошибкой продуктов Майкрософт, перечисленных в разделе «Применимо к».

Сбор данных

Если вам нужна помощь службы поддержки Microsoft, мы рекомендуем собирать информацию путем выполнения действий, описанных в разделе Сбор информации с помощью TSS для решения проблем, связанных с развертыванием.