Примечание
Для доступа к этой странице требуется авторизация. Вы можете попробовать войти или изменить каталоги.
Для доступа к этой странице требуется авторизация. Вы можете попробовать изменить каталоги.
В этой статье описывается решение проблемы, из-за которой репликация не завершена при репликации изменений службы Active Directory в контроллер домена.
Исходный номер базы знаний: 830746
Симптомы
При попытке репликации изменений службы Active Directory в поддерживаемую версию контроллера домена репликация не завершена.
В журнале событий могут отображаться события, аналогичные следующим:
Источник событий | ИД события | Строка события |
---|---|---|
Репликация NTDS | 1232 | Active Directory попыталась выполнить удаленный вызов процедуры (RPC) на следующем сервере. Время ожидания звонка истекло и было отменено. |
Репликация NTDS | 1188 | Поток в Active Directory ожидает завершения RPC, выполненного на следующий контроллер домена. Контроллер домена: b8b5a0e4-92d5-4a88-a601-61971d7033af._msdcs. Contoso.com Операция: получение изменений Идентификатор потока: 448 Период ожидания (минуты): 5 Active Directory попыталась отменить вызов и восстановить этот поток. Действие пользователя Если это условие продолжается, перезапустите контроллер домена. |
Репликация NTDS | 1173 с состоянием ошибки 1818 | Внутреннее событие: Active Directory обнаружил следующее исключение и связанные параметры. Исключение: e0010002 Параметр: 0 Дополнительное значение ошибки данных: 1818 Внутренний идентификатор: 5000ede |
Репликация NTDS | 1085 с состоянием ошибки 1818 | Внутреннее событие: Active Directory не удалось синхронизировать следующий раздел каталога с контроллером домена по следующему сетевому адресу. Раздел каталога: <NC> Сетевой адрес: <имя контроллера домена на основе GUID> Если эта ошибка продолжается, средство проверки согласованности знаний (KCC) перенастроит ссылки репликации и обойдет контроллер домена. Действие пользователя Убедитесь, что сетевой адрес можно разрешить с помощью DNS-запроса. Дополнительное значение ошибки данных: 1818 Удаленный вызов процедуры был отменен. |
В этой ситуации также отображается ошибка 1818 в выходных данных repadmin /showrepl
команды и выходных данных repadmin /showreps
команды:
DC=Contoso,DC=com
<Sitename>\<DCname> via RPC DC
DC object GUID: <GUID> Last attempt @ <DateTime> failed, result 1818 (0x71a): Can't retrieve message string 1818
(0x71a), error 1815. 823 consecutive failure(s). Last success @ (never).
Причина
Эта проблема может возникать, если контроллеры домена назначения, выполняющие удаленный вызов процедур (RPC), не получают изменения репликации от исходного контроллера домена в течение RPC Replication Timeout (mins)
указанного параметра реестра (значение по умолчанию составляет пять минут, если запись реестра не существует). Эта проблема чаще всего возникает в одной из следующих ситуаций:
- Вы повышаете уровень нового контроллера домена в лесу с помощью мастера настройки служб домен Active Directory из диспетчер сервера консоль управления или с помощью командлета
Install-ADDSDomainController
. - Существующие контроллеры домена реплицируются из исходных контроллеров домена, подключенных через медленные сетевые каналы.
Примечание.
- Имя значения реестра:
RPC Replication Timeout (mins)
- Расположение значения реестра:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters
- Тип значения реестра:
REG_DWORD
Значение по умолчанию для параметра реестра времени ожидания репликации RPC (mins) в поддерживаемых операционных системах составляет пять минут. Если контроллер домена назначения, выполняющий репликацию на основе RPC, не получает запрошенный пакет репликации в течение указанного параметра реестра времени ожидания репликации RPC (mins), контроллер домена назначения завершает подключение RPC с контроллером домена неответственного исходного домена и регистрирует предупреждение.
Решение
Чтобы устранить эту проблему, увеличьте пропускную способность сетевого подключения, чтобы изменения Active Directory реплицировались в течение пяти минут времени ожидания.
Сбор данных
Если вам нужна помощь от службы поддержки Майкрософт, мы рекомендуем собрать информацию, выполнив действия, описанные в разделе "Сбор сведений" с помощью TSS для проблем с репликацией Active Directory.