Примечание
Для доступа к этой странице требуется авторизация. Вы можете попробовать войти или изменить каталоги.
Для доступа к этой странице требуется авторизация. Вы можете попробовать изменить каталоги.
В этой статье описано решение проблем, возникающих при настройке профилей пользователей по умолчанию.
Область применения: Windows 10 — все выпуски, Windows Server 2019, Windows Server 2016
Исходный номер базы знаний: 4056823
Симптом
Рассмотрим следующий сценарий.
- Вы создадите профиль пользователя по умолчанию и включите его.
- Новый пользователь входит в систему с помощью профиля, созданного из профиля по умолчанию на компьютере под управлением Windows 10, Windows Server 2016 или Windows Server 2019.
В этом сценарии возникает одна или несколько следующих проблем:
Значки рабочего стола занимают много времени.
Производительность низка при запуске или просмотре в Internet Explorer или Microsoft Edge.
Ошибки ESENT, как показано ниже, записываются в журнал событий:
EventLogID: 454
TaskHostW: (pid)
WebCacheLocal: "Восстановление базы данных и восстановление завершилось с неожиданной ошибкой -1907"Примечание.
Полное сообщение журнала событий также может указывать на связь с другим расположением папки пользователя, например C:\Users\Administrator.
Причина
Эти проблемы возникают, так как профиль пользователя по умолчанию включает заблокированную копию базы данных кэша другого пользователя.
При входе нового пользователя на компьютер содержимое профиля пользователя по умолчанию включается в новый профиль. По мере загрузки оболочки Windows и рабочего стола база данных не может быть полностью инициализирована для использования. Приложения, использующие базу данных, испытывают отрицательные показатели производительности или сообщают об ошибках.
Разрешение
Чтобы устранить проблему, выполните следующие действия.
Войдите на каждый затронутый компьютер с помощью учетной записи с учетными данными администратора, а затем удалите следующий скрытый файл и папку, если они существуют:
Файл: C:\Users\Default\AppData\Local\Microsoft\Windows\WebCacheLock.dat
Папка: C:\Users\Default\AppData\Local\Microsoft\Windows\WebCacheДля каждой учетной записи пользователя на компьютере убедитесь, что пользователь полностью выгружается и профиль выгрузил полностью, а затем удалите следующий скрытый файл и папку, если они существуют:
Файл: C:\Users\<affectedUserFolder>\AppData\Local\Microsoft\Windows\WebCacheLock.dat
Папка: C:\Users\<affectedUserFolder>\AppData\Local\Microsoft\Windows\WebCache
Примечание.
<affectedUserFolder> — это заполнитель для имени папки профиля пользователя. Например, для учетной записи администратора папка находится в папке C:\Users\Administrator. Необходимо удалить указанные выше файлы и папки для каждой затронутой учетной записи пользователя на компьютере.
Просмотр скрытых файлов
Чтобы просмотреть скрытые файлы, выполните следующие действия.
- В проводнике Windows выберите "Файл" и выберите " Параметры".
- На вкладке "Вид" выберите параметр "Показать скрытые файлы, папки и диски".
- Отмените флажок "Скрыть защищенные файлы операционной системы ( рекомендуется) и нажмите кнопку "ОК".
Примечание.
Рекомендуется повторно выбрать два варианта после устранения проблемы.
Дополнительные сведения
Так как база данных кэша предназначена для создания на пользователя во время первоначального входа на отдельный компьютер, корпорация Майкрософт не рекомендует или поддерживает включение базы данных кэша в базу данных кэша по умолчанию или любой другой профиль пользователя, который предназначен для использования в качестве шаблона.