Вы не можете просмотреть роли и компоненты и получить код ошибки 0x800706BE в диспетчер сервера

В этой статье описывается решение проблемы, из-за чего не удается просмотреть роли и компоненты и получить код ошибки 0x800706BE в диспетчер сервера.

Применяется к: Windows Server 2012 R2
Исходный номер базы знаний: 2461206

Симптомы

Рассмотрим следующий сценарий.

  1. У вас есть компьютер под управлением Windows Server 2008 или Windows Server 2008 R2.
  2. Откройте окно диспетчер сервера для просмотра, добавления и удаления ролей и компонентов.

В этом сценарии роли и компоненты не отображаются с желтым ударом по ним в окне диспетчер сервера. При попытке открыть его в нижней части диспетчер сервера появляется следующее сообщение об ошибке:

Диспетчер серверов
Непредвиденная ошибка при обновлении диспетчер сервера: сбой удаленного вызова процедуры. (Исключение из HRESULT: 0x800706BE)
Дополнительные сведения см. в журнале событий: Диагностика, Просмотр событий, Журналы приложений и служб, Microsoft, Windows, диспетчер сервера, Operational.)

В то же время в журнал Microsoft-Windows-ServerManager/Operational добавляется следующее событие:

Имя журнала: Microsoft-Windows-ServerManager/Operational
Источник: Microsoft-Windows-ServerManager
Дата: <время & даты>
Идентификатор события: 1601
Категория задачи: Нет
Уровень: ошибка
Ключевые слова:
Пользователь: <имя пользователя>
Компьютер: <имя компьютера>
Описание:
Не удалось обнаружить состояние системы. Обнаружено непредвиденное исключение:
System.Runtime.InteropServices.COMException (0x800706BE): сбой удаленного вызова процедуры. (Исключение из HRESULT: 0x800706BE)
в System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
в Microsoft.Windows.ServerManager.ComponentInstaller.CreateSessionAndPackage(IntPtr& сеанс, IntPtr& пакет)
в Microsoft.Windows.ServerManager.ComponentInstaller.InitializeUpdateInfo()
в Microsoft.Windows.ServerManager.ComponentInstaller.Initialize()
в Microsoft.Windows.ServerManager.Common.Provider.RefreshDiscovery()
в Microsoft.Windows.ServerManager.LocalResult.PerformDiscovery()
в Microsoft.Windows.ServerManager.ServerManagerModel.CreateLocalResult(RefreshType refreshType)
в Microsoft.Windows.ServerManager.ServerManagerModel.InternalRefreshModelResult(Состояние объекта)

Причина

Некоторые файлы каталога, файлы манифестов или MUM-файлы повреждены на компьютере.

Разрешение

Ниже приведены действия по устранению проблемы.

  1. Получите средство проверки готовности к обновлению Майкрософт из расположения: https://support.microsoft.com/kb/947821.

  2. Запустите средство проверки готовности к обновлению Майкрософт на проблемном компьютере.

  3. После завершения проверки откройте файл %Systemroot%\Windows\logs\CBS\Checksur.log.

  4. Вы проверка поврежденные сведения в файлах. Ниже приведены некоторые примеры.

    (f) CBS MUM Повреждено 0x00000000 обслуживание\Packages\Package_for_KB978601~31bf3856ad364e35~amd64~6.0.1.0.mum Ожидаемое имя файла Package_for_KB978601_server~31bf3856ad364e35~amd64~~6.0.1.0.mum не соответствует фактическому имени файла
    (f) CBS MUM Повреждено 0x00000000 обслуживания\Packages\Package_for_KB979309~31bf3856ad364e35~amd64~6.0.1.0.mum Ожидаемое имя файла Package_for_KB979309_server~31bf3856ad364e35~amd64~~6.0.1.0.mum не соответствует фактическому имени файла

    Или

    (f) CBS MUM Повреждено обслуживание 0x800B0100\Packages\Package_for_KB978601~31bf3856ad364e35~amd64~~6.0.1.0.mum servicing\Packages\Package_for_KB978601~31bf3856ad364e35~amd64~~6.0.1.0.cat Манифест пакета не может быть проверен соответствующим каталогом (f) CBS MUM Повреждена 0x800B0100 обслуживание\Packages\Package_for_KB979309~31bf3856ad364e35~amd64~~6.0.1.0.0.0. mum servicing\Packages\Package_for_KB979309~31bf3856ad364e35~amd64~~6.0.1.0.cat Манифест пакета не может быть проверен с помощью соответствующий каталог

    Или

    (f) CBS MUM Отсутствует 0x00000002 обслуживание\packages\Package_114_for_KB955839~31bf3856ad364e35~amd64~~6.0.1.0.mum (f) CBS MUM Отсутствует 0x00000002 servicing\packages\Package_83_for_KB955839~31bf3856ad364e35~amd64~~6.0.1.0.mum

    Далее вы увидите:

    Недоступные файлы восстановления:
    servicing\packages\Package_for_KB978601~31bf3856ad364e35~amd64~~6.0.1.0.mum
    servicing\packages\Package_for_KB979309~31bf3856ad364e35~amd64~~6.0.1.0.mum
    servicing\packages\Package_for_KB978601~31bf3856ad364e35~amd64~~6.0.1.0.cat
    servicing\packages\Package_for_KB979309~31bf3856ad364e35~amd64~~6.0.1.0.cat

Скопируйте эти файлы в папку %systemroot\Windows\Servicing\Packages.

  1. Сначала необходимо получить контроль над этой папкой. Для этого используйте следующие команды:

    takeown /F c:\Windows\Servicing\Packages /D y /R
    
  2. Теперь назначьте полный доступ с помощью следующей команды. Он предоставит вам полный контроль над каталогом:

    cacls c:\Windows\Servicing\Packages /E /T /C /G "UserName": F
    
  3. Теперь необходимо собрать отсутствующие или поврежденные файлы из checksur журнала: скачайте файлы базы знаний для отсутствующих файлов.

    servicing\packages\Package_for_ KB978601 ~31bf3856ad364e35~amd64~~6.0.1.0.mum

  4. Распакуйте их с помощью следующей команды:

    Expand -F:\* UpdateKBXXXX.msu x:\DestinationDirectory
    
  5. После развертывания вы увидите файл UpdateKBXXXX.cab. Также разверните его:

    Expand -F:\* UpdateKBXXXX.CAB x:\DestinationDirectoryCAB
    

    Внутри этой кабины вам нужно будет захватить два файла: update.mum и update.cat.

  6. Переименуйте собранные файлы update.mum и update.cab точно так, как в checksur.log:

    Например: update.mum для KB978601 будет Package_for_ KB978601 ~31bf3856ad364e35~amd64~~6.0.1.0.mum
    Выполните то же самое для всех остальных отсутствующих или поврежденных файлов и поместите их в каталог, указанный в checksur.log (/servicing/packages).

После выполнения этих действий проблема должна быть устранена, перезагрузка не требуется.

Примечание.

Если диспетчер сервера не работает даже после выполнения этих действий, снова запустите средство проверки готовности к обновлению и дважды проверка описанные выше действия.