Ошибка возникает во время установки рабочего стола, а расположение рабочего стола недоступно при первом входе в Windows

Эта статья поможет устранить проблему, из-за которой загрузка профиля завершается сбоем, если файл ntuser.dat или usrclass.dat определен как доступный только для чтения или пользователь профиля не имеет соответствующих разрешений для этих двух DAT-файлов.

Область действия: Windows 10 — все выпуски, Windows Server 2012 R2
Исходный номер базы знаний: 3048895

Симптомы

После установки обновления в службе "Уязвимость" в службе профилей пользователей Windows может быть разрешено повышение привилегий : 13 января 2015 г. (MS15-003) вы можете устранить следующие проблемы:

  • Профили не загружаются при первом входе пользователей на компьютер. Кроме того, вы можете войти на компьютер, где политика удаляет кэшированный профиль после интервала даты при выключении.

    Примечание.

    Входы, использующие обязательные профили пользователей или инфраструктура виртуальных рабочих столов (VDI), также могут быть затронуты.

  • Профили не загружаются при входе пользователей с помощью кэшированных профилей пользователей.

  • Службы не запускаются из-за сбоев загрузки профиля. Затронутые службы включают в себя, но не ограничиваются следующими:

    • Локальная служба
    • Сетевая служба
    • MSSQL

При возникновении этой проблемы регистрируются связанные события. Просмотрите события, которые были зарегистрированы в Просмотр событий.

Монитор процессов может указывать, что операция CreateFile завершается сбоем с результатом ACCESS DENIED по следующему пути в зависимости от ограничения доступа к файлам: <drive>:\documents & settings\<username>\local settings\Application Data\Microsoft\Windows\UsrClasss.dat.

Снимок экрана монитора процессов можно увидеть здесь:

Монитор процессов указывает, что операция CreateFile завершается сбоем с результатом ACCESS DENIED.

См . сведения о сбое, отображаемом в мониторе процессов.

Причина

Обновление 3021674 добавляет проверки доступа к файлам Ntuser.dat и Usrclass.dat.

Решение

Чтобы устранить эту проблему, выполните следующие действия.

  1. Проверьте, установлен ли флаг READ ONLY в NTUSER. DAT или USERCLASS. DAT-файл для профиля, который не удается загрузить.

    Новые профили пользователей являются производными от C:\users\default\ во время первого входа в учетную запись. Если профили не загружаются с сигнатурами, которые соответствуют тем, которые описаны в разделе "Симптомы", проверьте, включен ли Read-Only бит в NTUSER. DAT и USRCLASS. Файлы DAT в каталоге профиля для указанных пользователей или учетных записей служб.

    NTUSER. DAT в Windows Vista и более поздних версиях Windows находится в папке C:\users\default\ntuser.dat. Более ранние операционные системы имеют другие пути, такие как C:\Documents и Settings\<username>\ntuser.dat.

    The USRCLASS. DAT-файл обычно расположен по пути, например C:\Documents and Settings<user_name>\Local Settings\Application Data\Microsoft\Windows\UsrClass.dat или C:\Users<user_name>\AppData\Local\Microsoft\Windows.

    В проводнике Windows щелкните правой кнопкой мыши NTUSER. Файл DAT или USRCLASS для соответствующего профиля пользователя или кэшированного пользователя по умолчанию. Флажок только для чтения должен быть снят. Если этот флажок установлен, это приведет к сбоям загрузки профиля.

    Убедитесь, что параметр только для чтения не выбран в NTUSER. Свойства DAT.

  2. Проверьте параметр разрешений файловой системы NTFS в NTUSER. DAT или USERCLASS. DAT-файл в кэшированном каталоге профиля, который не удается загрузить.

На следующем снимке экрана тестовый пользователь CONTOSO/testUser имеет полный контроль над NTUSER. DAT (не отображается) и USRCLASS.DAT. Все пользователи не указаны в группе редактора ACL.

ACLS файловой системы NTFS для файлов DAT Расширенные ACLS файловой системы NTFS для DAT-файлов
Разрешение тестового пользователя, которое отображается на вкладке
Разрешение тестового пользователя, которое отображается в разделе

Состояние

Данное поведение является подтвержденной ошибкой продуктов Майкрософт, перечисленных в разделе «Применимо к».

Дополнительные сведения

События, зарегистрированные в Просмотр событий

Имя журнала Отправитель событий Идентификатор события Текст сообщения о событии
Application Служба профилей пользователей Microsoft-Windows 1542 Windows не может загрузить файл реестра классов.
DETAIL — неуказанная ошибка
Die Klassenregistrierungsdatei kann nicht geladen werden.
DETAIL — Unbekannter Fehler
Application Диспетчер управления службами 7005 Сбой вызова LoadUserProfile со следующей ошибкой:
Не удается найти указанный файл.
Application Диспетчер управления службами 7024 Служба SQL Server (MSSQLSERVER) завершила работу с ошибкой конкретной службы 2148081668 (0x80092004).
Application Userenv 1500 Windows не может войти в систему, так как не удается загрузить профиль. Убедитесь, что вы подключены к сети или работаете правильно. Если эта проблема не исчезнет, обратитесь к администратору сети. DETAIL — системе не удается найти указанный файл.
Application Userenv 1502 Windows не может загрузить локально хранимый профиль. К возможным причинам этой ошибки относятся недостаточные права безопасности или поврежденный локальный профиль. Если эта проблема не исчезнет, обратитесь к администратору сети.

Сведения о сбое, отображаемые в мониторе процессов

Сведения о proMon. В мониторе процессов отображается следующее сообщение:

Требуемый доступ: универсальное чтение и запись, ликвидация: Открыть, Параметры: Синхронный операции ввода-вывода без оповещения, файл без каталога, атрибуты: H, ShareMode: Чтение, запись, AllocationSize: n/a, олицетворение: <SID>

На следующем снимке экрана показаны сведения о мониторе процессов:

Сведения о сбое, отображаемые в мониторе процессов.