Hyper-V виртуальная машина неожиданно отсутствует в Windows Server 2016

Сводка

В этой статье рассматривается проблема, при которой виртуальная машина неожиданно исчезает из автономной среды Windows Server 2016 Hyper-V. Хотя виртуальная машина больше не отображается в диспетчере Hyper-V, связанные с ним файлы виртуального жесткого диска (VHD) и диски данных остаются на узле. В этой статье приводятся общие сведения о симптомах, потенциальных причинах и действиях по устранению проблем, которые помогут пострадавшим пользователям.

Симптомы

Вы столкнулись со следующими симптомами:

  • Виртуальная машина отсутствует в диспетчере Hyper-V, но связанные файлы виртуальных машин и диски данных по-прежнему существуют в хост-системе.
  • Проблема возникает неожиданно, часто во время небюзных часов (например, вскоре после полуночи).

При возникновении этой проблемы применяются следующие условия:

  • В журналах не записывается определенное сообщение об ошибке или идентификатор события.
  • Другие виртуальные машины на том же узле Hyper-V остаются не затронутыми и продолжают работать без каких-либо проблем.
  • Нет никаких доказательств удаления или вмешательства вручную, как сообщает пользователь.
  • Затронутая среда находится в рабочей среде. Возможно, произошли последние действия по обслуживанию или обновлению.
  • Попытки восстановления, такие как переход на конфигурацию резервного копирования в Azure, успешны. Это условие указывает, что проблема изолирована от конкретной виртуальной машины.

Причина

Точные первопричины исчезновения виртуальной машины пока не определены из-за недоступности соответствующих данных журнала. Однако определены следующие потенциальные факторы:

  • Случайное удаление или повреждение файлов конфигурации виртуальной машины. Это условие может быть вызвано антивирусной программой или другими автоматизированными процессами.

  • Проблемы с повреждением диска или оборудованием, влияющими на данные конфигурации виртуальной машины.

  • Раннее инициирование запланированных действий по выводу из эксплуатации узла либо случайно, либо из-за неправильного общения.

Замечание

Удаление виртуальной машины вручную не создает определенные журналы или записи событий в Hyper-V. Таким образом, может оказаться сложной задачей отследить такие действия постфактум.

Резолюция

Чтобы разрешить эту проблему, выполните следующие действия:

  1. Сбор журналов и анализ:

Соберите и отправьте журналы скриптов поддержки (TSS), относящиеся к Hyper-V, для дальнейшего анализа. См. коллекцию данных.

Рекомендации для клиентов и лучшие практики:

  • Реализуйте политики регулярного хранения журналов, чтобы убедиться, что критически важные журналы не очищаются.
  • Сохраняйте резервные копии файлов конфигурации виртуальной машины и просматривайте варианты восстановления для аналогичных сценариев.
  • Просмотрите антивирусные или автоматизированные процессы, которые могут непреднамеренно изменять или удалять файлы виртуальных машин.

Сбор данных

Прежде чем обратиться в службу поддержки Майкрософт, вы можете собрать следующие сведения о проблеме.

  1. Используйте средство TSS для сбора подробных Hyper-V журналов.
  2. Сохраняйте журналы для критических периодов, особенно во время или после периода обслуживания.
  3. Архивируйте файлы конфигурации виртуальной машины и другие связанные данные в рамках стандартных операционных процедур.
  4. Просмотрите журналы событий для любых необычных действий, таких как ошибки диска или антивирусные действия, которые могут повлиять на файлы конфигурации виртуальной машины.

Ссылки