2. Настройка Photon Unity Networking

В этом учебнике показано, как подготовиться к созданию совместного взаимодействия с помощью Photon Unity Networking (PUN). Вы узнаете, как создать приложение PUN, импортировать активы PUN в проект Unity и подключить проект Unity к приложению PUN.

Задачи

  • Узнать, как создать приложение PUN.
  • Узнать, как найти и импортировать активы PUN.
  • Узнать, как подключить проект Unity к приложению PUN.

Создание и подготовка проекта Unity

В рамках этого раздела вы создадите новый проект Unity и подготовите его к разработке MRTK.

Для этого сначала выполните инструкции из руководства Инициализация проекта и развертывание первого приложения (исключая разделы Добавление взаимодействия с рукой к объекту и Разработка приложения для устройства), в том числе следующие действия:

  1. Создание проекта Unity и присвоение ему подходящего имени, например MRTK Tutorials.
  2. Переключение платформы сборки.
  3. Импорт требуемых ресурсов TextMeshPro.
  4. Импорт набора средств для смешанной реальности (MRTK) и настройка проекта Unity
  5. Создание сцены и настройка MRTK и присвоение ей понятного имени, например MultiUserCapabilities

Затем выполните инструкции из раздела Изменение параметра отображения отслеживания пространственного положения:

  1. Измените профиль конфигурации MRTK на DefaultHoloLens2ConfigurationProfile.
  2. Измените параметры отображения сетки отслеживания пространственного положения на Occlusion (Загораживание).

Включение дополнительных возможностей

В меню Unity щелкните Edit>Project Settings... (Правка > Параметры проекта...), чтобы открыть окно параметров проигрывателя, а затем найдите раздел Player>Publishing Settings (Проигрыватель > Параметры публикации).

Unity Player settings

В окне Publishing Settings (Параметры публикации) прокрутите содержимое вниз до раздела Capabilities (Возможности) и убедитесь, что здесь включены возможности InternetClient, Microphone, SpatialPerception и GazeInput, которые вы включили при выполнении шага Настройка проекта Unity ранее.

Затем включите следующие дополнительные возможности:

  • возможность InternetClientServer;
  • возможность PrivateNetworkClientServer.

Unity Capabilities settings

Импорт активов для руководства

Скачайте и импортируйте следующие пользовательские пакеты Unity в указанном здесь порядке:

Совет

 Сведения о том, как правильно импортировать пользовательский пакет Unity, см. в разделе Импорт ресурсов для руководства.

Примечание

После импорта пакета учебных активов MultiUserCapabilities в окне консоли появятся несколько ошибок CS0246. Они указывают на отсутствие типа или пространства имен. Это ожидаемое поведение, и ошибки будут устранены при работе со следующим разделом при импорте активов PUN.

Импорт активов PUN

В меню Unity последовательно выберите Window>Asset Store (Окно > Asset Store), чтобы открыть окно Asset Store. Найдите и выберите актив PUN 2 — FREE от Exit Games, а затем нажмите кнопку Download (Скачать), чтобы скачать пакет активов в учетную запись Unity.

После скачивания нажмите кнопку Импорт, чтобы открыть окно Import Unity Package (Импорт пакета Unity).

Unity Asset Store with PUN 2 - Free

В окне импорта пакета Unity нажмите кнопку All (Все), чтобы выбрать все ресурсы, а затем нажмите кнопку Import (Импорт), чтобы импортировать их.

Unity with PUN 2 import window

Когда в Unity завершится процесс импорта, появится окно мастера PUN с открытым меню PUN Setup (Настройка PUN). На данный момент вы можете проигнорировать или закрыть это окно.

Unity with PUN Setup window

Создание приложения PUN

В этом разделе показано, как создать учетную запись Photon, если у вас ее еще нет, а также приложение PUN.

Перейдите на панель мониторинга Photon и войдите в систему, если у вас уже есть учетная запись, которую вы хотите использовать. В противном случае щелкните ссылку Создать и следуйте инструкциям, чтобы зарегистрировать новую учетную запись.

Photon login page

После входа нажмите кнопку Создать приложение.

Photon dashboard welcome page

На странице создания приложения введите приведенные ниже значения.

  • В раскрывающемся списке Photon Type (Тип Photon) выберите PUN.
  • В поле "Имя" введите подходящее имя, например MRTK Tutorials.
  • В поле "Описание" можно ввести описание (необязательно).
  • Поле "URL-адрес" оставьте пустым.

Затем нажмите кнопку Create (Создать), чтобы создать приложение.

Photon create application page

Когда Photon завершит процесс создания, на панели мониторинга появится новое приложение PUN.

Photon application page

Подключение проекта Unity к приложению PUN

В этом разделе показано, как подключить проект Unity к приложению PUN, которое вы создали при работе с предыдущим разделом.

На панели мониторинга Photon щелкните поле ИД приложения, чтобы отобразить идентификатор приложения, а затем скопируйте его в буфер обмена.

Photon application page with App Id selected

В меню Unity последовательно выберите Window>Photon Unity Networking>PUN Wizard (Окно > Photon Unity Networking > Мастер PUN), чтобы открыть окно мастера PUN. Затем нажмите кнопку Проект установки, чтобы открыть меню PUN Setup (Настройка PUN), и настройте его, как описано ниже.

  • В поле AppId or Email (Идентификатор приложения или адрес электронной почты) вставьте идентификатор приложения PUN, скопированный на предыдущем шаге.

Затем нажмите кнопку Проект установки, чтобы применить идентификатор приложения.

Unity PUN Setup window with AppId filled in

Когда в Unity завершится процесс настройки PUN, в меню PUN Setup (Настройка PUN) появится сообщение Done! (Готово!) и автоматически будет выбран ресурс PhotonServerSettings в окне Project (Проект), чтобы его свойства отобразились в окне Inspector (Инспектор):

Unity PUN Setup window with Setup Project applied

Поздравляем!

Вы успешно создали приложение PUN и подключили его к проекту Unity. Следующим шагом будет разрешение подключений для других пользователей, чтобы несколько пользователей могли видеть работу друг друга.