Dynamics 365'ye yükseltildikten sonra, İş Süreci Akışları içeren bir çözümü 'Farklı Dışarı Aktar'ı denerseniz, İş Süreci Akışı ile dışarı aktarılan çözümdeki varlığı arasındaki bağımlılık, bunu herhangi bir hedef CRM 2016 kuruluşuna aktarmayı engeller

Bu makale, Microsoft Dynamics CRM'da bir çözümü içeri aktarırken karşılaşabileceğiniz sorunlardan birine yönelik bir çözüm sağlar.

Şunlar için geçerlidir: Microsoft Dynamics CRM
Özgün KB numarası: 4025529

Belirtiler

Microsoft Dynamics 365 çözümü tarafından sunulan bir İş Süreci Akışı içeren bir Microsoft Dynamics CRM 2016 kuruluşunu yükselttikten sonra, bu çözüm Farklı Dışarı Aktar aracılığıyla paketlenmişse kullanıcılar bu çözümü Microsoft Dynamics CRM 2016 kuruluşuna geri aktaramaz seçeneğine tıklayın.

Bu, hem çevrimiçi hem de şirket içi müşteriler için geçerlidir.

Neden

Microsoft Dynamics 365'da İş Süreci Akışları varlıklarla temsil edilir. Bu varlıklar, Microsoft Dynamics 365 yükseltildiğinde bir kuruluşta bulunan tüm İş Süreci Akışları için oluşturulur. Ancak, İş Süreci Akışları bir çözüm aracılığıyla tanıtıldıysa, yükseltme sırasında bu çözüm, bu oluşturulan İş Süreci Akışı varlıklarını yükseltme işleminin bir parçası olarak otomatik olarak eklemez. Bu durumda, kullanıcı Bu çözüm olarak 8.1 veya 8.0'a Dışarı Aktar'ı seçerse, çözümün Microsoft Dynamics CRM 2016 kuruluşuna aktarılmasını engelleyecek gerekli bağımlılıklar çözümde eksik olur.

Çözüm

Böyle bir çözüm olarak Dışarı Aktarmayı denemeden önce, içerdiği herhangi bir İş Süreci Akışı için çözüme microsoft Dynamics 365 ilgili İş Süreci Akışı varlığının eklendiğinden emin olun. Bu işlem tamamlandıktan sonra, Microsoft Dynamics 365'da Farklı Dışarı Aktar seçeneği aracılığıyla Microsoft Dynamics CRM 2016 için bir çözüm paketi oluşturmak, başarıyla içeri aktarılabilen kullanılabilir bir çözüm oluşturur.