Microsoft Dynamics 365'de SavedQuery içeri aktarılırken hata oluşuyor

Bu makalede, Microsoft Dynamics 365'da bir çözümü içeri aktarmaya çalıştığınızda alabileceğiniz hata iletileri için bir çözüm sağlanır.

Şunlar için geçerlidir: Microsoft Dynamics 365 Müşteri Etkileşimi Çevrimiçi
Özgün KB numarası: 4496853

Belirtiler

Microsoft Dynamics 365'da bir çözümü içeri aktarmaya çalışırken aşağıdaki hatayla karşılaşırsınız:

Çözümün içeri aktarılması: [çözüm adı] başarısız oldu.
Hata kodu 8004f016

Hata iletişim kutusundaki kılavuz, Tür = Sistem Görünümleri satırı içerir. Bu satır için gösterilen ayrıntı metni aşağıdaki iletidir:

Yönetilen bir çözüm, yönetilmeyen bir temel örneğine sahip olan hedef sistemde SavedQuery bileşeninin üzerine yazamaz. Bu hata için en olası senaryo, yönetilmeyen bir çözümün hedef sisteme yeni bir yönetilmeyen SavedQuery bileşeni yüklemiş olması ve şimdi aynı yayımcıdan yönetilen bir çözümün yönetilen olarak aynı SavedQuery bileşenini yüklemeye çalışmasıdır. Bu, hedef sistemde geçersiz bir çözüm katmanına neden olur ve buna izin verilmez.

XML günlük dosyasını indirin ve Excel'de açın. Bileşenler sekmesinde hücreyi bulun: 0x8004F016.

Sonraki sütunda bileşenin kimliğini içeren bir hata iletisi olacaktır:

Yönetilen bir çözüm, yönetilmeyen bir temel örneğe sahip Id=[Bileşen Kimliği] ile SavedQuery bileşeninin üzerine yazamaz. Bu hata için en olası senaryo, yönetilmeyen bir çözümün hedef sisteme yeni bir yönetilmeyen SavedQuery bileşeni yüklemiş olması ve şimdi aynı yayımcıdan yönetilen bir çözümün yönetilen olarak aynı SavedQuery bileşenini yüklemeye çalışmasıdır. Bu, hedef sistemde geçersiz bir çözüm katmanına neden olur ve buna izin verilmez.

Neden

Hata ayrıntılarında belirtildiği gibi, bu hata için en olası senaryo, hedef kuruluştaki varsayılan çözümde yönetilmeyen bir özelleştirmenin yapılmış olmasıdır. Bu, hedef sistemde geçersiz bir çözüm katmanına neden olur ve buna izin verilmez.

Örnek: Microsoft Dynamics 365 örneğinizde, yönetilmeyen bir çözüm içeri aktarılarak oluşturulmuş özel Kaydedilmiş Sorgu gibi bir bileşen zaten var. Daha sonra aynı Kayıtlı Sorgu ile yönetilen bir çözümü içeri aktarmayı denerseniz bu hatayla karşılaşırsınız.

Çözüm

Kayıtlı Sorgu için yönetilen bileşen bir Web API sorgusuyla bulunabilir ve ardından hedefte silinebilir:

  1. Kuruluşunuzda bir tarayıcı açın ve ardından sekmeyi çoğaltın.

  2. [Hatadan GUID] değerini günlük dosyasındaki hata iletisindeki GUID ile değiştirin ve ardından kuruluşunuzun sonuna ekleyin:

    api/data/v9.1/savedqueries?$filter=savedqueryid eq '[Hatadan GUID]'

    Örneğin:

    https://MyOrganization.crm11.dynamics.com/api/data/v9.1/savedqueries?$filter=savedqueryid eq '1d0f4d57-6d49-e911-a98d-00224800ce20'

    Çıkış şu şekildedir:

    {
    "@odata.etag": "W/\"5792499\"",
    "returnedtypecode": "css_testsqparent",
    "statecode": 0,
    "layoutxml": "<grid name=\"resultset\" icon=\"1\" preview=\"1\" select=\"1\" jump=\"css_name\" 
    object=\"10224\"><row id=\"css_testsqparentid\" name=\"result\"><cell name=\"css_name\" width=\"150\" />
    <cell name=\"css_testsqfield\" width=\"100\" /></row></grid>",
    "savedqueryid": "1d0f4d57-6d49-e911-a98d-00224800ce20",
    "description": "View to trigger 8004F016 named ",
    "createdon": "DateTime",
    "savedqueryidunique": "bdab33b7-18d0-45d6-9db9-6111afc1e444",
    "fetchxml": "<fetch mapping=\"logical\" output-format=\"xml-platform\" version=\"1.0\"><entity 
    name=\"css_testsqparent\"><attribute name=\"css_name\" /><order descending=\"false\" attribute=\"css_name\"
    /><attribute name=\"css_testsqfield\" /><attribute name=\"css_testsqparentid\" /></entity></fetch>",
    "isuserdefined": true,
    "name": "TestSQView","isdefault": false,
    "solutionid": "fd140aae-4df4-11dd-bd17-0019b9312238",
    "ismanaged": false,
    "versionnumber": 5792499,
    "introducedversion": "1.1.0.0",
    "querytype": 0,
    "statuscode": 1,
    "_modifiedby_value": "ba7ca8f4-5a68-4221-821c-5ca91b5f54ad",
    "modifiedon": "DateTime",
    
  3. Bu bileşeni hedef kuruluşta bulmak için Ayarlar>Özelleştirmeleri>Sistemi Özelleştir'e gidin.

  4. Varlıklar'ı seçin ve Şema Adına göre sıralayın.

  5. Sorgu çıkışında returntypecode olan Varlığı bulun.

  6. Varlığı açın ve Görünümler'i seçin.

  7. Sorgu çıkışındaki ad olan Adı bulun.

  8. Bu görünümü silin.

  9. Çözümü yeniden içeri aktarın.