Microsoft Dynamics 365'de "Çözümün içeri aktarılması başarısız oldu" hatası oluşuyor

Bu makalede, Microsoft Dynamics 365'de bir çözümü içeri aktarmaya çalıştığınızda oluşan Çözümün içeri aktarılması: [çözüm adı] başarısız hatası için bir çözüm sağlanır.

Şunlar için geçerlidir: Microsoft Dynamics 365
Özgün KB numarası: 4346891

Belirtiler

Microsoft Dynamics 365'da bir çözümü içeri aktarmaya çalışırken aşağıdaki hata ayrıntılarıyla karşılaşırsınız:

Çözümün içeri aktarılması: [çözüm adı] başarısız oldu.

Kılavuzun Ayrıntı sütununda aşağıdaki iletiyi görürsünüz:

Varlık için geçerli olmayan alanlar belirtildi.

Günlük Dosyasını İndir'i seçerseniz aşağıdakine benzer bir ileti görürsünüz:

[öznitelik adı] özniteliği bir Boole değeridir, ancak Bir Seçim Listesi türü belirtildi.

Ayrıca 80041A06 hata koduna başvuru görürsünüz.

Neden

Bu hata, daha önce belirli bir veri türünde alan (öznitelik) oluşturduysanız ve daha sonra aynı alan adını içeren ancak farklı bir veri türüne sahip bir çözümü içeri aktarmayı denediyseniz oluşabilir.

Örnek: Veri Türü İki Seçenek (Boole) olarak ayarlanmış CustomField1 adlı bir alan oluşturursunuz. Aynı alan adına ancak Seçenek Kümesi (Seçim Listesi) gibi farklı bir Veri Türüne sahip bir çözümü içeri aktarmaya çalışırsanız, bu hatayla karşılaşırsınız.

Çözüm

Türü değiştirme amacıyla farklı bir türe sahip aynı alanı kasıtlı olarak içeri aktarmaya çalışıyorsanız, bu desteklenmez. Örneğin: Belirli türde bir alan oluşturduysanız ve daha sonra türü değiştirmek istediğinize karar verirseniz, aşağıdaki seçeneklerden birini kullanmanız gerekir:

  1. İçeri aktarmaya çalıştığınız çözümde farklı bir adla alanı oluşturun. Alanı farklı bir şema adıyla oluşturduktan/içeri aktardıktan sonra, verileri (gerekirse) geçirip daha önce var olan alanı (artık gerekmiyorsa) silebilirsiniz.

  2. Çözümü içeri aktarmaya çalıştığınız kuruluştaki mevcut alanı silin.

    Önemli

    Bu seçenek yalnızca mevcut verileri bu alanda tutmanız gerekmiyorsa kullanılmalıdır.