Azure'a Bulut hizmeti (klasik) dağıtırken ConstrainedAllocationFailed sorunlarını giderme
Önemli
Cloud Services (klasik) artık yeni müşteriler için kullanımdan kaldırılmıştır ve tüm müşteriler için 31 Ağustos 2024'te kullanımdan kaldırılacaktır. Yeni dağıtımlarda yeni Azure Resource Manager tabanlı dağıtım modeli Azure Cloud Services (genişletilmiş destek) kullanılmalıdır.
Bu makalede, Ayırma kısıtlamaları nedeniyle Azure Bulut hizmetlerinin (klasik) dağıtılamadığı ayırma hatalarını giderebilirsiniz.
Bulut hizmetine (klasik) örnek dağıttığınızda veya yeni web veya çalışan rolü örnekleri eklediğinizde, Microsoft Azure işlem kaynaklarını ayırır.
Azure abonelik sınırına ulaşmadan önce bile bu işlemler sırasında bazen hatalar alabilirsiniz.
İpucu
Bu bilgiler, hizmetlerinizin dağıtımını planlarken de yararlı olabilir.
Belirti
Azure portalında Bulut hizmetinize (klasik) gidin ve kenar çubuğunda İşlem günlüğü (klasik) öğesini seçerek günlükleri görüntüleyin.
Bulut hizmetinizin (klasik) günlüklerini incelediğinizde aşağıdaki özel durumu görürsünüz:
Özel Durum Türü | Hata İletisi |
---|---|
ConstrainedAllocationFailed | '{Operation ID} ' Azure işlemi Compute.ConstrainedAllocationFailed koduyla başarısız oldu. Ayrıntılar: Ayırma başarısız oldu; istekteki kısıtlamalar karşılanamıyor. İstenen yeni hizmet dağıtımı bir Benşim Grubuna bağlı veya bir Sanal Ağ hedefleniyor ya da bu barındırılan hizmet altında mevcut bir dağıtım var. Bu koşullardan herhangi biri yeni dağıtımı belirli Azure kaynaklarıyla kısıtlar. Daha sonra yeniden deneyin veya sanal makine (VM) boyutunu veya rol örneği sayısını azaltmayı deneyin. Alternatif olarak, mümkünse kısıtlamaları kaldırın veya farklı bir bölgeye dağıtmayı deneyin. |
Nedeni
Bulut hizmetine (hazırlama veya üretimde) ilk örnek dağıtıldığında, bu Bulut hizmeti bir kümeye sabitlenir.
Zaman içinde bu kümedeki kaynaklar tamamen kullanılmış olabilir. Bir Bulut hizmeti (klasik) sabitlenmiş kümede yeterli kaynak olmadığında daha fazla kaynak için ayırma isteğinde bulunursa, istek ayırma hatasıyla sonuçlanır. Daha fazla bilgi için bkz. Ayırma hatasıyla ilgili yaygın sorunlar.
Çözüm
Mevcut bulut hizmetleri bir kümeye sabitlenir . Bulut hizmeti (klasik) için daha fazla dağıtım aynı kümede gerçekleşir.
Bu senaryoda bir ayırma hatasıyla karşılaştığınızda önerilen eylem, yeni bir Bulut hizmetine (klasik) yeniden dağıtmak (ve CNAME'yi güncelleştirmektir).
İpucu
Platformun o bölgedeki tüm kümelerden seçmesine olanak tanıdığı için büyük ihtimalle en başarılı çözüm bu olacaktır.
Not
Bu çözüm sıfır kapalı kalma süresi getirmelidir.
İş yükünü yeni bir Bulut hizmetine (klasik) dağıtın.
- Diğer yönergeler için Bulut hizmetini (klasik) oluşturma ve dağıtma kılavuzuna bakın.
Uyarı
Bu dağıtım yuvasıyla ilişkili IP adresini kaybetmek istemiyorsanız Çözüm 3 - IP adresini koruyun seçeneğini kullanabilirsiniz.
Trafiği yeni Bulut hizmetine (klasik) işaret edecek şekilde CNAME veya A kaydını güncelleştirin.
- Diğer yönergeler için Azure Bulut hizmeti (klasik) için özel etki alanı adını yapılandırma kılavuzuna bakın.
Eski siteye sıfır trafik gitmesi durumuna ulaşıldığında eski Bulut hizmetini (klasik) silebilirsiniz.
- Diğer yönergeler için Dağıtımları ve Bulut hizmetini (klasik) silme kılavuzuna bakın.
- Bulut hizmetinizdeki (klasik) ağ trafiğini görmek için Bulut hizmetini (klasik) izlemeye giriş belgesine bakın.
Diğer düzeltme adımları için bkz. Bulut hizmeti (klasik) ayırma hatalarını giderme | Microsoft Docs.
Sonraki adımlar
Daha fazla ayırma hatası çözümü ve arka plan bilgileri için:
Azure sorununuz bu makalede ele alınmıyorsa Microsoft Developer Network (MSDN) ve Stack Overflow'daki Azure forumlarını ziyaret edin. Sorununuzu bu forumlara gönderebilir veya X'te @AzureSupport gönderebilirsiniz. Ayrıca bir Azure desteği isteği gönderebilirsiniz. Destek isteği göndermek için Azure desteği sayfasında Destek al'ı seçin.