Share via


Bulut hizmetlerini (klasik) Azure'a dağıtırken OverconstrainedAllocationRequest sorunlarını giderme

Önemli

Cloud Services (klasik) artık yeni müşteriler için kullanımdan kaldırılmıştır ve tüm müşteriler için 31 Ağustos 2024'te kullanımdan kaldırılacaktır. Yeni dağıtımlarda yeni Azure Resource Manager tabanlı dağıtım modeli Azure Cloud Services (genişletilmiş destek) kullanılmalıdır.

Bu makalede, Azure Cloud Services (klasik) dağıtımını engelleyen kısıtlanmış ayırma hatalarıyla ilgili sorunları gidereceksiniz.

Bulut Hizmetine örnekleri dağıtırken veya yeni web veya çalışan rolü örnekleri eklerken Microsoft Azure işlem kaynaklarını ayırır.

Azure abonelik sınırına ulaşmadan önce bile bu işlemler sırasında bazen hatalar alabilirsiniz.

İpucu

Bu bilgiler, hizmetlerinizin dağıtımını planlarken de yararlı olabilir.

Belirti

Görüntüde İşlem günlüğü (klasik) dikey penceresi gösterilmektedir.

Özel Durum Türü Hata İletisi
OverconstrainedAllocationRequest Bu dağıtımın gerektirdiği VM boyutu (veya VM boyutlarının birleşimi) dağıtım isteği kısıtlamaları nedeniyle sağlanamaz. Mümkünse, sanal ağ bağlamaları gibi kısıtlamaları gevşetmeyi, içinde başka bir dağıtım olmadan barındırılan bir hizmete ve farklı bir bensellik grubuna ya da benzimi grubu olmayan bir hizmete dağıtmayı deneyin veya farklı bir bölgeye dağıtmayı deneyin.

Nedeni

Kök nedeni bulut hizmetinin sabitlenmiş veya sabitlenmemiş olmasına bağlı olarak değişir.

Not

İlk örnek bir bulut hizmetine dağıtıldığında (hazırlama veya üretimde), bu bulut hizmeti bir kümeye sabitlenir.

Zaman içinde kümedeki kaynaklar tam olarak kullanılabilir hale gelebilir. Sabitlenmiş kümede yeterli kaynak olmadığında bir Bulut hizmeti (klasik) ek kaynaklar için ayırma isteğinde bulunursa, istek ayırma hatasına neden olur.

Çözüm

Aşağıdaki senaryolarda ayırma hatalarına yönelik kılavuzu izleyin.

Kümeye sabitlenmemiş

Bir Bulut hizmetini (klasik) ilk kez dağıttığınızda küme henüz seçilmediğinden bulut hizmeti sabitlenmez. Azure'da bir dağıtım hatası olabilir çünkü:

  • Bölgede kullanılamayan belirli bir boyut seçtiniz.
  • Farklı roller arasında gereken boyutların bileşimi bölgede kullanılamıyor.

Bu senaryoda ayırma hatasıyla karşılaştığınızda önerilen eylem bölgede kullanılabilir boyutları denetlemek ve daha önce belirtmiş olduğunuz boyutu değiştirmektir.

  1. Bir bölgede kullanılabilen boyutları Bulut hizmeti (klasik) ürünleri sayfasından de kontrol edebilirsiniz.

    Not

    Ürünler sayfasında kullanılabilir kapasite gösterilmez. Yeni ayırmalar için Azure'ın bölgenizdeki en uygun kümeyi o anda seçebilmesi gerekir.

  2. Bölgenizden farklı bir ürün boyutu belirtmek için Bulut hizmetinizin (klasik) hizmet tanımı dosyasını güncelleştirin.

Kümeye sabitlenmiş

Mevcut bulut hizmetleri bir kümeye sabitlenir . Bulut hizmeti (klasik) için bundan sonra yapılan tüm dağıtımlar aynı kümede gerçekleşir.

Bu senaryoda bir ayırma hatasıyla karşılaştığınızda önerilen eylem, yeni bir Bulut hizmetine (klasik) yeniden dağıtmak (ve CNAME'yi güncelleştirmektir).

İpucu

Platformun o bölgedeki tüm kümelerden seçmesine olanak tanıdığı için büyük ihtimalle en başarılı çözüm bu olacaktır.

Not

Bu çözüm sıfır kapalı kalma süresi getirmelidir.

  1. İş yükünü yeni bir Bulut hizmetine (klasik) dağıtın.

    Uyarı

    Bu dağıtım yuvasıyla ilişkili IP adresini kaybetmek istemiyorsanız Çözüm 3 - IP adresini koru seçeneğini kullanabilirsiniz.

  2. CNAME veya A kaydını trafiği yeni Bulut hizmetine (klasik) işaret edecek şekilde güncelleştirin.

  3. Eski siteye sıfır trafik gitmesi durumuna ulaşıldığında eski Bulut hizmetini (klasik) silebilirsiniz.

Diğer düzeltme adımları için bkz. Bulut hizmeti (klasik) ayırma hatalarını giderme | Microsoft Docs.

Sonraki adımlar

Daha fazla ayırma hatası çözümü ve arka plan bilgileri için:

Azure sorununuz bu makalede ele alınmazsa MSDN ve Stack Overflow'daki Azure forumlarını ziyaret edin. Sorununuzu bu forumlara gönderebilir veya Twitter'da @AzureSupport gönderebilirsiniz. Ayrıca Azure desteği isteği gönderebilirsiniz. Destek isteği göndermek için Azure desteği sayfasında Destek al'ı seçin.