AIPService PowerShell modülünü yükleme

Azure Information Protection'den koruma hizmeti için Windows PowerShell modülünü yüklemenize yardımcı olması için aşağıdaki bilgileri kullanın. Bu modülün adı AIPService'tir ve AADRM adlı önceki sürümün yerini alır.

Bu PowerShell modülünü, internet bağlantısı olan ve sonraki bölümde listelenen önkoşulları karşılayan herhangi bir Windows bilgisayarı kullanarak komut satırından koruma hizmetini (Azure Rights Management) yönetmek için kullanabilirsiniz. Azure Information Protection için Windows PowerShell, otomasyon için betik oluşturma desteği sağlar veya gelişmiş yapılandırma senaryoları için gerekli olabilir. Modülün desteklediği yönetim görevleri ve yapılandırmaları hakkında daha fazla bilgi için bkz. PowerShell kullanarak Azure Information Protection korumasını yönetme.

Önkoşullar

Bu tabloda, Azure Information Protection'den koruma hizmeti için AIPService PowerShell modülünü yükleme ve kullanma önkoşulları listelenir.

Gereksinim Daha fazla bilgi
en düşük Windows PowerShell sürümü Sürüm 3.0

PowerShell oturumuna yazarak $PSVersionTable çalıştırdığınız Windows PowerShell sürümünü onaylayabilirsiniz. Windows PowerShell'in daha yeni bir sürümünü yüklemeniz gerekirse bkz. Mevcut Windows PowerShell sürümünü yükseltme.

AIPService PowerShell modülünün yalnızca Windows PowerShell desteklediğini unutmayın. PowerShell 7 desteklenmez.
Microsoft .NET Framework en düşük sürümü Sürüm 4.6.2

Not: Microsoft .NET Framework'nin bu sürümü sonraki işletim sistemlerine eklenmiştir, bu nedenle yalnızca istemci işletim sisteminiz Windows 8.0'dan küçükse veya sunucu işletim sisteminiz Windows Server 2012'den küçükse el ile yüklemeniz gerekir.

Microsoft .NET Framework en düşük sürümü zaten yüklü değilse Microsoft .NET Framework 4.6.2'yi indirebilirsiniz. Microsoft .NET Framework'nin bu en düşük sürümü, AIPService modülünün kullandığı bazı sınıflar için gereklidir.
Gerekli lisans Bu özelliği kullanmak için bir ürün lisansına sahip olmanız gerekir. Daha fazla bilgi için bkz. Güvenlik & uyumluluğu için Microsoft 365 lisanslama kılavuzu - Hizmet Açıklamaları.

AADRM modülünü yüklediyseniz

AIPService modülü, eski AADRM modülünün yerini alır. Eski modülü yüklediyseniz, kaldırın ve ardından AIPService modülünü yükleyin.

Daha yeni modülde, mevcut betiklerin çalışmaya devam etmesi için eski modüldeki cmdlet adlarına yönelik diğer adlar bulunur. Ancak, eski modül destekten çıkmadan önce bu başvuruları güncelleştirmeyi planlayın. AADRM modülü desteği 15 Temmuz 2020'de sona erecektir.

AADRM modülünü PowerShell Galerisi yüklediyseniz, modülü kaldırmak için Yönetici Olarak Çalıştır seçeneğiyle bir PowerShell oturumu başlatın ve şunu yazın:

Uninstall-Module -Name AADRM

AADRM modülünü Azure Rights Management Yönetim Aracı ile yüklediyseniz, Windows Azure AD Rights Management Yönetimi'ni kaldırmak için Programlar ve Özellikler'i kullanın.

AIPService modülünü yükleme

AIPService modülü PowerShell Galerisi ve Microsoft İndirme Merkezi'nden sağlanmaz.

PowerShell Galerisi yeniyseniz bkz. PowerShell Galerisi kullanmaya başlama. PowerShellGet modülünü ve NuGet sağlayıcısını yüklemeyi de içeren galeri gereksinimleri için yönergeleri izleyin.

PowerShell Galerisi AIPService modülüyle ilgili ayrıntıları görmek için AIPService sayfasını ziyaret edin.

AIPService modülünü yüklemek için Yönetici Olarak Çalıştır seçeneğiyle bir PowerShell oturumu başlatın ve şunu yazın:

Install-Module -Name AIPService

Güvenilmeyen bir depodan yükleme hakkında uyarılırsanız onaylamak için Y tuşuna basabilirsiniz. Alternatif olarak, N tuşuna basın ve komutunu Set-PSRepository -Name PSGallery -InstallationPolicy Trusted kullanarak PowerShell Galerisi güvenilir depo olarak yapılandırın ve ardından komutu yeniden çalıştırarak AIPService modülünü yükleyin.

Galeri'den AIPService modülünün önceki bir sürümü yüklüyse, şunu yazarak en son sürüme güncelleştirin:

Update-Module -Name AIPService

Sonraki adımlar

Windows PowerShell oturumunda yüklü modülün sürümünü onaylayın. Bu denetim, özellikle de eski bir sürümden yükselttiyseniz önemlidir:

(Get-Module AIPService –ListAvailable).Version

Not

Bu komut başarısız olursa, önce Import-Module AIPService komutunu çalıştırın.

Hangi cmdlet'lerin kullanılabilir olduğunu görmek için şunu yazın:

Get-Command -Module AIPService

Belirli bir cmdlet’e yönelik Yardım menüsünü görmek için Get-Help <cmdlet_name> komutunu; Microsoft belgeleri sitesindeki en son yardım konularını görmek içinse -online parametresini kullanın. Örnek:

Get-Help Connect-AipService -online

Daha fazla bilgi için:

Koruma hizmetini yapılandıran komutları çalıştırabilmeniz için önce Connect-AipService cmdlet'ini kullanarak hizmete bağlanmanız gerekir.

Yapılandırma komutlarınızı çalıştırmayı bitirdiğinizde, en iyi yöntem olarak Disconnect-AipService cmdlet'ini kullanarak hizmet bağlantısını kesin. Bağlantıyı kesmezseniz bağlantı bir süre işlem yapılmadığında otomatik olarak kesilir. Otomatik bağlantı kesme davranışı nedeniyle bir PowerShell oturumu sırasında zaman zaman yeniden bağlanmanız gerekebilir.

Not

Koruma hizmeti henüz etkinleştirilmediyse, enable-AipService cmdlet'ini kullanarak hizmete bağlandıktan sonra bunu yapabilirsiniz.