Aracılığıyla paylaş


Outlook veya OWA'da ortak klasörler genişletemiyor veya eklenemez

Belirtiler

Microsoft Outlook'ta, ortak klasör için yeterli izinlere sahip bir kullanıcı ortak klasör ağacını genişletmeye çalışırsa, aşağıdaki hata iletisi görüntülenir:

Klasör genişletilemiyor. Microsoft Exchange'e bağlanma girişimi başarısız oldu.

Web üzerinde Outlook'da, kullanıcı ortak klasörü Sık Kullanılanlar'a eklemeye çalışırsa, "ortak klasör ekleme" penceresi görünmez. Ayrıca, F12 tanılama araçlarını kullanarak GetFolder isteğini ararsanız yanıt metninde aşağıdaki hata iletisini yakalayabilirsiniz:

"Posta kutusuna sahip olarak erişilmelidir. Sahip: ortak klasör posta kutusu guid; Kullanıcıya erişme: Kullanıcı ExchangelegacyDN"

Not

Microsoft, lisanslı bir kullanıcı varsayılan izinlerle klasöre erişmeden kimliğe bürünme yoluyla ortak klasör bilgilerine erişime izin veren üçüncü taraf çözümleri desteklemez.

Neden

Bu sorun, kullanıcının EffectiveDefaultPublicFolderMailbox özelliğine Tam Erişim gibi açık izinleri varsa oluşur.

Bu koşulu doğrulamak için aşağıdaki cmdlet'leri çalıştırın:

Get-Mailbox <mailbox name of the affected user> | FL *public*
Get-MailboxPermission <EffectiveDefaultPublicFolderMailbox name>

Örneğin:

İzin denetiminin ekran görüntüsü.

Çözüm

Bu sorunu düzeltmek için Remove-MailboxPermission cmdlet'ini çalıştırarak EffectiveDefaultPublicFolderMailbox özelliğine yönelik açık izinleri kaldırın:

Remove-MailboxPermission pfmbx1 -User exo1 -AccessRights FullAccess

Ardından, bu açık izinlerin kaldırıldığını doğrulamak için Get-MailboxPermission cmdlet'ini çalıştırın:

Get-MailboxPermission pfmbx1