Yönetim aracısı çalıştırma hata kodları

Aşağıdaki tablolarda, Microsoft Identity Manager (MIM) 2016'daki Eşitleme Hizmeti Yöneticisi kullanıcı arabiriminin hata kodları listelenmektedir. Her hatayı açıklamak için ayrıntılı açıklamalar sağlanır.

Bağlantı hataları

Hata Açıklama
başarısız bağlantı Bağlı dizine bağlantı, kimlik doğrulaması dışında bir nedenle başarısız oldu. Örneğin, ağ kullanılamıyor veya hedef sunucu çevrimdışı.
bırakılan bağlantı Yönetim aracısı ile bağlı dizin arasındaki bağlantı artık yok. Çoğu durumda yönetim aracısı bağlı dizine yeniden bağlanmayı dener.
başarısız kimlik doğrulaması Sağlanan kimlik bilgileri kullanılarak kimlik doğrulaması mümkün değildir.
başarısız izin Bağlı dizindeki bir kapsayıcıya erişmek için yeterli hak yok. Hata yalnızca farklı bağlı dizin kapsayıcılarını arayan Basit Dizin Erişim Protokolü (LDAP) yönetim aracıları için beklenir.
başarısız arama Kapsayıcı veya tablo araması beklenmeyen bir hatayla başarısız oldu.
filigransız uyarı Yönetim aracısı tam içeri aktarma yaparken filigranı okuyamıyor. Hata yalnızca ilk yönetim aracısı yapılandırması tamamlandığında ve bağlı dizinde değişiklik günlüğü etkinleştirildiğinde Sun ONE Directory Server 5.1 (eski adı iPlanet Dizin Sunucusu) için yönetim aracısı için beklenir. Daha sonra, bağlı dizin değişiklik günlüğü kapatıldığında, yönetim aracısı yapılandırması güncelleştirilmezse, tam içeri aktarma işlemi tamamlandığında uyarı oluşur.
no-start-partition-delete Başlangıçta bu yönetim aracısı için yapılandırılmış LDAP bölümü artık yok. Bölüm silindiğinde veya bölüm silinip aynı adla yeniden oluşturulduğunda hata döndürülür. İkinci durumda, ad aynı olsa da hata bölümü GUID'i değişmiştir.

Bulma hataları

Hata Açıklama
eksik-değişiklik-türü Bu hata, değişiklik türü sütun değeri (ekle, değiştir, sil) mevcut olmadığında, dosya tabanlı ve veritabanı yönetim aracılarının yanı sıra Sun ve Netscape dizin sunucuları için yönetim aracısı tarafından yapılan bir delta içeri aktarma işlemi sırasında döndürülür.
invalid-change-type Değişiklik türü sütun değeri geçerli değişiklik türleri listesiyle eşleşmediğinde, dosya tabanlı ve veritabanı yönetim aracılarının yanı sıra Sun ve Netscape dizin sunucuları için yönetim aracısı tarafından yapılan bir delta içeri aktarma işlemi sırasında bu hata döndürülür. Ayrıca, bir değişiklik türü alanı mevcut olduğunda ve ekleme dışında bir değere sahip olduğunda LDAP Veri Değişim Biçimi (LDIF) tam içeri aktarma işleminden döndürülür.
multi-valued-change-type Bu hata, değişiklik türü için birden fazla değer mevcut olduğunda dosya tabanlı ve Sun ve Netscape dizin sunucuları yönetim aracıları tarafından çalıştırılan bir delta içeri aktarma işlemi sırasında döndürülür.
need-full-object Bu hata, dosya tabanlı bir yönetim aracısının delta içeri aktarma çalıştırması sırasında veya dosya tabanlı bir yönetim aracısından devam ederken döndürülür. Yönetim aracısının bağlayıcı alanında bulunamayan bir nesne üzerinde değişiklik gönderdiğini gösterir. Eşitleme altyapısı nesnedeki tüm özniteliklerin geçerli değerlerini istemektedir. Bu bir dosyadan içeri aktarma olduğundan, bu bilgiler kullanılamaz. Tam içeri aktarma işlemi bu sorunu çözmelidir.
missing-dn Bu hata, etki alanı adı değeri olmadığında dosya tabanlı yönetim aracıları (LDIF, DSML veya yapılandırılmış etki alanı adı özniteliklerine sahip düz dosyalar için yönetim aracıları) için döndürülür. Bu, etki alanı adı özniteliğinin eksik olduğu bozuk bir Sun ONE Dizin Sunucusu değişiklik günlüğü için de döndürülür. Yönetim aracısının öğeyi okuyup ayrıştırabileceğini, ancak nesne için etki alanı adı değeri olmadığını gösterir.
dn-not-ldap-conformant LDAP, LDIF, DSML veya yapılandırılmış etki alanı adı özniteliğine sahip düz bir dosya için bir yönetim aracısı LDAP belirtimine uymayan bir etki alanı adı değeri bildirdiğinde bu hata döndürülür.
invalid-dn Bu hata, bir yönetim aracısı bir etki alanı adının FIM kısıtlamasını karşılamadığını bildirdiğinde döndürülür ve bunlar şunlardır:
  • FIM tarafından izin verilmeyen bir veya daha fazla karakter.
  • Boş bir göreli ayırt edici ad (RDN olarak da bilinir).
  • FIM için üst sınırı aşan göreli ayırt edici ad.
  • Etki alanı adının hiyerarşi düzeylerinin sayısı FIM için üst sınırı aşıyor.
missing-anchor-component Bu hata, dosya tabanlı ve veritabanı yönetim aracılarının yanı sıra Sun ve Netscape dizin sunucuları için yönetim aracısı tarafından, bir veya daha fazla yer işareti oluşturma kuralı özniteliğinin değerleri olmadığından bağlayıcı oluşturulamadığında döndürülür.
çok değerli yer işareti bileşeni Bu hata, bir yer işareti oluşturma kuralı özniteliği birden fazla değere sahip olduğundan tutturucuyu oluşturamıyorlarsa Sun ve Netscape dizin sunucuları için yönetim aracısı tarafından döndürülür.
yer işareti çok uzun Bu hata, dosya tabanlı ve veritabanı yönetim aracılarının yanı sıra, bağlantı yapısı FIM için boyut üst sınırını aşan bir yer işareti ürettiğinde Sun ve Netscape dizin sunucuları için yönetim aracısı tarafından döndürülür.
yinelenen nesne Bu hata, bu çalıştırma sırasında eşitleme altyapısına aynı tutturucuya sahip bir nesne zaten bildirildiğinde dosya tabanlı ve veritabanı yönetim aracıları tarafından tam içeri aktarmalarda döndürülür.
Not: Bağlayıcı alanı nesnelerinin kullanımdan kaldırılma süresi, yalnızca geçerli çalıştırma adımı Başarılı, Eşitleme hatasıyla tamamlama, Uyarıyla tamamlama veya Geçici ile tamamlama ile tamamlanırsa gerçekleşir.
missing-object-class Bu hata, dosya tabanlı bir yönetim aracısı (DSML, LDIF için bir yönetim aracısı veya yapılandırılmış nesne sınıfı özniteliğine sahip düz bir dosya) veya bozuk bir değişiklik günlüğü varsa Sun ve Netscape dizin sunucuları için yönetim aracısı tarafından döndürülür. Bu, yönetim aracısının nesne sınıfı özniteliği için bir değeri okuyamadığını gösterir.
missing-object-type Bozuk bir bırakma dosyasından içeri aktarma özgeçmişi gerçekleştirilirken bu hata döndürülür. Normal işlem sırasında bu hatayla karşılaşılmaz.
unmappable-object-type Bu hata, herhangi bir ön ek eşlemesi ile eşleştirilemeyen bir dizi nesne sınıfı değerine sahip bir nesneyi okuduğunda dosya tabanlı bir yönetim aracısı tarafından döndürülür.
ayrıştırma hatası Bu hata, delta modundaki Sun ve Netscape dizin sunucuları için yönetim aracısı tarafından ve bir girişi ayrıştıramadıklarında dosya tabanlı yönetim aracıları tarafından döndürülür. Hatanın bulunmasına yardımcı olmak için <entry-number> öğesi (ve çoğu durumda <line-number> ve <column-number>) bulunur. <attribute-name> öğesi mevcut olabilir. Sun ve Netscape dizin sunucuları için yönetim aracısı, bu durumla karşılaşıldığında çalıştırmayı sonlandırır. Dosya tabanlı yönetim aracıları bulma hatasını günlüğe kaydeder ve devam edin.
okuma hatası Bu hata, belirli bir nesneyi okurken genel bir hata olduğunda çağrı tabanlı yönetim aracıları tarafından döndürülür. Bu genellikle çalıştırmanın sonlandırılmasına neden olur. Sorunu gidermek için kullanabileceğiniz bağlı veri kaynağı hata öğesi mevcut.
hazırlama hatası Bu hata çoğu yönetim aracısı tarafından döndürülür. Eşitleme altyapısının deltayı bağlayıcı alanında hazırlamadığını gösterir. Sunucu, sorun hakkında bilgi sağlayan ve sorun giderme için kullanılabilecek bir olay günlüğü oluşturur. Çoğu yönetim aracısı, hata günlüğe kaydedildiğinde içeri aktarma çalıştırmasını sürdürür, ancak Sun ve Netscape delta çalıştırmaları için yönetim aracısı durur. Değişiklik günlüğü işlemedeki boşluklar bağlayıcı alanında tutarsız bir duruma neden olabilir. Normal işlem sırasında bu hatayla karşılaşılmaz.
invalid-modification-type Bu hata, bir nesne düzeyi değişiklik türü standart LDIF değişiklik türlerinden biri olmadığında veya nesne sınıfında nonreplace veya add: objectclassgibi bir delete: objectclass değişiklik türü olduğunda LDIF yönetim aracısında delta içeri aktarma sırasında döndürülür.
çakışan-değişiklik türleri Bu hata, aynı kayıtta farklı öznitelik düzeyi değişiklik türleriyle karşılaşıldığını belirten LDIF yönetim aracısı tarafından döndürülür (bu durumda çakışan türleri oluşturan öznitelik adı bildirilir) veya aynı dosyada birden çok değiştirme LDIF deltası görülür, örneğin:
LDIF Dosyası örneği
çoklu tek uyumsuzluk Bu hata, FIM'de tek bir değer özniteliği olarak tanımlanan bir öznitelik için birden fazla değer ekleme veya birden fazla değer silme bildirdiğinde dosya tabanlı bir yönetim aracısı tarafından döndürülür. Bu hata, FIM ile depolanan bağlı veri kaynağı şemasının yanlış belirtildiğini (dosya tabanlı yönetim aracıları) veya geçerli şemayla güncel olmadığını gösterebilir. Hatanın bağlamını vermek için bir <attribute-name> öğesi içerir.
invalid-attribute-value Bu hata, şemada bildirilen öznitelik türüne uymayan bir öznitelik değeri okunduğunda çağrı tabanlı bir yönetim aracısı tarafından döndürülür. Hatanın bağlamını vermek için bir <attribute-name> öğesi içerir.
invalid-base64-value Bu hata, geçersiz bir base64 dizesiyle karşılaştıklarında LDIF, DSML, Sun ve Netscape dizin sunucuları için yönetim aracıları tarafından döndürülür.
invalid-numeric-value Bu hata, sayısal bir değeri ayrıştıramadıklarında dosya tabanlı yönetim aracıları ve LDAP için yönetim aracısı tarafından döndürülür. Hatanın bağlamını vermek için bir <attribute-name> öğesi içerir.
invalid-boolean-value Bu hata, bir Boole değerini ayrıştıramadıklarında dosya tabanlı yönetim aracıları ve LDAP için yönetim aracısı tarafından döndürülür. Hatanın bağlamını vermek için bir <attribute-name> öğesi içerir.
reference-value-not-ldap-conformant Bu hata, bir etki alanı adı değeri LDAP belirtimine uymadığında LDAP, LDIF ve DSML veya düz dosyalar (yapılandırılmış etki alanı adı özniteliği ile) için yönetim aracıları tarafından döndürülür. Bu hata iletisi, hatanın bağlamını vermek için bir <attribute-name> öğesi içerir.
invalid-reference-value Bu hata, bir etki alanı adı FIM kısıtlamalarına uymadığında bir yönetim aracısı tarafından döndürülür ve bunlar şunlardır:
  • FIM tarafından izin verilmeyen bir veya daha fazla karakter
  • Boş bir göreli ayırt edici ad (RDN olarak da bilinir)
  • FIM için üst sınırı aşan göreli ayırt edici ad
  • Etki alanı adının hiyerarşi düzeylerinin sayısı FIM için üst sınırı aştı.
unsupported-value-type Bu hata, dosyada verilen değer türü öznitelik türüyle uyumsuz olduğunda DSML veya LDIF yönetim aracısı tarafından döndürülür; örneğin:
  • Dize olmayan bir öznitelik veya dn, objectclass veya changetype gibi ayrılmış anahtar sözcükler için URI veya URL değeri verilir.
  • changetype özniteliği için bir base64 değeri verilir.
  • İkili öznitelik için ASCII olmayan karakterler içeren bir dize değeri verilir.

Eşitleme hataları

Hata Açıklama
extension-dll-exception Bir kural uzantısı özel duruma neden olursa bu hata oluşur. Bu hatayla karşılaşırsanız, özel durumun çağrı yığınını incelemek için <exception-error-info> öğesine bakın. Bazı durumlarda, <rule-error-info> vardır ve hata oluştuğunda hangi kuralın işlendiği hakkında ek bilgi sağlar.
extension-dll-crash Bu hata, kural uzantısını yürüten işlem beklenmedik bir şekilde sonlandırıldığında oluşur. Bu hata yalnızca bir kural uzantısı işlem dışı yürütülürken oluşabilir. Bu hata değerinin olası bir nedeni, kural uzantısının erişim ihlaline neden olan kodu çağırmasıdır.
extension-dll-timeout Müşteri bir uzantı zaman aşımı yapılandırdıysa ve tek bir müşteri uzantı kodu giriş noktasındaki çağrı yapılandırılan zaman aşımını aşarsa bu hata oluşur. <exception-error-info>, zaman aşımına uğradıklarında hangi giriş noktasının çağrıldığı hakkında bağlamsal bilgiler sağlar. Bazı durumlarda '<rule-error-info> mevcuttur ve hata oluştuğunda hangi kuralın işlendiği hakkında ek bilgi sağlar.
Not: Uzantıyı yürüten işlemde hata ayıklarken zaman aşımları uygulanmaz.
extension-projection-object-type-not-set Bu hata oluşur Kural uzantısındaki IMASynchronization.ShouldProjectToMV yönteminin uygulanması metaverse nesne türünü belirtmez.
extension-projection-invalid-object-type Bu hata, kural uzantısındaki IMASynchronization.ShouldProjectToMV yönteminin uygulanması, giden meta veri kümesi nesne türünün değerini Eşitleme Hizmeti Yöneticisi'nin MetaVeri Tasarımcısı'nda listelenmeyen bir değere ayarladığında oluşur. yönteminin belirtilen nesne türü değerlerinden birini kullanıp kullanmadığını denetleyin.
extension-join-resolution-invalid-object-type Bu hata, kural uzantısında IMASynchronization.ResolveJoinSearch yönteminin uygulanması, giden meta veri deposu nesne türünün değerini Eşitleme Hizmeti Yöneticisi'nin MetaVerse Tasarımcısı'nda listelenmeyen bir değere ayarladığında oluşur. yönteminin giden meta veri kümesi nesne türünün değerini listelenen nesne türü değerlerinden birine ayarladığını denetleyin.
extension-join-resolution-index-out-of-bounds Bu hata, kural uzantısındaki IMASynchronization.ResolveJoinSearch yönteminin bir uygulaması, meta veri kümesi nesne sayısına eşit veya negatif olan bir dizin değeri ayarladığında oluşur.
extension-provisioning-call-limit-reached Bu hata, tek bir nesnenin eşitlenmesi sırasında IMASynchronization.Provision yöntemi 10'dan fazla kez çağrıldığında oluşur. Sağlama yöntemindeki müşteri mantığı bir nesnenin sağlamasını kaldırıyorsa ve metaveri nesnesinde değişiklik yapılmasına neden olan öznitelik geri çağırması varsa, bu yöntem birden çok kez çağrılabilir ve bu da Sağlama için yeni bir çağrıyla sonuçlanır. Provision yöntemi için 10 çağrı sınırı, olası sonsuz sağlama notlarını durduracak şekilde ayarlanır.
extension-deprovisioning-invalid-result Bu hata, IMASynchronization.Deprovision yönteminin bir uygulaması geçersiz bir DeprovisionAction numaralandırma değeri döndürdüğünde oluşur. yönteminin geçerli bir değer döndürdüğünü doğrulayın.
extension-entry-point-not-implemented Bu hata, bir kural uzantısı EntryPointNotImplementedException özel durumu oluşturulduğunda oluşur.
extension-unexpected-attribute-value Bu hata, bir kural uzantısı UnexpectedDataException özel durumu oluştururken oluşur.
çoklu değerden tek değere akış Eşitleme Hizmeti Yöneticisi'nde yapılandırılmış bir içeri veya dışarı aktarma öznitelik akışı kuralı birden çok değer içeren bir özniteliği tek değerli bir özniteliğe akıtmaya çalıştığında bu hata oluşur. Bu hata yalnızca Eşitleme Hizmeti Yöneticisi'nde yapılandırılmış doğrudan akış kuralları için döndürülür. Akış kuralı tek değerli bir özniteliğe birden çok değer akıtan bir kural uzantısı kullanıyorsa, TooManyValuesException özel durumu oluşturulur.
cs-attribute-type-uyumsuzluğu bu hata, içeri aktarılan özniteliğin türü yönetim aracısı şemasında belirtilen öznitelik türüyle eşleşmediğinde oluşur. Bu hatanın bir nedeni, depolanan bağlı veri kaynağı şemasının bağlı veri kaynağının gerçek şemasıyla güncel hale gelmiş olması olabilir. Depolanan bağlı veri kaynağı şemasını -date up-togetirmek için, Eşitleme Hizmeti Yöneticisi'ni kullanarak şemayı yenileyin.
join-object-id-must-be-single-valued Bu hata, Eşitleme Hizmeti Yöneticisi'ndeki bir yönetim aracısının özelliklerinde belirtilen bir birleştirme kuralı aracılığıyla meta veri kümesi nesnesini birleştirmek için kullanılan veri kaynağı öznitelik değeri birden fazla değer içerdiğinde oluşur. Birleştirme kuralında kullanılan veri kaynağı öznitelik değeri yalnızca tek bir değer içerebilir.
dn-index-out-of-bounds Eşitleme Hizmeti Yöneticisi'ndeki bir yönetim aracısının özelliklerinde yapılandırılan bir içeri aktarma özniteliği akışında kullanılan ayırt edici ad bileşeni dizin değeri, kaynak nesnenin ayırt edici adındaki bileşen sayısından büyük olduğunda bu hata oluşur.
bağlayıcı-filtre-kuralı-ihlali Bu hata, bir ekleme veya yeniden adlandırma sağlama işlemi veya dışarı aktarma öznitelik akışı gerçekleştirdiğinizde ve bağlayıcı filtresi yapılandırmasının bir sonucu olarak bağlayıcı nesnesi filtrelenmiş bir disconnector nesnesine dönüştüğünde oluşur. Bu değer açık bağlayıcı nesnelerinde oluşmaz.
unsupported-container-delete Yönetim aracısı sağlamayı kaldırma sırasında bir kapsayıcı nesnesini silmeye çalışır. FIM yönetim aracıları, alt nesneleri olan kapsayıcı nesnelerini silemez.
birden çok bağlayıcıdan belirsiz-içeri aktarma-akış Bu hata, kaynak yönetim aracısının altında metaverse nesnesine bağlı birden çok bağlayıcınız olduğunda ve bildirim temelli bir içeri aktarma özniteliği akış kuralı tanımlandığında oluşur. Meta veri dönüştürme nesnesine birden çok bağlayıcısı olan bir yönetim aracısı aracılığıyla öznitelikleri içeri aktarmak için, yönetim aracısının özelliklerinde doğrudan kural yapılandırmak yerine akış kurallarını tanımlamak için bir kural uzantısı kullanın.
ambiguous-export-flow-to-single-valued-attribute Bu hata, Eşitleme Hizmeti Yöneticisi'ndeki bir yönetim aracısının özelliklerinde yapılandırılan dışarı aktarma akışı kuralı, meta veri kümesi nesnesinden tek değerli bir özniteliğe birden çok değer akışı yapmaya çalıştığında oluşur.
cannot-parse-object-id Eşitleme Hizmeti Yöneticisi'ndeki bir yönetim aracısının özelliklerinde belirtilen bir birleştirme kuralında meta veri kümesi nesnesi aramak için kullanılan dize değeri, doğru genel benzersiz tanımlayıcı (GUID) biçiminde değil. GUID biçimi{nnnnn-nnnn-nnnn-nnnnnnnn} biçimindedir; burada n onaltılık bir sayıdır.
unexported-container-rename IMVSynchronization.Provision veya IMASynchronization.Deprovision yönteminin uygulanması, kapsayıcı nesnesini bir veya daha fazla desteklenmeyen alt nesneyle yeniden adlandırmaya çalışır.
mv-constraint-violation Bu hata, doğrudan içeri aktarma öznitelik akışı oluştuğunda ve bağlayıcı alanından öznitelik değeri meta veri kümesi özniteliğinin uzunluk kısıtlamalarını aştığında oluşur.
locking-error-needs-retry Birden çok yönetim aracısı aynı bağlayıcı alanı nesnesini eşitlemeye çalışır. Yönetim aracısını yeniden çalıştırın.
unique-index-violation Kullanıcı meta veri kümesi tablosundaki bir öznitelikte el ile benzersiz bir dizin ayarlanıyor. Meta veri ters tablolarını el ile yapılandırmayın.
şifreleme anahtarı kayboldu FIM çalıştıran sunucuda şifreleme anahtar kümeleri eksik.
beklenmeyen hata Eşitleme altyapısı meta veri kümesine bir değişiklik uygulamayı denediğinde (sağlama ve dışarı aktarma öznitelik akışı dahil) bu hata oluşur. Bu hata yalnızca meta veri deposuna değişiklik uygulayan çalıştırmalar sırasında oluşabilir. Daha fazla bilgi için olay günlüğünü denetleyin.
exported-change-not-reimported Bu hata, bir yönetim aracısına dışarı aktarılan değişiklikler bu içeri aktarma yönetim aracısı çalıştırması sırasında yeniden onaylanmadığında oluşur. FIM dışında çalışan bir kullanıcı veya sistem işlemi, bağlı veri kaynağındaki verileri, dışarı aktarma özniteliği akış kuralının bağlı bir veri kaynağı nesnesine bir değer akışı yapmaya çalıştığı bir yapılandırma sorununu gösterecek şekilde değiştirmiştir, ancak bağlı veri kaynağı, yönetim aracısına hata bildirmeden değeri otomatik olarak farklı bir değere sıfırlar. <change-not-reimported> öğesi hangi değişikliklerin yeniden onaylanmadığını gösterir.
cannot-parse-dn-component Bu hata, LDAP stili ayırt edici adı (DN olarak da bilinir) yapılandırılmış olan herhangi bir yönetim aracısı tarafından döndürülür ve bağlayıcı alanından meta veri deposuna eşitleme başarısız olmuştur. Ayırt edici ad bileşeni, hedef öznitelik türü için doğru biçimde olmadığından bir dncomponent eşlemesi tarafından ayrıştırılamaz.
çalıştırma adımı için eksik bölüm Bu hata, çalıştırma profilinde belirtilen bölümün bulunamadığını gösterir. Bölümün silinmediğini veya yeniden adlandırılmadığını doğrulayın.

Dışarı aktarma hataları

Hata Açıklama
cd-missing-object Bu hata, bir nesnenin bir değiştirmesi bağlı veri kaynağına aktarıldığında döndürülür, ancak nesne bağlı veri kaynağında bulunamaz. Yalnızca çağrı tabanlı yönetim aracıları için döndürülür. Bu hatanın nedeni, bir kişinin veya dış işlemin FIM dışındaki bağlı veri kaynağından bir nesneyi silmiş olmasıdır.
cd-existing-object Bir ekleme bağlı veri kaynağına aktarıldığında ancak nesne bağlı veri kaynağında zaten mevcut olduğunda bu hata döndürülür. Yalnızca çağrı tabanlı yönetim aracıları ve ilişkisel veritabanı yönetim aracıları için döndürülür.
yinelenen bağlantı Yeni sağlanan nesnedeki tutturucu benzersiz değilse bu hata döndürülür. Yalnızca çağrı tabanlı ve veritabanı yönetim aracılarının yanı sıra Sun ve Netscape dizin sunucuları için yönetim aracısı için döndürülür. Bu hatayla karşılaşırsanız, her nesne için benzersiz bir yer işareti değerinin tanımlandığından emin olmak için yer işareti oluşturma kurallarını denetleyin.
belirsiz güncelleştirme Bağlayıcı benzersiz olmadığından yönetim aracısı bir güncelleştirme uygulayamadığında veya deltayı silemediğinde bu hata döndürülür. Yalnızca Microsoft SQL Server ve Oracle Veritabanı için yönetim aracıları için döndürülür. Bu hatayla karşılaşırsanız, her nesne için benzersiz bir yer işareti değerinin tanımlandığından emin olmak için yer işareti oluşturma kurallarını denetleyin.
parola-ilkesi-ihlali Bu hata, parola özniteliği ayarlandığında veya bağlı veri kaynağının yönetici tanımlı parola ilkesine uymayan bir değere değiştirildiğinde Active Directory ve Active Directory genel adres listesi (GAL) için yönetim aracıları tarafından döndürülür.
parola kümesine izin verilmiyor Bu hata, parola şifrelemesi şifreleme yok veya 128 bit Güvenli Yuva Katmanı (SSL) olarak ayarlandığında ve yönetici bu senaryoda parola kümelerine izin vermek için açıkça geçersiz kılma yaptığında Active Directory Uygulama Modu (ADAM) için yönetim aracısı tarafından döndürülür.
kerberos-time-skew Bu hata, active directory ve Active Directory genel adres listesi (GAL) için yönetim aracıları tarafından, parola özniteliği ayarlandığında veya değiştirildiğinde ve FIM sunucusu makine süresi etki alanı denetleyicisindeki zamandan beş dakikadan fazla farklı olduğunda döndürülür.
kerberos-no-logon-server Bu hata, active directory ve Active Directory genel adres listesi (GAL) için yönetim aracıları tarafından bir parola özniteliği ayarlamaya veya değiştirmeye çalıştıklarında ve oturum açma kimlik bilgilerinin etki alanı bölümü için sunucuyu çözümleyemediğinde döndürülür. Bunun nedeni yanlış bir NetBIOS veya DNS yapılandırması olabilir.
şifreleme etkin değil Bu hata, parola özniteliği ayarlandığında veya değiştirildiğinde ve yönetim aracısının bağlı veri kaynağıyla iletişim kurmak için kullandığı bağlantı uygun bir şifreleme mekanizması (128 bit SSL veya TLS) ile yapılandırılmadığında Active Directory Uygulama Modu (ADAM) için yönetim aracısı tarafından döndürülür. ADAM, parolaları ayarlamak için 128 bit SSL veya TLS yapılandırması gerektirir.
invalid-dn Bu hata, ldap ve Windows NT 4.0 için yönetim aracıları tarafından yeni sağlanan bir nesneyi dışarı aktarırken veya var olan bir nesneyi yeniden adlandırırken ve ayırt edici ad bağlı veri kaynağı adlandırma gereksinimleriyle uyumsuz olduğunda döndürülür.
şema ihlali Bu hata, bir nesne değişikliği dışarı aktarılırken ve bağlı veri kaynağı şemasında olmayan bir öznitelik eklenirken veya şemanın gerektirdiği bir nesneden bir özniteliği kaldırırken LDAP için yönetim aracısı tarafından döndürülür. FIM, kuralları bağlı veri kaynağı şemasının depolanmış kopyasını denetlediğinden bu işlemlerin gerçekleşmesine izin vermez. Ancak, FIM şeması bağlı veri kaynağı şemasıyla güncel değilse bu sorun oluşabilir. Bu sorunla karşılaşırsanız, kullanıcı arabirimini kullanarak yönetim aracısı şemasını yenileyin.
kısıtlama ihlali Bu hata, ldap ve veritabanı yönetim aracıları için yönetim aracısı tarafından, bir ekleme, değiştirme veya silme işleminin dışarı aktarımı bağlı veri kaynağının zorlanan kısıtlamalarını ihlal ettiğinde döndürülür. LDAP için yönetim aracısının tipik nedenleri arasında tek bir değer özniteliği için birden çok değer ayarlama, dize ve ikili özniteliklerde alan genişliği kısıtlamalarını aşma veya sayısal özniteliklerdeki aralık kısıtlamalarını ihlal etme sayılabilir. Veritabanı yönetim aracılarının bilgi tutarlılığı, kuralları ve veritabanları için tanımlanabilir kısıtlamalar gibi birçok olası nedeni vardır.
söz dizimi ihlali Bu hata, bir özniteliğin değeri belirli değer kısıtlamalarını ihlal ettiğinde LDAP ve Windows NT 4.0 için yönetim aracıları tarafından döndürülür. Örneğin, dışarı aktarılan değer geçersiz bir karakter içerdiğinde.
modify-naming-attribute Bu hata, bir adlandırma özniteliği (birçok nesne türü için CN gibi) göreli ayırt edici ad (RDN olarak da bilinir) değeriyle çakişen bir değere ayarlandığında LDAP için yönetim aracısı tarafından döndürülür. Bunun nedeni kötü tanımlanmış bir dışarı aktarma özniteliği akış kuralı veya betik kodunda yeni sağlanan nesnede ilk değerleri ayarlayan bir hata olması olabilir.
yetersiz alan genişliği Bu hata, bir nesneye ekleme veya değiştirme dışarı aktarılırken ve özniteliğin değeri sütunun genişliğini aştığında sabit genişlikli metin dosyaları için yönetim aracısı tarafından döndürülür.
yetersiz sütunlar Bu hata, bir nesneye ekleme veya değiştirme dışarı aktarılırken ve çok değerli bir özniteliğin değer sayısı birden çok değer için yapılandırılan sütun sayısını aştığında sabit genişlikli ve sınırlandırılmış metin dosyaları için yönetim aracıları tarafından döndürülür.
izin sorunu Bu hata, ldap ve Windows NT 4.0 için yönetim aracıları tarafından, bir ekleme, değiştirme veya silme işleminin dışarı aktarımı başarısız olduğunda, yönetim aracısının bağlı veri kaynağına karşı işlemi gerçekleştirmek için yeterli izinleri olmadığı için döndürülür.
dn-attributes-failure Bu hata Active Directory, Active Directory genel adres listesi (GAL) ve Active Directory Uygulama Modu (ADAM) için yönetim aracıları tarafından döndürülürken, ekleme veya değiştirme işlemi, karşılık gelen bağlı veri kaynağı nesnesi olmayan bir başvuru değeri ayarlar. Bu hatayı görürseniz, başvuru özniteliklerinde yapılan değişikliklerin başarıyla dışarı aktarılmadığını belirlemek için bağlayıcı alanı nesne görüntüleyicisini kullanın.
varolmayan üst öğe Bu hata, üst nesne bağlı veri kaynağında bulunmadığından bir eklemenin dışarı aktarımı veya yeniden adlandırma başarısız olduğunda LDAP için yönetim aracısı tarafından döndürülür.
kod sayfası dönüştürme FiM çalıştıran sunucuda Unicode olarak depolanan bir öznitelik değeri dönüştürme hataları nedeniyle dışarı aktarma dosyasının kod sayfasına dönüştürülemediğinde bu hata dosya tabanlı yönetim aracıları tarafından döndürülür.
bu nesne türüne dışarı aktarma yok Bu hata, bilgisayar nesnelerinde sağlama işlemleri gerçekleştirmeye veya öznitelik akışını dışarı aktarmaya çalıştığınızda Windows NT 4.0 için yönetim aracısı tarafından döndürülür. Bu nesne türünde dışarı aktarma işlemlerine izin verilmez, ancak bu tür nesneler üzerinde içeri aktarma gerçekleştirebilirsiniz.
missing-provisioning-attribute Bu hata, yeni sağlanan bir nesneyi dışarı aktarırken ve yeni bir nesne sağlamak için gereken bazı öznitelikler kural uzantısı tarafından ayarlanmadığında Lotus Notes için yönetim aracısı tarafından döndürülür.
invalid-provisioning-attribute-value Bu hata, yeni sağlanan bir nesneyi dışarı aktarırken ve kural uzantısı tarafından ayarlanan bazı sağlama öznitelikleri geçersiz olduğunda (örneğin, belirli bir değer aralığında olmadığında) döndürülür.
provision-to-secondary-nab Bu hata, ikincil Lotus Notes adres defterine bir kişi veya sertifika nesnesi sağlama girişiminde bulunulduğunda Lotus Notes için yönetim aracısına özgüdür. Lotus Notes yalnızca kişilerin ikincil adres defterlerine sağlanmasına izin verir.
missing-anchor-component Yeni sağlanan bir nesneyi dışarı aktarırken bu hata döndürülür ve tutturucuyu oluşturmak için gereken bir değer kullanılamadığından bağlantı oluşturulamaz. Olası nedenler, sağlama sırasında bir özniteliğin ayarlanmaması (yani Sun veya Netscape dizin sunucuları, veritabanı ve dosya tabanlı yönetim aracıları için yönetim aracılarında) veya bağlantı otomatik artırma sütunundan oluşturulduğunda bağlı veri kaynağından (Active Directory, Sun ve Netscape dizin sunucuları ve veritabanı yönetim aracıları için yönetim aracılarında) okunamamasıdır.
çok değerli yer işareti bileşeni Bu hata, sun ve Netscape dizin sunucuları için yönetim aracısı tarafından oluşturulur, çünkü tutturucuyu oluştururken kullanılan özniteliklerden biri birden çok değere sahip olduğundan yeni sağlanan nesne için tutturucuyu oluşturamaz. Bağlantı yapısında kullanılan öznitelikler, bağlı veri kaynağı şemasında birden çok değerli olarak tanımlanabilir, ancak FIM'deki gerçek nesneler üzerinde yalnızca tek bir değere sahip olmalıdır.
yer işareti çok uzun Bu hata, dosya tabanlı ve veritabanı yönetim aracılarının yanı sıra, bağlantı yapısı FIM için boyut üst sınırını aşan bir yer işareti ürettiğinde Sun ve Netscape dizin sunucuları için yönetim aracısı tarafından döndürülür. Bağlayıcı alanında tek bir öznitelik için yer işareti değerlerinin uzunluk üst sınırı 398 karakterdir. Tutturucu birden çok öznitelikten oluşturulmuşsa, her ek öznitelik için 2 karakter çıkarın. Örneğin, 3 özniteliklerden (sn+location+telephoneNumber) oluşan bir yer işareti 392 karakterlik bir sınıra sahip olabilir.
invalid-attribute-value Bu hata, bağlı veri kaynağı için geçersiz karakterler içeren bir öznitelik değeri çıkarmaya çalıştığınızda oluşur. Örneğin, sabit genişlikli metin dosyaları, sınırlandırılmış metin dosyaları ve öznitelik-değer çifti metin dosyaları için yönetim aracılarına aktarılan öznitelik değerleri CR, LF veya EOF karakterleri içeremez.
şifreleme anahtarı kayboldu Normal işlemin bir parçası olarak bu hatayla karşılaşılmaz. FIM'in, nesneyi yüklediğinde bağlayıcı alanında depolanan şifrelenmiş özniteliğin değerinin şifresini çözemediğini gösterir. FIM tarafından kullanılan şifreleme anahtar kümelerinin bilgisayarda eksik olduğunu gösterebilir. Bu hata, Active Directory, Active Directory genel adres listesi (GAL), Sun ve Netscape dizin sunucuları, Lotus Notes ve Windows NT 4.0 gibi bir parola özniteliği içeren herhangi bir yönetim aracısı tarafından oluşturulabilir.
locking-error-needs-retry Bu hata yalnızca birden çok yönetim aracısının aynı bağlayıcı alanı nesnesini aynı anda eşitlemeyi denemesi durumunda ortaya çıkar. Bu hatayla karşılaşırsanız dışarı aktarmayı ikinci kez çalıştırmayı deneyin.
cd-error Bağlı veri kaynağı özel bir hata türüne sahip olduğunda bu hata döndürülür. Bu hataya <cd-error> öğesi eşlik ediyor ve burada yer alan bilgiler sorun gidermeye yardımcı olmalıdır.
beklenmeyen hata Bir değişiklik dışarı aktarılmaya çalışıldığında ve işlem bir arızaya neden olduğunda bu hata döndürülür. Bu hatayla karşılaşırsanız, sorunu gidermeye yardımcı olacak daha fazla bilgi için olay günlüğüne bakın.
bu nesne türüne dışarı aktarma yok Bu hata, sağlama işlemlerini gerçekleştirmeye çalıştığınızda veya bilgisayar nesnelerinde öznitelik akışını dışarı aktardığınızda Windows NT 4.0 için yönetim aracısı tarafından döndürülür. Windows NT 4.0 için yönetim aracısı, bu nesne türündeki dışarı aktarma işlemlerini desteklemez.
certifier-ou-not-configured Yeni bir kullanıcı veya kapsayıcı sağlamaya çalışırken Lotus Notes için yönetim aracısı tarafından bu hata döndürülür ve _MMS_Certifier özniteliği için belirttiğiniz sertifikalayıcı adı düzgün yapılandırılmış bir sertifika kapsayıcısının adı değildir. Sağlamada kullanılabilmesi için önce her sertifika kapsayıcısı Eşitleme Hizmeti Yöneticisi kullanılarak yapılandırılmalıdır.
geçici sertifikalayıcı-dosya oluşturma-hatası Yeni bir kullanıcı veya kapsayıcı sağlandığında ve sertifika dosyası oluşturma işlemi herhangi bir nedenle başarısız olduğunda (örneğin, disk alanı, izinler vb.) Lotus Notes için yönetim aracısı tarafından bu hata döndürülür. Sertifikalayıcı dosyasını oluşturmaya yönelik FIM işlemi, _MMS_Certifier özniteliği tarafından belirtilen sertifika kapsayıcısı için sertifikalayıcı bilgilerini getirmek ve Lotus Notes için yönetim aracısının MAData klasöründe Notlar API'sinin kullanımı için geçici olarak bir sertifika dosyası oluşturmaktır.
unexpected-provisioning-attribute Yeni sağlanan bir nesneyi dışarı aktarırken Lotus Notes için yönetim aracısı tarafından bu hata döndürülür ve diğer sağlama özniteliklerinin değerleriyle uyumsuz olduğundan, müşteri uzantısı tarafından ayarlanan bazı sağlama öznitelikleri dahil edilmemelidir. Örneğin, aşağıdaki durumlarda bu hatayı görebilirsiniz:
  • Bir kişi oluşturursunuz (_MMS_IDRegType=0) ve şu özniteliklerden herhangi birini sağlarsınız: _MMS_Certifier, _MMS_OU, _MMS_Password, _MMS_IDStoreType, _MMS_IDPath veya MailFile.
  • BIR ABD kullanıcısı veya Uluslararası kullanıcı oluşturursunuz, ancak kimlik dosyası (_MMS_IDStoreType=0) oluşturmayı belirtmezsiniz, ancak _MMS_IDPath veya MailFile özniteliklerini sağlayın OU (sertifikalayıcı) oluşturursunuz ve _MMS_OU özniteliğini sağlarsınız.
  • Bir O (sertifikalayıcı) oluşturur ve _MMS_Certifier özniteliğini sağlayın.