Not
Bu sayfaya erişim yetkilendirme gerektiriyor. Oturum açmayı veya dizinleri değiştirmeyi deneyebilirsiniz.
Bu sayfaya erişim yetkilendirme gerektiriyor. Dizinleri değiştirmeyi deneyebilirsiniz.
Uyarı
Kullanımdan kaldırılan, destek dışı Internet Explorer 11 masaüstü uygulaması, Windows 10'un belirli sürümlerinde Microsoft Edge güncelleştirmesi aracılığıyla kalıcı olarak devre dışı bırakılmıştır. Daha fazla bilgi için bkz. Internet Explorer 11 masaüstü uygulamasının kullanımdan kaldırılması hakkında SSS.
Bu makalede, tarayıcı modüllerini kullanan tarayıcıların veya uygulamaların, geçerli kullanıcının profiline ait dosyalara ek olarak bilgisayarın Yönetici profiline ait dosyalara erişmeye çalışması sorununun nasıl çözüleceğini açıklar.
Özgün ürün sürümü: Internet Explorer, Windows 10; Microsoft Edge, Windows 10
Belirtiler
Internet Explorer, Microsoft Edge veya her iki tarayıcının modüllerini kullanan uygulamaların kurumsal kullanıcıları aşağıdaki belirtileri bildiriyor:
- Kullanıcılar Windows masaüstünde oturum açarken uzun gecikmeler oluşur.
- Uygulama, tarayıcı önbelleğine içerik kaydedemiyor.
- Uygulama, tarayıcı önbelleğinden içeriğe erişemiyor.
Bu senaryoda, etkilenen bir kullanıcı sorun yaşarken İşlem İzleyicisi günlüğünü kaydeder. Günlüğü analiz ettiğinizde, tarayıcıların veya uygulamaların, kullanıcının profil klasöründe bulunan dosya ve klasörlere ek olarak C:\Users\Administrator klasöründe bulunan dosya ve klasörlere erişmeye çalıştıklarını fark edeceksiniz.
Neden
Kullanıcı Windows'ta ilk kez oturum açtığında, sistem yeni kullanıcı profilini yapılandırmak için varsayılan kullanıcı profilindeki bilgileri kullanır. Windows ayrıca tarayıcıların ve diğer uygulamaların kullanması için kullanıcı profilinin bir parçası olarak bir önbellek kapsayıcısı oluşturur.
Varsayılan kullanıcı profili, yeni kullanıcı profilleri için özel ayarlar oluşturacak şekilde değiştirildiğinde bu erişim sorunu oluşabilir. Bu, özellikle değişiklik işlemi Yönetici profilinden profil bilgilerini kopyalamayı içeriyorsa geçerlidir. Özellikle, bazı görüntüleme veya dağıtım araçları Yönetici profili içeriğinin bir bölümünü veya tümünü varsayılan kullanıcı profiline kopyalar.
Yönetici profilinin kendi önbellek kapsayıcısı vardır. Yönetici profilinin bu bölümü Varsayılan kullanıcı profiline kopyalanırsa, yeni kullanıcılar yeni bir önbellek kapsayıcısı yerine Yönetici önbellek kapsayıcısının bir kopyasını alır. Yönetici hesabı önbellek kapsayıcısının sahibidir. Kullanıcı hesabı bunu yapmaz. Sonuç olarak, kullanıcının önbellek kapsayıcısına tam erişimi yoktur.
Çözüm
Etkilenen bilgisayarlarda, etkilenen kullanıcı profilini ve varsayılan kullanıcı profilini ayrı ayrı düzeltmeniz gerekir.
Dikkat
Herhangi bir değişiklik yapmadan önce profil klasörü konumlarını veya kayıt defteri girdilerini yedeklemenizi kesinlikle öneririz.
Not veya Dikkat
Varsayılan olarak, bu profil dosyaları ve klasörleri görünümden gizlenir. Bunları görünür hale getirmek için, C:\Users\Default klasörünün ve C:\Users\<user name> klasörünün klasör görünümü seçeneklerini ( <kullanıcı adı> etkilenen kullanıcının profilinin adıdır) geçici olarak değiştirmeniz gerekir. Bunun için aşağıdaki adımları izleyin:
- Windows Dosya Gezgini açın ve uygun profil klasörü konumunu bulun.
- Görünüm>Seçenekleri>Görünüm.
- Gelişmiş ayarlar listesinde Gizli dosyaları, klasörleri ve sürücüleri göster'i seçin.
- Aynı listede Korumalı işletim sistemi dosyalarını gizle (Önerilen) onay kutusunu temizleyin ve ardından Evet'i seçin.
- Uygula>Tamam'ı seçin.
1. Adım: Varsayılan kullanıcı profilini onarma
Yeni kullanıcı profillerinin varsayılan kullanıcı profilinden önbellek kapsayıcısının kopyasını almasını önlemek için aşağıdaki dosya ve klasörleri silin (varsa):
- C:\Users\Default\AppData\Local\Microsoft\Windows\WebCacheLock.dat
- C:\Users\Default\AppData\Local\Microsoft\Windows\WebCache
- C:\Users\Default\AppData\Local\Microsoft\Windows\INetCache
- C:\Users\Default\AppData\Local\Microsoft\Windows\INetCookies
2. Adım: Etkilenen her kullanıcı profilini onarma
Kullanıcı Windows'ta oturum açtığında, kullanıcı profilinin parçası olan birkaç dosya ve klasör silinemez. Bu kısıtlama nedeniyle kullanıcının Windows oturumunu kapatması gerekir ve ardından yönetici oturum açıp profili düzeltebilir. Profili düzeltmek için aşağıdaki dosya ve klasörleri silin (varsa):
C:\Users\<user name>\AppData\Local\Microsoft\Windows\WebCacheLock.dat
C:\Users\<user name>\AppData\Local\Microsoft\Windows\WebCache
C:\Users\<user name>\AppData\Local\Microsoft\Windows\INetCache
C:\Users\<user name>\AppData\Local\Microsoft\Windows\INetCookies
Not veya Dikkat
Bu dosya yollarında, <kullanıcı adı> etkilenen kullanıcının profilinin adıdır.
Bu öğeleri sildikten sonra şu adımları izleyin:
- Klasör görünümü seçeneklerini önceki değerlerine geri yükleyin.
- Bilgisayarı yeniden başlatın ve etkilenen kullanıcının oturum açmasını sağlayın (veya yeni bir kullanıcı hesabı kullanarak oturum açabilirsiniz).
Daha Fazla Bilgi
Bu makalede listelenen dosya ve klasörler, Internet Explorer ve Microsoft Edge tarayıcı önbelleğinin bir parçasını oluşturur. Bu içerik konumları her kullanıcı için ayrı ayrı oluşturulacak şekilde tasarlanmıştır. Bu nedenle, bunları özelleştirmeye, değiştirmeye veya yeniden taşımaya çalışmamanızı öneririz. Bunu yapmayı desteklemiyoruz.