Aracılığıyla paylaş


Microsoft Dynamics CRM 2011'de belirli görünümler açılırken tablo diğer adı adı benzersiz değil

Bu makalede, Microsoft Dynamics CRM 2011 Güncelleştirme Paketi 12'yi geçtikten sonra görünümleri açamamanıza neden olabilecek bir sorun için çözüm sağlanır.

Şunlar için geçerlidir: Microsoft Dynamics CRM 2011
Özgün KB numarası: 2907665

Belirtiler

Güncelleştirme Paketi 12'nin ardından bir kullanıcı görünümleri açamayabilir. Bu sorun, Gelişmiş Bul Görünümü türündeki görünümler, görüntüleme sütununa ilgili varlıklardan alanlar eklenecek şekilde değiştirildiğinde ortaya çıkar. Sorun hem Kullanıma Kullanıma Alınmış hem de özel varlıklarla tanımlanır.

Neden

Görünümü değiştirirken, bağlantı varlığı düğümü iki kez kullanılabilir. Ancak tek bir bağlantı varlığı düğümü türü için yalnızca bir kez kullanılabilir olması gerekir.

Çözüm

Microsoft Dynamics CRM 2011 Güncelleştirme Paketi 15'in yüklenmesi, Güncelleştirme Paketi 15 yüklendikten sonra değiştirilen görünümler için sorunu çözer. Hata oluşturan Güncelleştirme Paketi 15'i yüklemeden önce tanımlanan mevcut görünümlerin el ile düzeltilmesi gerekir.

Mevcut bozuk görünümde sorunun nasıl düzeltileceğini gösteren bir örnek aşağıda verilmiştir:

Sorunu yeniden oluşturmak için:

  1. Ayarlar'a gidin, Özelleştirmeler'i seçin, Sistemi Özelleştir'i seçin, Varlıklar'ın üzerine gelin, Hesap'ı seçin ve Görünüm'ü seçin.
  2. Hesap Gelişmiş Bul Görünümü'nü açın ve Sütun Ekle'yi seçin.
  3. Kayıt Türü açılan listesinde Birincil Kişi (Kişi) ile ilgili varlığı seçin.
  4. Tam Ad'ın yanındaki onay kutusunu işaretleyin ve Tamam'ı seçin.
  5. Kaydet ve Kapat'ı seçin.
  6. Tüm Özelleştirmeleri Yayımla'yı seçin.
  7. Etkin Olmayan Hesaplar görünümünü açın ve Filtre Ölçütlerini Düzenle'yi seçin.
  8. Herhangi bir filtre ölçütü ekleyin/değiştirin/silin (Durum = Etkin Değil değerini Durum = Etkin olarak değiştirin), Tamam'ı seçin ve Kaydet ve Kapat'ı seçin.
  9. Tüm Özelleştirmeleri Yayımla'yı seçin.
  10. Yine Etkin Olmayan Hesaplar görünümünde Filtre Ölçütlerini Düzenle'yi seçin ve filtre ölçütlerini ekleyin/değiştirin/silin (Durum = Etkin değerini Durum = Etkin Değil olarak değiştirin).
  11. Tamam'ı seçin.
  12. Kaydet ve Kapat'ı seçin.
  13. Tüm Özelleştirmeleri Yayımla'yı seçin.
  14. Gelişmiş Bul'a gidin ve Arama: açılan menüsünde Hesaplar'ı seçin ve Kayıtlı Görünümü Kullan açılan listesinde Etkin Olmayan Hesaplar'ı seçin.
  15. Sonuçlar'ı seçin.

Sorunu şu şekilde düzeltiriz (Sorunu yeniden oluşturmak için kullanılan yukarıdaki örneği kullanarak):

  1. CRM 2011 uygulamasını başlatın.

  2. Ayarlar'a gidin, Özelleştirmeler'in üzerine gelin ve Çözümler'i seçin.

  3. Yeni bir çözüm oluşturun ve bağımlılık eklemeden Buna Hesap varlığı ekleyin.

  4. Şimdi çözümü kaydedin ve yönetilmeyen bir çözüm olarak dışarı aktarın.

  5. Yönetilmeyen çözüm zip dosyası kaydedildikten sonra dosyayı ayıklayın.

  6. customizations.xml dosyasını Visual Studio 2012 gibi bir XML düzenleyicisinde açın ve tam XML'yi daraltmak için klavyede CTRL+M+M tuşlarına basın.

  7. Hata oluşturan görünüm adını arayın. Bu durumda Etkin Olmayan Hesaplar'dır ve dosyanın tamamında yalnızca bir kez bulunur.

  8. XML'de yalnızca bir kayıtlı sorgu genişletir.

  9. Bu bölümde öğesini genişletin <fetchxml> ve öğesini arayın <Link-entity>.

  10. Aşağıdaki XML'nin yinelendiğini göreceksiniz:

    <link-entity name="contact" from="contactid" to="primarycontactid" visible="false" link- type="outer" alias="a_410707b195544cd984376608b1802904">
    
    <attribute name="fullname" />
    
    <attribute name="emailaddress1" />
    
    </link-entity>
    

    Yalnızca bir kez mevcut olmalıdır.

  11. customizations.xml dosyasından bu XML'nin bir girdisini kaldırın ve değişiklikleri kaydedin.

  12. Şimdi düzenlenmiş customizations.xml, [content_Types].xml ve solution.xmlile dosyaları yeniden sıkıştırın.

  13. Bu zip dosyasını CRM uygulamasına aktarıp tüm özelleştirmeleri yayımlayın.

  14. Hesap Etkin Olmayan Görünümler ile ilgili sorunu düzeltir. Bu şekilde bu hatayı oluşturan diğer tüm görünümleri düzeltebilirsiniz.