Eğitim: İfadeleri Tanıtın

Bu Report Builder eğitiminde, ortak fonksiyonlar ve operatörlerle ifadeler kullanarak güçlü ve esnek Reporting Services sayfalı raporlar oluşturuyorsunuz.

Bu eğitimde, isim değerlerini birleştiren, ayrı bir veri setinde değerleri arayan, alan değerlerine göre farklı renkler gösteren ifadeler yazıyorsunuz ve benzeri.

Rapor, beyaz ve renkli sıralar arasında değişen şeritli bir rapordur. Rapor, beyaz olmayan satırların rengini seçmek için bir parametre içermektedir.

Bu illüstrasyon, bu eğitimde oluşturduğunuz rapora benzer bir raporu gösteriyor.

İfadeler kullanan bir Report Builder raporunun ekran görüntüsü.

Bu öğreticinin tamamlanması için tahmini süre: 30 dakika.

Requirements

Gereksinimler hakkında bilgi için bkz. Öğreticiler için önkoşullar (Report Builder).

1. Tablo veya Matris Sihirbazı'ndan tablo raporu ve veri kümesi oluşturma

Bu bölümde bir tablo raporu, bir veri kaynağı ve bir veri seti oluşturulur. Tabloyu düzenlerken yalnızca birkaç alan eklersiniz. Büyücüyü tamamladıktan sonra manuel olarak sütunlar eklersiniz. Sihirbaz, tabloyu düzenlemeyi kolaylaştırır.

Note

Bu öğreticide sorgu veri değerlerini içerdiğinden dış veri kaynağına ihtiyacı yoktur. Bu, sorguyu oldukça uzun yapar. bir iş ortamında sorgu verileri içermez. Bu yalnızca öğrenme amaçlıdır.

Bir tablo raporu oluştur

  1. Rapor Oluşturucu'yu Başlat bilgisayarınızdan, Reporting Services web portalından veya SharePoint tümleşik modundan.

    Yeni Rapor veya Veri Kümesi iletişim kutusu açılır.

    Yeni Rapor veya Veri Kümesi iletişim kutusunu görmüyorsanız, Dosya menüsünde >Yeni.

  2. Sol bölmede Yeni Rapor'un seçili olduğunu doğrulayın.

  3. Sağ bölmede Tablo veya Matris Sihirbazı'nı seçin.

  4. Veri kümesi seçin sayfasında Veri kümesi> oluşturİleri'yi seçin.

  5. Bir veri kaynağı bağlantısı seç sayfasında, SQL Server tipinde bir veri kaynağı seçin. Listeden bir veri kaynağı seçin veya rapor sunucusuna göz atarak birini seçin.

    Note

    Seçtiğiniz veri kaynağı önemli değildir, yeterli izinleriniz olduğu sürece. Veri kaynağından veri almayacaksınız. Daha fazla bilgi için bkz. Veri bağlantısı almanın alternatif yolları (Report Builder).

  6. sonrakiseçin.

  7. Sorgu tasarla sayfasında Metin Olarak Düzenle'yi seçin.

  8. Aşağıdaki sorguyu sorgu bölmesine yapıştırın:

    SELECT 'Lauren' AS FirstName,'Johnson' AS LastName, 'American Samoa' AS StateProvince, 1 AS CountryRegionID,'Female' AS Gender, CAST(9996.60 AS money) AS YTDPurchase, CAST('2015-6-10' AS date) AS LastPurchase  
    UNION SELECT'Warren' AS FirstName, 'Pal' AS LastName, 'New South Wales' AS StateProvince, 2 AS CountryRegionID, 'Male' AS Gender, CAST(5747.25 AS money) AS YTDPurchase, CAST('2015-7-3' AS date) AS LastPurchase  
    UNION SELECT 'Fernando' AS FirstName, 'Ross' AS LastName, 'Alberta' AS StateProvince, 3 AS CountryRegionID, 'Male' AS Gender, CAST(9248.15 AS money) AS YTDPurchase, CAST('2015-10-17' AS date) AS LastPurchase  
    UNION SELECT 'Rob' AS FirstName, 'Caron' AS LastName, 'Northwest Territories' AS StateProvince, 3 AS CountryRegionID, 'Male' AS Gender, CAST(742.50 AS money) AS YTDPurchase, CAST('2015-4-29' AS date) AS LastPurchase  
    UNION SELECT 'James' AS FirstName, 'Bailey' AS LastName, 'British Columbia' AS StateProvince, 3 AS CountryRegionID, 'Male' AS Gender, CAST(1147.50 AS money) AS YTDPurchase, CAST('2015-6-15' AS date) AS LastPurchase  
    UNION SELECT  'Bridget' AS FirstName, 'She' AS LastName, 'Hamburg' AS StateProvince, 4 AS CountryRegionID, 'Female' AS Gender, CAST(7497.30 AS money) AS YTDPurchase, CAST('2015-5-10' AS date) AS LastPurchase  
    UNION SELECT 'Alexander' AS FirstName, 'Martin' AS LastName, 'Saxony' AS StateProvince, 4 AS CountryRegionID, 'Male' AS Gender, CAST(2997.60 AS money) AS YTDPurchase, CAST('2015-11-19' AS date) AS LastPurchase  
    UNION SELECT 'Yolanda' AS FirstName, 'Sharma' AS LastName ,'Micronesia' AS StateProvince, 5 AS CountryRegionID, 'Female' AS Gender, CAST(3247.95 AS money) AS YTDPurchase, CAST('2015-8-23' AS date) AS LastPurchase  
    UNION SELECT 'Marc' AS FirstName, 'Zimmerman' AS LastName, 'Moselle' AS StateProvince, 6 AS CountryRegionID, 'Male' AS Gender, CAST(1200.00 AS money) AS YTDPurchase, CAST('2015-11-16' AS date) AS LastPurchase  
    UNION SELECT 'Katherine' AS FirstName, 'Abel' AS LastName, 'Moselle' AS StateProvince, 6 AS CountryRegionID, 'Female' AS Gender, CAST(2025.00 AS money) AS YTDPurchase, CAST('2015-12-1' AS date) AS LastPurchase  
    UNION SELECT 'Nicolas' as FirstName, 'Anand' AS LastName, 'Seine (Paris)' AS StateProvince, 6 AS CountryRegionID, 'Male' AS Gender, CAST(1425.00 AS money) AS YTDPurchase, CAST('2015-12-11' AS date) AS LastPurchase  
    UNION SELECT 'James' AS FirstName, 'Peters' AS LastName, 'England' AS StateProvince, 12 AS CountryRegionID, 'Male' AS Gender, CAST(887.50 AS money) AS YTDPurchase, CAST('2015-8-15' AS date) AS LastPurchase  
    UNION SELECT 'Alison' AS FirstName, 'Nath' AS LastName, 'Alaska' AS StateProvince, 7 AS CountryRegionID, 'Female' AS Gender, CAST(607.50 AS money) AS YTDPurchase, CAST('2015-10-13' AS date) AS LastPurchase  
    UNION SELECT 'Grace' AS FirstName, 'Patterson' AS LastName, 'Kansas' AS StateProvince, 7 AS CountryRegionID, 'Female' AS Gender, CAST(1215.00 AS money) AS YTDPurchase, CAST('2015-10-18' AS date) AS LastPurchase  
    UNION SELECT 'Bobby' AS FirstName, 'Sanchez' AS LastName, 'North Dakota' AS StateProvince, 7 AS CountryRegionID, 'Female' AS Gender, CAST(6191.00 AS money) AS YTDPurchase, CAST('2015-9-17' AS date) AS LastPurchase  
    UNION SELECT 'Charles' AS FirstName, 'Reed' AS LastName, 'Nebraska' AS StateProvince, 7 AS CountryRegionID, 'Male' AS Gender, CAST(8772.00 AS money) AS YTDPurchase, CAST('2015-8-27' AS date) AS LastPurchase  
    UNION SELECT 'Orlando' AS FirstName, 'Romeo' AS LastName, 'Texas' AS StateProvince, 7 AS CountryRegionID, 'Male' AS Gender, CAST(8578.00 AS money) AS YTDPurchase, CAST('2015-7-29' AS date) AS LastPurchase  
    UNION SELECT 'Cynthia' AS FirstName, 'Randall' AS LastName, 'Utah' AS StateProvince, 7 AS CountryRegionID, 'Female' AS Gender, CAST(7218.10 AS money) AS YTDPurchase, CAST('2015-1-11' AS date) AS LastPurchase  
    UNION SELECT 'Rebecca' AS FirstName, 'Roberts' AS LastName, 'Washington' AS StateProvince, 7 AS CountryRegionID, 'Female' AS Gender, CAST(8357.80 AS money) AS YTDPurchase, CAST('2015-10-28' AS date) AS LastPurchase  
    UNION SELECT 'Cristian' AS FirstName, 'Petulescu' AS LastName, 'Wisconsin' AS StateProvince, 7 AS CountryRegionID, 'Male' AS Gender, CAST(3470.00 AS money) AS YTDPurchase, CAST('2015-11-30' AS date) AS LastPurchase  
    UNION SELECT 'Cynthia' AS FirstName, 'Randall' AS LastName, 'Utah' AS StateProvince, 7 AS CountryRegionID, 'Female' AS Gender, CAST(7218.10 AS money) AS YTDPurchase, CAST('2015-1-11' AS date) AS LastPurchase  
    UNION SELECT 'Rebecca' AS FirstName, 'Roberts' AS LastName, 'Washington' AS StateProvince, 7 AS CountryRegionID, 'Female' AS Gender, CAST(8357.80 AS money) AS YTDPurchase, CAST('2015-10-28' AS date) AS LastPurchase  
    UNION SELECT 'Cristian' AS FirstName, 'Petulescu' AS LastName, 'Wisconsin' AS StateProvince, 7 AS CountryRegionID, 'Male' AS Gender, CAST(3470.00 AS money) AS YTDPurchase, CAST('2015-11-30' AS date) AS LastPurchase  
    
  9. Sorgu tasarımcısı araç çubuğunda Çalıştır (!) öğesini seçin. Sonuç kümesi, aşağıdaki sütunlarda 23 satır veri gösterir: FirstName, LastName, StateProvince, CountryRegionID, Gender, YTDPurchase ve LastPurchase.

    Yeni Tablo veya Matris sihirbazındaki Sorgu tasarlama adımının ekran görüntüsü.

  10. sonrakiseçin.

  11. Arrange fields sayfasında, aşağıdaki alanları belirtilen sırayla Mevcut Alanlar listesinden Değerler listesine sürükleyin.

    • Eyalet/İl
    • ÜlkeBölge Kimliği
    • Son Satın Alma
    • YTDPurchase

    CountryRegionID ve YTDPurchase sayısal veri içerdiği için, varsayılan olarak SUM agregası uygulanır, ancak toplam olmalarını istemezsiniz.

  12. Değerler listesinde CountryRegionID'ye sağ tıklayın ve Toplam işaret kutusunu temizleyin.

    Sum artık CountryRegionID'ye uygulanmıyor.

  13. Değerler listesinde YTDPurchase'e sağ tıklayın ve Sum seçeneğini seçin.

    Sum artık YTDPurchase'e uygulanmıyor.

    Değerler listesinin ekran görüntüsü, Toplam seçeneğinin temizlenmeye hazır olduğunu gösteriyor.

  14. İleri'yi seçin.

  15. Düzeni seç sayfasında tüm varsayılan ayarları koruyun ve Sonraki'yi seçin.

    Yeni Tablo veya Matris sihirbazının Düzen Seçimi adımının ekran görüntüsü.

  16. Bitirseçin.

2. Veri kaynağı ve veri setinin varsayılan isimlerini güncelle

Veri kaynağının varsayılan adını güncelle

  1. Verisi Raporu panelinde, Veri Kaynakları klasörünü genişletin.

  2. DataSource1'e sağ tıklayın ve Data Source Properties'i seçin.

  3. İsim kutusuna ExpressionsDataSource girin

  4. Tamam'ı seçin.

Veri setinin varsayılan adını güncelle

  1. Report Data panelinde Veri klasörünü genişletin.

  2. DataSet1'e sağ tıklayın ve Veri Seti Özellikleri'ni seçin.

    Report Builder'da Veri Seti Özelliklerine nasıl erişileceğini gösteren ekran görüntüsü.

  3. İsim kutusuna İfadeler girin

  4. Tamam'ı seçin.

3. İlk baş harf ve soyadı gösterin

Bu bölümde, baş harf ve soyadı içeren bir adla sonuçlanan bir ifadede Sol işlevini ve Concatenate (&) işleçini kullanırsınız. İfadeyi adım adım oluşturabilir veya prosedürde ileri atlayıp eğitimdeki ifadeyi Expression diyalog kutusuna kopyalayıp yapıştırabilirsiniz.

  1. StateProvince sütununa sağ tıklayın, Insert Column'a işaret edin ve ardından Left'i seçin.

    StateProvince sütununun solunda yeni bir sütun eklenmiştir.

    Rapora sol sütun nasıl ekleneceğini gösteren ekran görüntüsü.

  2. Yeni sütunun başlığını seçin ve İsim girin.

  3. İsim sütununun veri hücresine sağ tıklayın ve İfade'yi seçin.

    Bir rapora ifadenin nasıl ekleneceğini gösteren ekran görüntüsü.

  4. İfade diyalog kutusunda, Ortak Fonksiyonlar'ı genişletin ve ardından Metin'i seçin.

  5. Öğe listesinde Sol tuşuna çift tıklayın.

    Sol fonksiyonu ifadeye eklenir.

    Bir ifadeye Sol fonksiyonu nasıl ekleneceğini gösteren ekran görüntüsü.

  6. Kategori listesinde Alanlar (İfadeler) seçeneğini seçin.

  7. Değerler listesinde FirstName tuşuna çift tıklayın.

  8. Girer , 1)

    Bu ifade, soldan sayarak İlk Isim değerinden bir karakter çıkarır.

  9. Girin &". "&

    Bu ifade, ifadenin ardından bir nokta ve boşluk ekler.

  10. Değerler listesinde Soyadı çift tıklayın.

    Tamamlanmış ifade şudur: =Left(Fields!FirstName.Value, 1) &". "& Fields!LastName.Value

    Bir ifadeye Soyadadı değeri nasıl ekleneceğini gösteren ekran görüntüsü.

  11. Tamam'ı seçin.

  12. Raporu önizlemek için Çalıştır'ı seçin.

(İsteğe bağlı) Tarih ve para birimi sütunlarını ile başlık satırını biçimlendir

Bu bölümde, tarihleri içeren Son Satın Alma sütununu ve para birimini içeren YTDPurchase sütununu biçimlendiriyorsunuz. Ayrıca başlık satırını da biçimlendirirsiniz.

Tarih sütununu biçimlendir

  1. Tasarım görünümüne dönmek için Tasarım'ı seçin.

  2. Son Satın Alma sütunundaki veri hücresini seçin ve Ana Sayfa >Numarası bölümünde Tarih'i seçin.

    Son Satın Alma sütununun Tarih olarak nasıl ayarlanacağını gösteren ekran görüntüsü.

  3. Ayrıca Sayı bölümünde, Placeholder Styles'ın yanındaki oku seçip Örnek Değerler'i seçin.

    Report Builder'da Örnek Değerler seçeneğini gösteren ekran görüntüsü.

    Şimdi seçtiğiniz biçimlendirmenin bir örneğini görebilirsiniz.

Para birimi sütununu biçimlendirin

  • YTDPurchase sütununda veri hücresini seçin ve Sayı bölümünde Para Birimi Sembolü'nü seçin.

Sütun başlıklarını biçimlendirin

  1. Sütun başlıklarının satırını seçin.

  2. Ana sayfa>Paragraf bölümünde Sol seçeneğini seçin.

    Report Builder'da başlıkların nasıl biçimlendirileceğini gösteren ekran görüntüsü.

  3. Raporu önizlemek için Çalıştır'ı seçin.

İşte şu ana kadarki rapor, biçimlendirilmiş tarihler, para birimi ve sütun başlıklarıyla birlikte.

Formatlanmış raporun önizlemesini gösteren ekran görüntüsü.

4. Cinsiyeti göstermek için renk kullanın

Bu bölümde, bir kişinin cinsiyetini göstermek için renk ekliyorsunuz. Rengi göstermek için yeni bir sütun eklersiniz ve ardından Cinsiyet alanının değerine göre sütunda görünen rengi belirlersiniz.

Raporu şeritli rapor hâline getirirken o tablo hücresine uyguladığınız rengi korumak istiyorsanız, bir dikdörtgen eklersiniz. Sonra arka plan rengini dikdörtgene eklersiniz.

Bir E/F sütunu ekleyin

  1. İsim sütununa sağ tıklayın, Sütun Ekle seçeneğine işaret edin ve ardından Sol'u seçin.

    İsim sütununun soluna yeni bir sütun eklenir.

  2. Yeni sütunun başlığını seçin ve Z/Ö girin.

Dikdörtgen ekleme

  1. Insert sekmesinde Dikdörtgen seçin ve ardından M/F sütunundaki veri hücresinden seçin.

    Hücreye bir dikdörtgen eklenir.

    Dikdörtgenin nasıl yerleştirileceğini gösteren ekran görüntüsü.

  2. Sütun bölücüsünü M/F ile İsim arasında sürükleyerek M/F sütununu daraltın.

    Bir sütunu nasıl daraltabileceğinizi gösteren ekran görüntüsü.

Cinsiyeti göstermek için renk kullanın

  1. M/F sütunundaki veri hücresindeki dikdörtgene sağ tıklayın ve Dikdörtgen Özellikler'i seçin.

  2. Dikdörtgen Özellikler diyalog kutusu >Fill sekmesinde, Fill color yanındaki ifade fx düğmesini seçin.

  3. İfade diyalog kutusunda, Ortak Fonksiyonlar'ı genişletin ve Program Flow'u seçin.

  4. Item listesinde Switch'e çift tıklayın.

  5. Kategori listesinde Alanlar (İfadeler) seçeneğini seçin.

  6. Değerler listesinde Cinsiyet'e çift tıklayın.

  7. Enter ="Erkek" (virgül dahil).

  8. Kategori listesinde Sabitler'i seçin ve Değerler kutusunda Mısır Çiçeği Mavisi'ni seçin.

    Bir cinsiyeti göstermek için bir rengin nasıl kullanılacağını gösteren ekran görüntüsü.

  9. Sonrasında virgül yaz.

  10. Kategori listesinde Alanlar (İfadeler) seçeneğini seçin ve Değerler listesinde tekrar Cinsiyet'e çift tıklayın.

  11. Enter ="Female" (virgül dahil).

  12. Kategori listesinde Sabitler'i seçin ve Değerler kutusunda Domates'i seçin.

  13. Ardından bir kapama parantezi ) girin.

    Tamamlanmış ifade şudur: =Switch(Fields!Gender.Value ="Male", "CornflowerBlue",Fields!Gender.Value ="Female","Tomato")

    İfade iletişim kutusundaki tam ifadeyi gösteren ekran görüntüsü.

  14. OK'ü seçin, sonra tekrar OK'yu seçerek Dikdörtgen Özellikler diyalog kutusunu kapatın.

  15. Raporu önizlemek için Çalıştır'ı seçin.

    M/F sütununu içeren önizlemeyi gösteren ekran görüntüsü.

Renkli dikdörtgenleri biçimlendirin

  1. Tasarım görünümüne dönmek için Tasarım'ı seçin.

  2. M/F sütunundaki dikdörtgeni seçin. Özellikler panelinde, Sınır bölümünde şu özellikleri ayarlayın:

    • BorderColor = Beyaz
    • BorderStyle = Düz
    • BorderWidth = 5 puan

    M/F sütunundaki renk dikdörtgenlerinin nasıl biçimlendirileceğini gösteren ekran görüntüsü.

  3. Raporu tekrar önizlemek için Çalıştır'ı seçin. Bu sefer renk bloklarının etrafında beyaz boşluk var.

    M/F sütununda biçimlendirilmiş dikdörtgenlerle önizlemeyi gösteren ekran görüntüsü.

5. CountryRegion adını arayın

Bu bölümde, CountryRegion veri setini oluşturur ve Lookup fonksiyonunu kullanarak ülke/bölgenin tanımlayıcısı yerine bir ülke/bölge adını gösterirsiniz.

CountryRegion veri setini oluştur

  1. Tasarım görünümüne dönmek için Tasarım'ı seçin.

  2. Rapor Verisi panelinde Yeni seçeneğini seçin ve ardından Veri Set'i seçin.

  3. Veri Seti Özellikleri'nde, raporuma gömülü bir veri seti kullan seçeneğini seçin.

  4. Veri kaynak listesinde ExpressionsDataSource'u seçin.

  5. İsim kutusuna CountryRegion girin

  6. Metin sorgu türünün seçildiğini doğrulayın ve Sorgu Tasarımcısı'nı seçin.

  7. Metin Olarak Düzenle'yi seçin.

  8. Aşağıdaki sorguyu kopyalayıp sorgu bölmesine yapıştırın:

    SELECT 1 AS ID, 'American Samoa' AS CountryRegion  
    UNION SELECT 2 AS CountryRegionID, 'Australia' AS CountryRegion  
    UNION SELECT 3 AS ID, 'Canada' AS CountryRegion  
    UNION SELECT 4 AS ID, 'Germany' AS CountryRegion  
    UNION SELECT 5 AS ID, 'Micronesia' AS CountryRegion  
    UNION SELECT 6 AS ID, 'France' AS CountryRegion  
    UNION SELECT 7 AS ID, 'United States' AS CountryRegion  
    UNION SELECT 8 AS ID, 'Brazil' AS CountryRegion  
    UNION SELECT 9 AS ID, 'Mexico' AS CountryRegion  
    UNION SELECT 10 AS ID, 'Japan' AS CountryRegion  
    UNION SELECT 10 AS ID, 'Australia' AS CountryRegion  
    UNION SELECT 12 AS ID, 'United Kingdom' AS CountryRegion  
    
  9. Sorguyu çalıştırmak için Çalıştır (!) seçeneğini seçin.

    Sorgu sonuçları ülke/bölge tanımlayıcıları ve isimleridir.

  10. Tamam'ı seçin.

  11. Veri Seti Özellikleri iletişim kutusunu kapatmak için tekrar OK'yi seçin.

    Şimdi Report Data sütununda ikinci bir veri setiniz var.

CountryRegion veri setinde değerleri arayın

  1. Ülke Bölgesi Kimliği sütun başlığını seçin ve ID metnini silin; böylece Ülke Bölgesi olarak görünür.

  2. Ülke Bölgesi sütununun veri hücresine sağ tıklayın ve Expression'ı seçin.

  3. İfadeyi ilk eşit (=) işareti dışında silin.

    Kalan ifade şudur: =

  4. İfade iletişim kutusunda Ortak Fonksiyonlar'ı genişletip Çeşitli seçeneğini seçin, Öğe listesinde ise Arama'ya çift tıklayın.

  5. Kategori listesinde Alanlar (İfadeler) seçeneğini seçin ve Değerler listesinde CountryRegionID'ye çift tıklayın.

  6. İmleci CountryRegionID.Value hemen sonrasına yerleştirin ve ,Fields!ID.value, Fields!CountryRegion.value, "CountryRegion") girin.

    Tamamlanmış ifade: =Lookup(Fields!CountryRegionID.Value,Fields!ID.value, Fields!CountryRegion.value, "CountryRegion")

    Lookup fonksiyonunun sözdizimi, Expressions veri setindeki CountryRegionID ile CountryRegion veri setindeki ID arasında bir arama belirtir; bu da CountryRegion veri setinden CountryRegion değerini döndürür.

  7. Tamam'ı seçin.

  8. Raporu önizlemek için Çalıştır'ı seçin.

6. Son satın alımdan itibaren günleri sayın

Bu bölümde bir sütun eklersiniz ve ardından Now fonksiyonunu veya ExecutionTime yerleşik küresel değişkeni kullanarak bir müşterinin son alışverişinden bu yana günümüzden itibaren kaç gün sayısını hesaplarsınız.

Days Ago köşesini ekle

  1. Tasarım görünümüne dönmek için Tasarım'ı seçin.

  2. Son Satın Alma sütununa sağ tıklayın, Insert Column'a işaret edin ve ardından Sağ'ı seçin.

    Son Satın Alma sütununun sağında yeni bir sütun eklenmiştir.

  3. Sütun başlığına Gün Önce yazın.

  4. Days Ago sütununun veri hücresine sağ tıklayın ve Expression'ı seçin.

  5. İfade iletişim kutusunda Ortak Fonksiyonlar'ı genişletin ve ardından Tarih ve Saat'i seçin.

  6. Öğe listesinde DateDiff'e çift tıklayın.

  7. Hemen ardından DateDiff("d" harfini girin (tırnak işareti "" ve virgül dahil).

  8. Kategori listesinde Alanlar (İfadeler) seçeneğini seçin ve Değerler listesinde LastPurchase'e çift tıklayın.

  9. Hemen ardından Fields!LastPurchase.Value, girin , (virgül).

  10. Kategori listesinde tekrar Tarih ve Saat'i seçin ve Öğe listesinde Şimdi düğmesine çift tıklayın.

    Warning

    Üretim raporlarında, rapor görüntülenirken birden fazla kez değerlendirilen ifadelerde ( örneğin, bir raporun detay satırlarında) Now fonksiyonunu kullanmamalısınız. Now değeri satırdan satıra değişir ve farklı değerler ifadelerin değerlendirme sonuçlarını etkiler, bu da ince bir tutarsızlık ortaya çıkarır. Bunun yerine, Reporting Services'in sağladığı küresel değişkeni kullanınExecutionTime.

  11. Sol parantez sonrası Now(silin, sonra sağ parantez girin :).

    Tamamlanmış ifade şudur: =DateDiff("d", Fields!LastPurchase.Value, Now)

    Son satın alma tarihinin tam ifadesini gösteren ekran görüntüsü.

  12. Tamam'ı seçin.

  13. Raporu önizlemek için Çalıştır'ı seçin.

7. Satış karşılaştırmasını göstermek için bir gösterge kullanın

Bu bölümde, yeni bir sütun ekler ve bir kişinin yılbaşından bugüne kadarki (YTD) satın alımlarının, ortalama YTD satın alımlarının üzerinde mi yoksa altında mı olduğunu göstermek için bir gösterge kullanırsınız. Round fonksiyonu değerlerden ondalık sayıları çıkarır.

Göstergeyi ve durumlarını yapılandırmak birçok adım gerektirir. İsterseniz, "Göstergeyi yapılandırmak" prosedürüne atlayabilir ve bu eğitimdeki tamamlanmış ifadeleri İfade diyalog kutusuna kopyalayıp yapıştırabilirsiniz.

+ veya - AVG Satışlar sütununu ekleyin

  1. YTD Satın Alma sütununa sağ tıklayın, Insert Column'a işaret edin ve ardından Sağ'ı seçin.

    Yılbaşı Satın Alma sütununun sağına yeni bir sütun eklenmiştir.

  2. Sütun başlığını seçin ve + veya - AVG Sales girin.

Bir gösterge ekleyin

  1. Insert sekmesinde Indicator'ı seçin ve ardından + veya - AVG Sales sütununun veri hücresini seçin.

    Gösterge Türü Seç iletişim kutusu açılır.

  2. İkon setlerinin Yön grubunda, üç gri oktan oluşan bir küme seçin.

    Gösterge ekleyeceğinizi gösteren ekran görüntüsü.

  3. Tamam'ı seçin.

Göstergeyi yapılandır

  1. Göstergeye sağ tıklayın, Gösterge Özellikleri'ni seçin ve ardından Değer ve Durumlar'ı seçin.

  2. Değer metin kutusunun yanındaki ifade fx butonunu seçin.

  3. İfade diyalog kutusunda, Ortak Fonksiyonlar'ı genişletin ve ardından Matematik'i seçin.

  4. Item listesinde Round tuşuna çift tıklayın.

  5. Kategori listesinde Alanlar (İfadeler) seçin ve Değerler listesinde YTDPurchase'e çift tıklayın.

  6. Fields!YTDPurchase.Value ifadesinden hemen sonra - girin (eksi işareti).

  7. Ortak Fonksiyonlar'ı tekrar genişletin, Toplu seçin ve Öğe listesinde Avg'ye çift tıklayın.

  8. Kategori listesinde Alanlar (İfadeler) seçin ve Değerler listesinde YTDPurchase'e çift tıklayın.

  9. Fields!YTDPurchase.Value ögesinden hemen sonra ,"Expressions")) girin.

    Tamamlanmış ifade şudur: =Round(Fields!YTDPurchase.Value - Avg(Fields!YTDPurchase.Value, "Expressions"))

  10. Tamam'ı seçin.

  11. Eyalet Ölçüm Birimi kutusunda Sayısal seçeneğini seçin.

  12. Aşağıya işaret eden ok satırında, metin kutusunun sağındaki fx butonunu Başlat değeri için seçin.

    Başlat metin kutusunun yanındaki fx butonunun nasıl seçileceğini gösteren ekran görüntüsü.

  13. İfade diyalog kutusunda, Ortak Fonksiyonlar'ı genişletin ve ardından Matematik'i seçin.

  14. Item listesinde Round tuşuna çift tıklayın.

  15. Kategori listesinde Alanlar (İfadeler) seçin ve Değerler listesinde YTDPurchase'e çift tıklayın.

  16. Fields!YTDPurchase.Value öğesinden hemen sonra - girin (eksi işareti).

  17. Ortak Fonksiyonlar'ı tekrar genişletin ve Aggregate'i seçin, Öğe listesinde Avg'ye çift tıklayın.

  18. Kategori listesinde Alanlar (İfadeler) seçin ve Değerler listesinde YTDPurchase'e çift tıklayın.

  19. Hemen ardından Fields!YTDPurchase.Value, "İfadeler" girin)) < 0

    Tamamlanmış ifade: =Round(Fields!YTDPurchase.Value - Avg(Fields!YTDPurchase.Value, "Expressions")) < 0

  20. Tamam'ı seçin.

  21. Son değeri için metin kutusuna 0 yazın.

  22. Yatay oku olan satırı seçin ve Sil seçeneğini seçin.

    Bir göstergənin nasıl silineceğini gösteren ekran görüntüsü.

    Şimdi sadece iki ok var, ya yukarı ya da aşağı.

  23. Yukarı işaret okunun olduğu sırada, Başlangıç kutusuna 0 yazın.

  24. Metin kutusunun sağındaki fx butonunu End değeri için seçin.

  25. İfade diyalog kutusunda, 100'ü silin ve şu ifadeyi oluşturun:=Round(Fields!YTDPurchase.Value - Avg(Fields!YTDPurchase.Value, "Expressions")) >0

  26. Tamam'ı seçin.

  27. Gösterge özellikleri diyalog kutusunu kapatmak için tekrar OK'ye tıklayın.

  28. Raporu önizlemek için Çalıştır'ı seçin.

    + veya - AVG Satış sütunuyla önizlemeyi gösteren ekran görüntüsü, tüm yeni göstergeleri içeriyor.

8. Bantlı rapor yapın

Rapor okuyucularının rapordaki sıralı satırlara uygulanacak rengi belirleyebileceği bir parametre oluşturun, böylece rapor bantlı hale getirilir.

Parametre ekleme

  1. Tasarım görünümüne dönmek için Tasarım'ı seçin.

  2. Verisi Raporu panelinde, Parametreler'e sağ tıklayın ve Parametre Ekle'yi seçin.

    Parametre eklemenin nasıl yapılacağını gösteren ekran görüntüsü.

    Rapor Parametresi Özellikleri iletişim kutusu açılır.

  3. Prompt'ta Renk seç girin.

  4. Isim bölümünde RowColor yazın.

  5. Mevcut Değerler sekmesinde Değerleri Belirt seçeneğini seçin.

  6. Add (Ekle) seçeneğini belirleyin.

  7. Etiket kutusuna Sarı girin.

  8. Değer kutusuna Sarı girin.

  9. Add (Ekle) seçeneğini belirleyin.

  10. Etiket kutusuna Yeşil girin.

  11. Değer kutusuna PaleGreen girin.

  12. Add (Ekle) seçeneğini belirleyin.

  13. Etiket kutusuna Mavi girin.

  14. Değer kutusuna LightBlue girin.

  15. Add (Ekle) seçeneğini belirleyin.

  16. Etiket kutusuna Pembe yazın.

  17. Değer kutusuna Pembe girin.

    Bu parametre adımı için mevcut değerleri seç seçeneğini gösteren Rapor Parametre Özellikleri iletişim kutusunun ekran görüntüsü.

  18. Tamam'ı seçin.

Detay sıralarına alternatif renkler uygulayın

  1. Veri satırındaki tüm hücreleri seçin, ancak M/F sütunundaki hücre hariç, onun da kendi arka plan rengi vardır.

Bir veri satırında seçilmiş hücreleri gösteren ekran görüntüsü.

  1. Özellikler panelinde BackgroundColor'u seçin.

    Özellikler panelini görmüyorsanız, Görünüm sekmesinde Özellikler kutusunu seçin.

    Özellikler panelinde kategoriye göre listeleniyorsa, Çeşitli kategorisinde BackgroundColor bulunur.

  2. Aşağı oku seçin ve ardından İfade'yi seçin.

    Bir ifadeyi BackgroundColor ile nasıl ilişkilendirileceğini gösteren Özellikler kutusunun ekran görüntüsü.

  3. İfade iletişim kutusunda Ortak Fonksiyonlar'ı genişletin ve ardından Program Akışı seçeneğini seçin.

  4. Öğe listesinde IIf tuşuna çift tıklayın.

  5. Ortak Fonksiyonlar bölümünden Çeşitli seçeneğini seçin ve Öğe listesinde RowNumber'a çift tıklayın.

  6. RowNumber( ifadesinden hemen sonra Nothing) MOD 2 girin.

  7. Parametreler'i seçin ve Değerler listesinde RowColor'a çift tıklayın.

  8. Hemen ardından Parameters!RowColor.Value, "Beyaz") girin.

    Tamamlanmış ifade şudur: =IIF(RowNumber(Nothing) MOD 2, Parameters!RowColor.Value, "White")

    Tam bantlı renk ifadesini gösteren ekran görüntüsü.

  9. Tamam'ı seçin.

Raporu çalıştır

  1. Ana sayfa sekmesinde Çalıştır'ı seçin.

    Raporu çalıştırdığınızda, raporu beyaz olmayan bantlar için bir renk seçmeden önce görmüyorsunuz.

  2. Renk Seç listesinden, rapordaki beyaz olmayan bantlar için bir renk seçin.

    Beyaz olmayan bantlar için nasıl renk seçileceğini gösteren ekran görüntüsü.

  3. Raporu Görüntüle'yi seçin.

    Rapor renderleri ve dönüşümlü satırlar seçtiğiniz arka planı gösterir.

    Renklerin değiştiği sıralarla önizlemeyi gösteren ekran görüntüsü.

(İsteğe bağlı) Rapor başlığı ekleyin

Rapora bir başlık ekleyin.

Rapor başlığı ekleme

  1. Tasarım yüzeyinde Başlık eklemek için tıklayın'ı seçin.

  2. Satış Karşılaştırma Özeti'ni girin, ardından metni seçin.

  3. Ana sayfa sekmesinde, Font kutusunda, şu ayarlar:

    • Boyut = 18
    • Renk = Gri
    • Bold
  4. Ana sayfa sekmesinde Çalıştır'ı seçin.

  5. Rapordaki beyaz olmayan bantlar için bir renk seçin ve Raporu Görüntüle'yi seçin.

(İsteğe bağlı) Raporu kaydet

Raporları bir rapor sunucusuna, SharePoint library veya bilgisayarınıza kaydedebilirsiniz. Daha fazla bilgi için Save reports (Report Builder) bölümüne bakınız.

Bu eğitimde, raporu bir rapor sunucusuna kaydediyorsunuz. Rapor sunucusuna erişiminiz yoksa, raporu bilgisayarınıza kaydedin.

Raporu bir rapor sunucusuna kaydet

  1. Dosya menüsünde Farklı Kaydet’i seçin.

  2. Son Kullanılan Siteler ve Sunucular'ı seçin.

  3. Raporları kaydetme izninizin olduğu rapor sunucusunun adını seçin veya girin.

    "Rapor sunucusuna bağlanıyor" iletisi görüntülenir. Bağlantı tamamlandığında, rapor sunucusu yöneticisinin varsayılan rapor konumu olarak belirttiği rapor klasörünün içeriğini görürsünüz.

  4. Rapora bir isim verin ve kaydet'i seçin.

Rapor, rapor sunucusuna kaydedilir. Bağlı olduğunuz rapor sunucusunun adı, pencerenin en altındaki durum çubuğunda görünür.

Artık rapor okuyucularınız raporunuzu Reporting Services web portalında görebilir.

Her ifadesi görünür olan yeni raporun ekran görüntüsü.