Aracılığıyla paylaş


Hata kodu 0x80090016 - Anahtar kümesi olay görüntüleyicisinde veya aracı günlüklerinde mevcut değil

Not

Microsoft Monitoring Agent (MMA) olarak da bilinen Log Analytics aracısı Ağustos 2024'te kullanımdan kaldırılacaktır. Sonuç olarak, Bulut için Microsoft Defender'daki makine planlarında Sunucular için Defender ve SQL sunucuları için Defender güncelleştirilir ve Log Analytics aracısını kullanan özellikler yeniden tasarlanır. Daha fazla bilgi için bkz . Log Analytics aracısını kullanımdan kaldırmaya hazırlanma.

Bu makalede, olay görüntüleyicinize veya aracı günlüklerinize bağlanmaya çalıştığınızda hata kodu 0x80090016 - "Anahtar kümesi yok" hata kodunun nasıl çözüleceğini açıklar.

Belirtiler

Microsoft Monitoring Agent (MMA) aracılığıyla bir Log Analytics çalışma alanına bağlanmaya çalıştığınızda bağlantı başarısız olur ve aşağıdaki hata girdilerinden biri Operations Manager olay görüntüleyici günlüğüne kaydedilir:

Event ID:      7022 
Description:   The Health Service has downloaded secure configuration for management
               group AOI-00000000-0000-0000-0000-000000000000, and processing the 
               configuration failed with error code Keyset does not exist(0x80090016). 
Event ID:      3009  
Description:   Loading the private key for the client authentication certificate for
               service "Log Analytics - ed4Customer-WorkspaceID" failed with error 
               "Keyset does not exist" (0x80090016). Connections to the service may
               be made without authentication. This can cause failures if the service
               requires the agent to be authenticated. The agent will continue to 
               periodically retry loading the authentication configuration.

Neden

Sunucu, Windows Log Analytics aracısını yükleyip yapılandırmış olan altın renkli bir görüntüden (ana görüntü olarak da bilinir) kopyalandı. Sertifikalar şu anda Windows tarafından kullanılan ad yerine kopyalanan özgün sunucunun adını içerdiğinden bağlantı başarısız oluyor. (Not: Log Analytics aracısının zaten yapılandırılmış olduğu bir bilgisayarı kopyalama desteklenmez.)

Çözüm

Bu hataları çözmek için MMA sertifikalarını aşağıdaki gibi temizleyin ve yenileyin:

  1. Hizmetler ek bileşenini açmak için Başlat'ı seçin, services.msc yazın ve Enter tuşuna basın.

  2. Hizmeti durdurmak için Microsoft Monitoring Agent'ı ve ardından Hizmeti Durdur simgesini seçin.

  3. Microsoft Yönetim Konsolu'nu (MMC) açmak için Başlat'ı seçin, mmc.exe girin ve Enter tuşuna basın.

  4. Sertifikalar ek bileşenini eklemek için Dosya>Ekle/Kaldır Ek Bileşen>Sertifikaları>Bilgisayar Hesabı>Ekle>Sonraki>Yerel Bilgisayar>Tamam'ı> seçin.

  5. MMC'de mevcut MMA sertifikalarını görüntülemek için Sertifikalar>Microsoft Monitoring Agent>Sertifikaları'na gidin.

  6. Güvenlik ve denetim için yedek kopyanız olması için her sertifikayı dışarı aktarmanızı öneririz. Bunun için aşağıdaki adımları izleyin:

    1. Listelenen her sertifikayı tek tek seçip sağ tıklayın ve ardından Tüm Görevler SonrakiNi>>Dışarı Aktar>Hayır, özel anahtarı dışarı aktarma'yı seçin.

    2. Dosya biçimini dışarı aktar sayfasında Base-64 ile kodlanmış X.509 ( öğesini seçin. CER)>İleri.

    3. Dışarı Aktaracak Dosya sayfasındaki dosya adı alanına sertifika dosyasının adını girin ve sertifikayı dışarı aktarmak istediğiniz konuma gözatın. Ardından Sonraki>Bitişi Kaydet'i>seçin.

  7. 6. adımda açıklandığı gibi orta bölmede listelenen sertifikaların yedek kopyalarını dışarı aktardıktan sonra, sertifikaları MMC'den silin. Konsolu açık tutun.

  8. Hizmetler ek bileşeninde Microsoft Monitoring Agent'ı seçin ve ardından Hizmeti Başlat simgesini seçerek yeniden başlatın.

  9. Bir dakika bekleyin. Ardından MMC'de Sertifikalar ek bileşenini seçin ve yenilemek için Yenile simgesini veya F5'i seçin. Yeni sertifikalar görmeniz gerekir.

Bu adımların sorunu giderip çözmediğini belirlemek için aracıyı, olay günlüklerini ve Log Analytics çalışma alanınızı gözlemleyin.

Daha Fazla Bilgi

Microsoft Monitoring Agent kurulumu

Log Analytics Aracısı'ne genel bakış: yükleme seçenekleri

Yardım için bizimle iletişim kurun

Sorularınız varsa veya yardıma ihtiyacınız varsa bir destek isteği oluşturun veya Azure topluluk desteğine sorun. Ürün geri bildirimini Azure geri bildirim topluluğuna da gönderebilirsiniz.