Aracılığıyla paylaş


IIS Yöneticisi'ni kullanarak bir SSL .pfx dosyasını yerel bilgisayar kişisel sertifika deposuna içeri aktarırken hata oluştu

Bu makale, Microsoft Internet Information Services (IIS) Yöneticisi'ni kullanarak güvenli yuva katmanı (SSL) özel anahtar sertifikası (.pfx) dosyasını yerel bilgisayar kişisel sertifika deposuna içeri aktarmaya çalıştığınızda oluşan bir hatayı düzeltmenize yardımcı olur.

Özgün ürün sürümü: Internet Information Services
Özgün KB numarası: 919074

Önemli

Bu makale, kayıt defterinin nasıl değiştirileceği hakkında bilgiler içerir. Değiştirmeden önce kayıt defterini yedeklemeyi unutmayın. Bir sorun olduğunda kayıt defterinin nasıl geri yükleneceğini bildiğinizden emin olun. Kayıt defterini yedekleme, geri yükleme ve değiştirme hakkında daha fazla bilgi için bkz . Gelişmiş kullanıcılar için Windows kayıt defteri bilgileri.

Belirtiler

Bir SSL .pfx dosyasını yerel bilgisayar kişisel sertifika deposuna aktarmaya çalışırsınız. Bu durumda, .pfx dosyasını içeri aktarmaya nasıl çalıştığınıza bağlı olarak aşağıdaki belirtilerden biriyle karşılaşabilirsiniz:

  • IIS Yöneticisi'ni kullanarak .pfx dosyasını içeri aktarmaya çalışırsanız aşağıdaki hata iletisini alırsınız:

    pfx dosyası içeri aktarılamıyor. Bu dosya için yanlış parola girdiniz veya sertifikanın süresi doldu.

  • Sertifikalar Microsoft Yönetim Konsolu (MMC) ek bileşenini kullanarak .pfx dosyasını içeri aktarmaya çalışırsanız, aşağıdaki hata iletisini alırsınız:

    bir iç hata oluştu. Bu, kullanıcı profiline erişilemiyor olabilir veya içeri aktardığınız özel anahtar, sisteminizde yüklü olmayan bir şifreleme hizmeti sağlayıcısı gerektirebilir.

Neden

Bu davranış, aşağıdaki koşullardan biri veya daha fazlası doğru olduğunda oluşur:

  • Bilgisayardaki klasöre erişmek DriveLetter:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\MachineKeys için yeterli izniniz yok.
  • IIS'nin şifreleme hizmeti sağlayıcısına erişmesini engelleyen bir üçüncü taraf kayıt defteri alt anahtarı vardır.
  • Terminal Hizmetleri oturumu aracılığıyla bilgisayarda uzaktan oturum açtınız. Kullanıcı profili, Terminal Hizmetleri'nin etkinleştirildiği sunucuda yerel olarak depolanmaz.

Bu davranışı çözmek için, durumunuz için uygun olan aşağıdaki çözümlerden birini kullanın.

Çözüm 1: MachineKeys klasörü için doğru izinleri ayarlama

Bilgisayardaki klasöre erişmek DriveLetter:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\MachineKeys için yeterli izniniz yoksa, klasör için doğru izinleri ayarlayın.

MachineKeys klasörünün izinlerini ayarlama hakkında daha fazla bilgi için bkz . MachineKeys klasörleri için varsayılan izinler.

Çözüm 2: Üçüncü taraf kayıt defteri alt anahtarını silme

Uyarı

Kayıt Defteri Düzenleyicisi'ni veya başka bir yöntemi kullanarak kayıt defterini hatalı olarak değiştirirseniz önemli sorunlar oluşabilir. Bu sorunlar, işletim sisteminizi yeniden yüklemenizi gerektirebilir. Microsoft, bu sorunların çözülebileceğini garanti edemez. Kayıt defterini değiştirmek kendi sorumluluğunuzdadır.

Aşağıdaki kayıt defteri alt anahtarı varsa silin:
HKEY_USERS\Default\Software\Microsoft\Cryptography\Providers\Type 001

Bu kayıt defteri alt anahtarını sildikten sonra, IIS şifreleme hizmeti sağlayıcısına erişebilir.

3. Çözüm: Terminal Hizmetleri oturumu için kullanıcı profilini yerel olarak depolama

Terminal Hizmetleri oturumu için kullanıcı profili, Terminal Hizmetleri'nin etkinleştirildiği sunucuda yerel olarak depolanmıyorsa, kullanıcı profilini Terminal Hizmetleri'nin etkinleştirildiği sunucuya taşıyın. Alternatif olarak, dolaşım profillerini kullanın.

Durum

Bu davranış, tasarım gereğidir.