Aracılığıyla paylaş


İş Süreci Akışı silme işlemi bilinmeyen bir bağımlılık nedeniyle başarısız oluyor

Bu makalede, bağımlılık nedeniyle İş Süreci Akışı silme işleminin başarısız olması sorununa yönelik bir çözüm sağlanır.

Şunlar için geçerlidir: Microsoft Dynamics 365
Özgün KB numarası: 4527365

Belirtiler

bir iş süreci akışını silmeye çalışırken, bazen bağımlılık nedeniyle işlem başarısız olur. Ancak, son kullanıcı bağımlılık listesini seçtiğinde hiçbir giriş göstermez.

Neden

Her iş süreci akışı için bir arka uç bpf varlığı vardır. İş süreci akışı silindiğinde bpf varlığı da silinir.

BPF varlığı ile sistemdeki diğer bileşenler arasında bağımlılıklar olması mümkündür (örneğin, Hesaptaki bir arama alanı BPF varlığına başvurur). Bu gibi durumlarda, silme işlemini engelleyen bu tür bağımlılıklar nedeniyle BPF silme girişimi başarısız olur.

Çözüm

Son kullanıcı bpf varlığı için bu tür bir bağımlılığın mevcut olup olmadığını denetleyebiliyor. Öyleyse, BPF'yi silmeden önce bağımlılığın çözülmesi gerekir. Adım -ları:

  1. Ayarlar ->Özelleştirme'ye ve ardından BPF varlığına gidin. BPF varlığını silmeyi deneyin. Silme işlemi beklendiği gibi başarısız olur, ancak bu noktada silme işlemine izin verilmeden önce çözülmesi gereken bağımlılıkların listesi gösterilir.
  2. Bu bağımlılıkları çözün.
  3. İş süreci akışını silmeyi yeniden deneyin.