Aracılığıyla paylaş


Azure AD B2C için ayarlanmış bir uygulamada oturum açmaya çalıştığınızda hata oluşuyor

Bu makalede, Azure AD B2C için ayarlanmış bir uygulamada oturum açmaya çalıştığınızda oluşan bir hata açıklanır.

Orijinal ürün sürümü: Microsoft Entra Id
Özgün KB numarası: 3092587

Belirtiler

Microsoft Azure Active Directory (AD) işletmesi için tüketiciye (B2C) ayarlanmış bir uygulamada oturum açmaya çalıştığınızda aşağıdaki hata iletisini alırsınız:

Üzgünüz, ancak oturum açarken sorun yaşıyoruz
Bu hataları otomatik olarak izleriz, ancak sorun devam ederse bizimle iletişim kurmaktan çekinmeyin. Bu arada, lütfen yeniden deneyin.
Yöneticiniz herhangi bir iletişim bilgisi sağlamadı Bağıntı Kimliği:xxxxxxxx-xxxx-xxxx-xxxx-xxxx
Zaman damgası:yyyy-mm-dd hh:mm:ssZ
AADB2C: Özel durum oluştu

Neden

Uygulamanın Web.config dosyasında istemci kimliği eksik veya yanlış olabilir.

Çözüm

Bu sorunu çözmek için şu adımları izleyin:

  1. Uygulamanın Web.config dosyasını açın.

  2. Web.config dosyasında ida:ClientId uygulama anahtarını bulun.

  3. Uygulama anahtarının değerini Azure AD B2C yönetici portalında uygulamanız için sağlanan istemci kimliğiyle değiştirin.

    Dosyanın değiştirilen bölümü aşağıdakine benzer:

    <appSettings>
    <add key="ida:ClientId" value="**xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx**">
    </appSettings>
    

Yardım için bize ulaşın

Sorularınız veya yardıma ihtiyacınız varsa bir destek isteği oluşturun veya Azure topluluk desteği isteyin. Ürün geri bildirimini Azure geri bildirim topluluğuna da gönderebilirsiniz.