Not
Bu sayfaya erişim yetkilendirme gerektiriyor. Oturum açmayı veya dizinleri değiştirmeyi deneyebilirsiniz.
Bu sayfaya erişim yetkilendirme gerektiriyor. Dizinleri değiştirmeyi deneyebilirsiniz.
Bu makalede, Bilinmeyen Bilgisayar nesnesinin Configuration Manager Benzersiz Tanımlayıcısı'nın (GUID) görüntülenen bir istemci bilgisayar tarafından alınması sorununu çözmeye yönelik bilgiler sağlanır.
Özgün ürün sürümü: Configuration Manager (geçerli dal)
Özgün KB numarası: 4471061
Belirtiler
Configuration Manager geçerli dal sürümü 1702, Microsoft Windows Önyükleme Ortamı'nda (Windows PE) çalışırken Görev Dizisi Sihirbazı'nda başarısız olan bir görev dizisini yeniden denemek için Önceki düğmesini kullanmanıza olanak tanıyan yeni bir özellik içeriyordu.
Bu özellik hakkında daha fazla bilgi için bkz . Görev dizisi başarısız olduğunda önceki sayfaya dönme.
Bu özellik aşağıdaki sorunu kullanıma sunar:
Önceki düğmesi seçildiğinde, görüntülenen istemci bilgisayar kullanılmakta olan Bilinmeyen Bilgisayar nesnesinin Configuration Manager Benzersiz Tanımlayıcısını (GUID) çalabilir (x64 Bilinmeyen Bilgisayar veya x86 Bilinmeyen Bilgisayar).
Bu sorun Configuration Manager geçerli dalı sürüm 1702 için güncelleştirme paketinde düzeltildi.
Bu sorun Configuration Manager geçerli dalının sonraki tüm sürümlerinde de düzeltildi.
Ancak, Configuration Manager geçerli dal sürüm 1702'den başlayarak, medya veya ön yürütme ortamından (PXE) başlatılan bilinmeyen bilgisayarlar, kendilerine hedeflenen görev dizilerini bulamıyor olabilir. Bu senaryoda, SMSTS.log aşağıdaki hata iletisi günlüğe kaydedilir:
Bu bilgisayar için kullanılabilir görev dizisi yok. Lütfen bu bilgisayara tanıtılan en az bir görev dizisi olduğundan emin olun.
Belirtilmeyen hata (Hata: 80004005; Kaynak: Windows)
Bilinmeyen bilgisayarda Çalıştırılacak görev dizisini seçin sayfasındaki Önceki düğmesi seçiliyse bu sorun oluşabilir.
Bu sorun Configuration Manager geçerli dalının sonraki tüm sürümlerinde de düzeltildi.
Configuration Manager geçerli dal sürümü 1702'de güncelleştirme paketi uygulanmasına veya Configuration Manager'ın sonraki bir sürümüne yükseltilmesine rağmen, sorun yine de oluşur.
Neden
Configuration Manager geçerli dal sürümü 1702 ve üzeri Configuration Manager geçerli dal sürümleri için güncelleştirme paketindeki düzeltme sorunun yalnızca ileriye doğru oluşmasını engellediğinden bu sorun oluşmaya devam edebilir. Sorun şu anda ortamda mevcutsa sorunu düzeltmez.
Bu nedenle, sürüm 1702 güncelleştirme paketi veya sonraki bir sürüm uygulandıktan sonra bile bu sorun Configuration Manager geçerli dal sürümü 1702 veya daha yeni bir sürümde oluşmaya devam edebilir. Aşağıdaki adımlar atılmadığı sürece bu durum geçerlidir:
- Dağıtım noktalarındaki önyükleme görüntülerini güncelleştirin.
- Güncelleştirilmiş görüntüleri kullanarak önyükleme medyasını yeniden oluşturun.
- GUID'yi çalan istemci bilgisayarı doğru şekilde temizleyin.
Çözüm
Uyarı
Bilinmeyen Bilgisayar nesnelerini yeniden oluşturarak bu sorunu düzeltmeye çalışmayın. Bu, sorunu doğru şekilde düzeltmez ve sorunun ileriye doğru yeniden oluşmasını engellemez. Ayrıca, tek bir site için birden çok Bilinmeyen Bilgisayar nesnesi olan ortamlarda oluşan bilinen sorunlar vardır. Daha önce Bilinmeyen Bilgisayar nesnelerini yeniden oluşturarak bu sorunu çözmeye çalıştıysanız, bkz . Yinelenen Bilinmeyen Bilgisayar nesnelerini kaldırma.
Bu sorunu çözmek ve ortamda döndürülmesini önlemek için şu adımları izleyin:
Ortamdaki tüm önyükleme görüntülerini güncelleştirin. Bunu yapmak için Configuration Manager konsolundaki görüntülere sağ tıklayın ve dağıtım noktalarını güncelleştir'i seçin. Bu, düzeltmeyi içeren güncelleştirilmiş Configuration Manager ikili dosyalarını önyükleme görüntüsüne yerleştirir. Daha fazla bilgi için bkz . Dağıtım noktalarını önyükleme görüntüsüyle güncelleştirme.
Ortamda medya kullanıyorsanız, dağıtım noktalarındaki tüm önyükleme görüntülerini güncelleştirdikten sonra ortamdaki tüm medyayı yeniden oluşturun. Bu, düzeltmeyi içeren güncelleştirilmiş önyükleme görüntülerinin ortamda kullanılan medyada olmasını sağlar.
Eski önyükleme görüntülerine sahip medyanın kullanılmasını önlemek için, bu önyükleme görüntülerinin sertifikaları Configuration Manager konsolunda Yönetim>Güvenlik>Sertifikaları düğümü altında engellenebilir. Sorunun yinelenmediğinden emin olmak için, 1. adımda önyükleme görüntüleri güncelleştirilmeden önce oluşturulan tüm medya için tüm sertifikaları engellemenizi öneririz. Medyanın oluşturulduğu tarih, Başlangıç Tarihi sütununda görüntülenir.
Medya oluşturma hakkında daha fazla bilgi için bkz . Görev dizisi medyası oluşturma.
GUID'yi çalan istemci bilgisayar doğru temizlenmelidir.
GUID'yi çalan istemciyi doğru şekilde temizlemek için şu adımları izleyin:
GUID'yi alan bilgisayarı tanımlayın. Bunu yapmak için, Bilinmeyen Bilgisayar nesnesinin özelliklerini inceleyin (genellikle x64 Bilinmeyen Bilgisayar), Configuration Manager Benzersiz Tanımlayıcısı değerini not edin ve aynı GUID'ye sahip bilgisayar nesnesini tanımlamak için Configuration Manager konsolunda bir sorgu çalıştırın. Bu adımların tümünü konsolundan yapabilirsiniz. Bunu yapmak için SQL Server veritabanına gitmeniz gerekmez.
Çalınan GUID'yi alan bilgisayarı belirledikten sonra, bu bilgisayara uzaktan bağlanın ve configuration manager istemcisini tamamen temizleyin. Bu, istemciyi kaldırmaktan daha fazlasını içerir. Bunun yerine, 3-7 arası adımları izlemeniz gerekir.
İstemci bilgisayarda, altında
C:\Windows\CCMSetup
komutunu yükseltilmiş bir komut isteminde çalıştırınCCMSetup.exe /uninstall
.CCMSetup'ın çalışması bitene kadar Görev Yöneticisi'ne bakın. İstemcinin doğru şekilde kaldırıldığından emin olmak için ccmsetup.log dosyasını bir kez daha denetleyin.
İstemci bilgisayarda aşağıdaki dizinleri silin:
- C:\Windows\CCM
- C:\Windows\CCMSetup
Not
Bu dizinleri tamamen silmek için bilgisayarı yeniden başlatmanız gerekebilir.
İstemci bilgisayarda aşağıdaki kayıt defteri anahtarlarını silin (varsa):
HKEY_LOCAL_MACHINE\Software\Microsoft\CCM
HKEY_LOCAL_MACHINE\Software\Microsoft\CCMSetup
HKEY_LOCAL_MACHINE\Software\Microsoft\SMS
İstemci bilgisayarda C:\Windows\SMSCFG.ini dosyasını silin.
İstemci bilgisayarda, Bilgisayar hesabının Sertifikalar konsolundaki SMS>Sertifikaları düğümü altındaki tüm sertifikaları silin. Bunun için aşağıdaki adımları izleyin:
Yükseltilmiş bir komut isteminde komutunu çalıştırın
MMC.exe
.Dosya menüsünde Ek Bileşeni Ekle/Kaldır'ı seçin.
Sertifikalar'ı ve ardından Ekle'yi seçin.
Bilgisayar hesabı'nın ardından İleri'yi seçin.
Yerel bilgisayar'ı ve ardından Son'u seçin.
Tamam'ı seçin.
Sertifikalar>SMS>Sertifikaları'na gidin.
Sonuçlar bölmesinde, Sertifikalar>SMS>Sertifikaları düğümü altında listelenen her sertifikaya sağ tıklayın ve sil'i seçin. Tüm sertifikalar silinene kadar bu adımı yineleyin.
Sertifikalar konsolunu kapatın.
Configuration Manager konsolundan sorunlu bilgisayarın kaydını silin. Bunu yapmak için SQL Server veritabanına gitmeniz gerekmez. Kaydı Configuration Manager konsolundan silebilirsiniz. 1-8 arası adımları tamamladıktan sonra bunu yaptığınızdan emin olun. İlk olarak bunu yapmak, istemci raporları tamamen temizlenmeden önce yedeklenirse kaydın yeniden oluşturulmasına neden olabilir.
Configuration Manager istemcisini sorunlu istemci bilgisayara yeniden yükleyin.
Yinelenen Bilinmeyen Bilgisayar nesnelerini kaldırma
Sorunu düzeltmeye çalıştığınızda Sitede Bilinmeyen Bilgisayar nesneleri yeniden oluşturulduysa, ek Bilinmeyen Bilgisayar nesneleri silinmelidir. Bunu başarmak için, etkilenen site için tüm geçerli Bilinmeyen Bilgisayar nesnelerinin silinmesi ve ardından site için yepyeni bir Bilinmeyen Bilgisayar nesneleri kümesi oluşturulması gerekir. Bilinmeyen Bilgisayar nesnelerini silme işlemi yalnızca SQL Server veritabanından tamamlanabilir. Configuration Manager konsolundan yapılamaz.
Not
Birden çok birincil site varsa birden çok Bilinmeyen Bilgisayar nesnesi olması kabul edilebilir. Ancak, her sitenin mimari başına yalnızca bir Bilinmeyen Bilgisayar nesnesi olmalıdır. Örneğin, x64 Bilinmeyen Bilgisayar etiketli yalnızca bir x64 nesnesi ve x86 Bilinmeyen Bilgisayar etiketli yalnızca bir x86 nesnesi olmalıdır.
Ek Bilinmeyen Bilgisayar nesnelerini silmek için şu adımları izleyin:
Yerleşik Yedekleme bakım görevini kullanarak Configuration Manager sitesinin geçerli ve geçerli bir yedeğine sahip olduğunuzdan emin olun.
Configuration Manager konsolunu açın. Birden çok birincil site varsa, merkezi yönetim sitesine bağlı bir Configuration Manager konsolu açmanızı öneririz.
Configuration Manager konsolunda Varlıklar ve Uyumluluğa>Genel Bakış>Cihaz Koleksiyonları'na gidin.
Tüm Bilinmeyen Bilgisayarlar koleksiyonuna çift tıklayın.
Sonuçlar bölmesinde, Site Kodu sütununu seçerek Tüm Bilinmeyen Bilgisayarlar koleksiyonundaki nesneleri sıralayın.
Herhangi bir site için birden çok x64 Bilinmeyen Bilgisayar nesnesi veya x86 Bilinmeyen Bilgisayar nesnesi olup olmadığına dikkat edin.
Herhangi bir site için birden çok x64 Bilinmeyen Bilgisayar nesnesi veya x86 Bilinmeyen Bilgisayar nesnesi varsa, sonuçlar bölmesindeki sütunlara sağ tıklayın ve kaynak kimliğini sütun listesine ekleyin.
Herhangi bir site için her x64 Bilinmeyen Bilgisayar nesnesi ve her x86 Bilinmeyen Bilgisayar nesnesi için Kaynak Kimliği değerini belirleyin. Bilinmeyen Bilgisayar nesnelerinden yalnızca biri çoğaltılmış olsa bile tüm Bilinmeyen Bilgisayar nesnelerinin kaynak kimliğini not edin.
Bir sitenin Bilinmeyen Bilgisayar nesnelerinin Kaynak Kimliklerini belirledikten sonra, sitenin x64 Bilinmeyen Bilgisayar nesneleri ve x86 Bilinmeyen Bilgisayar nesneleri silinebilir.
SQL Server Management Studio'yu açın ve ardından ek Bilinmeyen Bilgisayar nesnelerini barındıran sitenin veritabanına bağlanın.
Veritabanları düğümünü genişletin ve Configuration Manager veritabanını seçin (genellikle CM_Site_Code).
Araç çubuğunda Yeni Sorgu'yu seçin.
Araç çubuğundaki Yürüt düğmesinin sol tarafındaki açılan menüde doğru veritabanının seçili olduğundan emin olun.
Sorgu bölmesinde aşağıdaki SQL sorgusunu çalıştırın:
SELECT C.CollectionID, C.SiteID, C.CollectionName, CM.MachineID, CM.Name FROM Collections C JOIN CollectionMembers CM ON C.SiteID = CM.SiteID JOIN UnknownSystem_DISC USD ON USD.ItemKey = CM.MachineID
Bu sorgu, tüm Bilinmeyen Bilgisayar nesnelerinin ait olduğu tüm koleksiyonları görüntüler. Bilinmeyen Bilgisayar nesnelerinin üyesi olduğu koleksiyonları belirlemek için bu sorguyu kullanın. Yeni Bilinmeyen Bilgisayar nesneleri kümesi oluşturulduğunda uygun koleksiyonlara geri eklenebilmeleri için bu bilgileri not edin. Kaynak Kimliği MachineID sütununda listelenir.
Sorgu bölmesinde aşağıdaki SQL sorgusunu çalıştırın:
SELECT * FROM UnknownSystem_DISC WHERE ItemKey IN ('Resource_ID_1','Resource_ID_2', 'Resource_ID_3')
Bu sorguda,
Resource_ID_x
9. adımda belirlendiği gibi sitenin Bilinmeyen Bilgisayar nesnelerinin her birinin Kaynak Kimliğidir. Örneğin, Kaynak Kimlikleri 2046820354 ve 2046820355 ise sorgu aşağıdaki gibi olur:SELECT * FROM UnknownSystem_DISC WHERE ItemKey IN ('2046820354','2046820355')
15. adımda sorgu tarafından döndürülen kayıtların doğru olduğunu doğrulayın. Varsa, kayıtları silmek için aşağıdaki sorguyu çalıştırın:
DELETE FROM UnknownSystem_DISC WHERE ItemKey IN ('Resource_ID_1','Resource_ID_2', 'Resource_ID_3')
Bu sorguda,
Resource_ID_x
9. adımda belirlendiği gibi sitenin Bilinmeyen Bilgisayar nesnelerinin her birinin Kaynak Kimliğidir. Örneğin, Kaynak Kimlikleri 2046820354 ve 2046820355, silme sorgusu aşağıdaki gibi olacaktır:DELETE FROM UnknownSystem_DISC WHERE ItemKey IN ('2046820354', '2046820355')
Not
Etkilenen site için x64 ve x86 olan tüm Bilinmeyen Bilgisayar nesnelerini silmeyi unutmayın( bunlardan yalnızca biri yinelenmiş olsa bile).
Etkilenen site için yeni Bilinmeyen Bilgisayar nesneleri oluşturmak üzere yanlışlıkla silme durumunda Bilinmeyen Bilgisayar nesnelerini yeniden oluşturma bölümünü izleyin.
Configuration Manager konsoluna dönün ve Varlıklara ve Uyumluluğa>Genel Bakış>Cihaz Koleksiyonları'na gidin.
Tüm Bilinmeyen Bilgisayarlar koleksiyonuna sağ tıklayın ve ardından Üyeliği Güncelleştir'i seçin.
Birkaç dakika bekleyin ve yenile'yi seçin. Her site için yalnızca bir x64 Bilinmeyen Bilgisayar nesnesinin veya x86 Bilinmeyen Bilgisayar nesnesinin var olduğunu doğrulayın. Nesneler görüntülenmiyorsa, birkaç dakika daha bekleyin ve yeniden deneyin.
Yeni Bilinmeyen Bilgisayar nesneleri göründükten sonra, bunları 14. adımda belirlenen uygun koleksiyonlara geri ekleyin.
Gerekirse tüm ek birincil siteler için 10-21 arası adımları yineleyin.
Yanlışlıkla silme durumunda Bilinmeyen Bilgisayar nesnelerini yeniden oluşturma
Herhangi bir nedenle, bu işlemi kullanan herhangi bir site için tüm Bilinmeyen Bilgisayar nesneleri yanlışlıkla silinirse, aşağıdaki adımlar kullanılarak yeniden oluşturulabilir. Bu adımlar yalnızca site için Bilinmeyen Bilgisayar nesneleri yoksa uygulanmalıdır. Bir sitede iki Bilinmeyen Bilgisayar nesnesinden yalnızca biri varsa, bu makalenin Yinelenen Bilinmeyen Bilgisayar nesnelerini kaldırma bölümündeki adımları kullanarak kalan bir Bilinmeyen Bilgisayar nesnesini silin ve aşağıdaki adımları izleyin:
Bilinmeyen Bilgisayar nesnelerinin eksik olduğu birincil site sunucusunda oturum açın.
Yükseltilmiş bir komut isteminde aşağıdaki komutu çalıştırın:
REG.exe ADD "HKLM\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_DISCOVERY_DATA_MANAGER" /v CreatedUnknownDDR /t REG_DWORD /d 0 /f
Bu kayıt defteri anahtarı değeri güncelleştirildikten sonra, Bilinmeyen Bilgisayar nesneleri kısa süre sonra otomatik olarak yeniden oluşturulmalıdır. Bilinmeyen Bilgisayar nesnelerini oluşturma işleminin ilerleme durumunu birincil site sunucusundaki DDM.log dosyasında de kontrol edebilirsiniz.
Bilinmeyen Bilgisayar kayıtlarının rekreasyonunu hızlandırmak için aşağıdaki adımları izleyerek iş parçacığını SMS_DISCOVERY_DATA_MANAGER
yeniden başlatın:
Bilinmeyen Bilgisayar nesnelerinin eksik olduğu birincil sitede Configuration Manager konsolunu açın ve ardından İzlemeye>Genel Bakış>Sistem Durumu>Bileşen Durumu'na gidin.
Araç çubuğunda Configuration Manager Service Manager'ı Başlat'ı>seçin.
Configuration Manager Service Manager'da, site kodunun altındaki düğümü genişletin ve ardından Bileşenler'i seçin.
Sonuçlar bölmesinde SMS_DISCOVERY_DATA_MANAGER sağ tıklayın ve Sorgu'yu seçin. İş parçacığı Çalışıyor olarak görüntülenmelidir.
SMS_DISCOVERY_DATA_MANAGER sağ tıklayın ve ardından Durdur'a tıklayın.
SMS_DISCOVERY_DATA_MANAGER sağ tıklayın ve ardından Sorgu'ya tıklayın.
Not
İş parçacığı Durduruldu olarak görüntülenmelidir.
SMS_DISCOVERY_DATA_MANAGER sağ tıklayın ve ardından Başlat'a tıklayın.
SMS_DISCOVERY_DATA_MANAGER sağ tıklayın ve ardından Sorgu'ya tıklayın.
Not
İş parçacığı Çalışıyor olarak görüntülenmelidir.
Configuration Manager Service Manager penceresini kapatın.
Bilinmeyen Bilgisayar nesneleri kısa süre içinde otomatik olarak yeniden oluşturulmalıdır. Bu işlemin ilerleme durumunu birincil site sunucusundaki DDM.log dosyasında de kontrol edebilirsiniz.