Aracılığıyla paylaş


Salesforce CRM'de eksik nesne erişimi nedeniyle kayıtlar güncelleştirilemiyor

Bu makale, Salesforce CRM'de eksik nesne erişimi nedeniyle kullanıcılar Sales için Microsoft Copilot'ta CRM kayıtlarını güncelleştiremediğinde karşılaşılan sorunları gidermenize ve çözmenize yardımcı olur.

Not

Microsoft Sales Copilot, Ocak 2024'te Microsoft Copilot for Sales olarak yeniden tanımlanmıştır. Bu makaledeki ekran görüntüsü yakında yeni adla güncelleştirilecektir.

Kimler etkilenir?

Gereksinim türü Açıklama
İstemci uygulaması Sales Outlook eklentisi için Copilot
Ortam Web ve masaüstü istemcileri
OS Windows ve Mac
Dağıtım Kullanıcı tarafından yönetilen ve yönetici tarafından yönetilen
CRM Salesforce
Kullanıcılar Copilot for Sales'ten CRM kaydını güncelleştirmeye çalışan kullanıcılar

Belirtiler

Kullanıcı Outlook için Satışlar için Copilot eklentisinden crm kaydını güncelleştirmeye çalıştığında aşağıdaki hata iletisi görüntülenir:

Salesforce'ı güncelleştirmek için bu nesne için düzenleme erişimi isteyin.

Salesforce CRM'de eksik nesne erişimi nedeniyle kayıtları güncelleştirememe hatası.

Neden

Kullanıcının Salesforce'taki bir nesneye düzenleme erişimi yoktur.

Kullanıcı bir nesneyi düzenlemeye çalıştığında, Sales için Copilot kullanıcının Salesforce'ta nesneye Yazma erişimi olup olmadığını denetler. Kullanıcının nesneye Yazma erişimi yoksa hata iletisi görüntülenir.

Günlüklerde aşağıdaki hatayı görüyorsanız, sorunun kök nedeninin kullanıcının varlığa Yazma erişimine sahip olmadığını onaylayabilirsiniz:

Exception thrown in VivaSalesContacts/UpdateContact -  
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId:<CLIENT REQUEST ID>-self --->  
System.Exception: {  
    "status": 400,  
    "message": "Object type contact is not supported. If you are attempting to use a custom object, be sure to append the '__c' after the entity name.  
                Please reference your WSDL or the describe call for the appropriate names\r\nclientRequestId: <CLIENT REQUEST ID>-self",  
    "error": null,  
    "source": "Salesforce.Common",  
    "errors": []  
} 

Yukarıdaki hata iletisinde, Object type contact is not supported kullanıcının nesneye ContactYazma erişimi olmadığını gösterir.

Çözüm

Sorunu çözmek için kullanıcının aşağıdakilere sahip olduğundan emin olun:

  • Kullanıcının Salesforce'ta düzenlemeye çalıştığı nesneye yönelik okuma veya yazma düzeyi izinleri.
  • Düzenleme için yapılandırılmış tüm alanlar için okuma veya yazma izinleri.

Salesforce'ta nesne düzeyinde güvenlik, alan düzeyi güvenlik ve kayıt düzeyi güvenlik hakkında bilgi için bkz . Kimlerin Ne Göreceğini Denetleme. Profillerde nesne izinlerini ayarlama konusunda yardım için Salesforce yöneticinize de başvurabilirsiniz.

Daha fazla bilgi

Sorununuz hala çözümlenmemişse uzmanlarımızla etkileşime geçmek için Copilot for Sales - Microsoft Community Hub'a gidin.

Üçüncü taraf bilgileri hakkında yasal uyarı

Bu makalede adı geçen üçüncü taraf ürünleri Microsoft'tan bağımsız şirketler tarafından üretilmektedir. Microsoft, bu ürünlerin performansı veya güvenilirliği ile ilgili örtük veya başka türlü hiçbir garanti vermez.

Üçüncü tarafla iletişim sorumluluk reddi

Microsoft, bu konu hakkında ek bilgi bulmanıza yardımcı olmak için üçüncü taraf iletişim bilgileri sağlar. Bu iletişim bilgileri önceden haber verilmeksizin değiştirilebilir. Microsoft, üçüncü taraf iletişim bilgilerinin doğruluğunu garanti etmez.