Aracılığıyla paylaş


"API'leri kullanarak Salesforce'a erişmek için CRM yöneticinizden izin isteyin" hatası

Bu makale, Sales için Microsoft Copilot'ta Salesforce CRM'ye bağlanıp oturum açtıktan sonra bir hata iletisi görüntülendiğinde sorunları gidermenize ve çözmenize yardımcı olur.

Not

Microsoft Sales Copilot, Ocak 2024'te Microsoft Copilot for Sales olarak yeniden tanımlanmıştır. Bu makaledeki ekran görüntüleri yakında yeni adla güncelleştirilecektir.

Kimler etkilenir?

Gereksinim türü Açıklama
İstemci uygulaması Sales Outlook eklentisi için Copilot
Ortam Web ve masaüstü istemcileri
OS Windows ve Mac
Dağıtım Kullanıcı tarafından yönetilen ve yönetici tarafından yönetilen
CRM Salesforce
Kullanıcılar Salesforce CRM ile Copilot for Sales kullanmaya çalışan kullanıcılar

Belirtiler

Outlook için Copilot for Sales eklentisi aracılığıyla Salesforce CRM'de oturum açtığınızda aşağıdaki hata iletisi görüntülenir:

API'leri kullanarak Salesforce'a erişmek için CRM yöneticinizden izin isteyin

API izin hatasını gösteren ekran görüntüsü.

Neden

Bu sorun, Salesforce'ta API izinleriniz olmadığında oluşur. Günlüklerde aşağıdaki hatayı görürseniz sorunun kök nedeninin bu olup olmadığını onaylayabilirsiniz:

Exception thrown in VivaSalesContacts/GetContactsByEmailAddress - 
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId: {CLIENT REQUEST ID HERE}-self ---> 
System.Exception: { 
    "error": { 
        "code": 502, 
        "source": "{APIM SOURCE}", 
        "message": "BadGateway", 
        "innerError": { 
            "status": 502, 
            "message": "Salesforce failed to complete task: Message: **API is disabled for this User**\r\nclientRequestId: {CLIENT REQUEST ID HERE}", 
            "error": null, 
            "source": "Salesforce.Common", 
            "errors": [] 
        } 
    } 
} 

Çözüm

Yönetici, aşağıdaki adımları izleyerek kullanıcıya veya etkilenen kullanıcının profiline API Etkin izni verebilir:

  1. Salesforce'ta yönetici olarak oturum açın.

  2. Arama kutusuna Kullanıcı yazın.

  3. Sol gezinti bölmesinde Profiller'i ve ardından etkilenen kullanıcının profilini seçin.

  4. Yönetim İzinleri bölümünde API Etkin'i seçin.

  5. Kaydet'i seçin.

    Profiller sayfasında API Etkin seçeneğini gösteren ekran görüntüsü.

Daha fazla bilgi

Sorununuz hala çözümlenmemişse uzmanlarımızla etkileşime geçmek için Copilot for Sales - Microsoft Community Hub'a gidin.

Üçüncü taraf bilgileri hakkında yasal uyarı

Bu makalede adı geçen üçüncü taraf ürünleri Microsoft'tan bağımsız şirketler tarafından üretilmektedir. Microsoft, bu ürünlerin performansı veya güvenilirliği ile ilgili örtük veya başka türlü hiçbir garanti vermez.