Aracılığıyla paylaş


SQL Server'da yinelenen bir Batch Tag değeri kullanıldığında MDS varlık tabanlı hazırlama başarısız olabilir

Bu makale, SQL Server'da yinelenen bir Batch Tag değeri kullanıldığında Ana Veri Hizmetleri (MDS) varlık tabanlı hazırlamanın başarısız olması sorununu çözmenize yardımcı olur.

Özgün ürün sürümü: SQL Server
Özgün KB numarası: 2712547

Belirtiler

Aşağıdaki senaryoyu değerlendirin:

  • Verileri MDS'ye aktarmak için Microsoft SQL Server MDS varlık tabanlı hazırlama işlemini kullanırsınız.

  • Toplu işlemi tanımlamak için sütununu kullanarak BatchTag çeşitli MDS hazırlama tablolarını (stg.name) hazırlama verileriyle doldurursunuz.

  • Farklı bir MDS modelindeki farklı bir varlığa ait ayrı bir hazırlama tablosunu doldurmak için aynı BatchTag değeri kullanırsınız.

  • Toplu işlemeyi başlatmak için gerekli saklı yordamları çalıştırırsınız. İsterseniz hazırlama toplu işlemini MDS web sitesindeki Integration Management işlevsel alanından da başlatabilirsiniz.

Hazırlama işlemini başlattığınızda, üç saklı yordamdan birini kullanırsınız:

  • stg.udp_name_Leaf

  • stg.udp_name_Consolidated

  • stg.udp_name_İlişki

Not

Ad <> yer tutucusu, varlık oluşturulduğunda belirtilen hazırlama tablosunun adıdır.

Aşağıdaki örneklerde hazırlama saklı yordamını kullanarak hazırlama işleminin nasıl başlatileceği gösterilmektedir:

  • exec mds.stg.udp_entityname1 'versionAdescription',0,'batchtag'

  • exec mds.stg.udp_entityname2 'versionBdescription',0,'batchtag'

Bu senaryoda, hazırlama işlemini başlattığınızda aşağıdaki hata iletisini alırsınız:

MDSERR310029
Belirtilen toplu iş durumu geçerli değil.

Ayrıca, toplu iş durumunu denetlediğinizde, değeri olan BatchTag toplu işlemin süresiz olarak Çalışıyor durumunda takıldığını fark edeceksiniz.

Not

MDS web sitesinden Tümleştirme Yönetimi'ne tıklayıp durumu görüntülemek için modeli seçerek veya tabloyu sorgulayarak [mdm].[tblStgBatch] toplu iş durumunu denetleyebilirsiniz.

Neden

Bu sorun, MDS varlık tabanlı hazırlama işleminin MDS modelinden bağımsız olarak durumu denetlemesi BatchTag nedeniyle oluşur.

Çözüm

Toplu işleminiz Çalışıyor durumunda takılı kalırsa toplu işlemi durdurun ve toplu işlemi yeniden işlemeyi deneyin. Toplu işlemi durdurmak için SQL deyimini çalıştırın: Exec [mdm].[udpStagingBatchQueueActivate]. Bu sorunu çözmek için, kayıtların hazırlama tablosundaki BatchTag değerini yeni bir adla güncelleştirin. Ayrıca, alanın kayıtlar için 0importstatus_IDayarlandığından emin olun.

Daha Fazla Bilgi

Hazırlama işlemini başlatma hakkında daha fazla bilgi için aşağıdaki web sitesine gidin: