Aracılığıyla paylaş


Yarı genişlikli ve Tam Genişlikli Katakana ve Hiragana karakterleri, consonant işaretleri ile farklı olarak değerlendirilir

Bu makale, .NET Framework 4 olduğunda oluşan bir sorunu çözmenize yardımcı olur.x uygulamaları Japonca dizeleri karşılaştırır.

Şunlar için geçerlidir: Windows 10 sürüm 2004, Windows 10 sürüm 20H2, Windows 10 sürüm 21H1, Windows 10 sürüm 21H2, Windows 10 sürüm 22H2

Belirtiler

Bazı Japonca yarım genişlikli ve tam genişlikte Katakana ve Hiragana karakterleri, bir harf işaretiyle aynı karakter olarak yorumlanmamıştır. Karşılaştırma yapmak için yöntemini ve IgnoreKanaType veya IgnoreWidth seçeneklerini CompareOptions kullandığınızdaCompareInfo.IndexOf, sıralama kuralındaki bir sorun nedeniyle bu karakterler farklı olarak değerlendirilir.

Neden

2004 sürümünden itibaren Windows 10, Ulusal Dil Desteği (NLS) sürümünü 6.3'e güncelleştirdi ve Arapça ve İbranice desteği ekledi. Bu ekleme, karşılaştırmaların farklı sonuçlar üretmesi için NLS kullanan Japonca dize karşılaştırmalarını sıralama kurallarını etkiler.

Geçici çözüm

Uyarı

Kayıt defterini hatalı olarak değiştirirseniz önemli sorunlar oluşabilir. Bu sorunlar, işletim sistemini yeniden yüklemenize ve hatta makinenizin başlatılmasını engellemenize neden olabilir. Microsoft, bu sorunların çözülebileceği konusunda garanti veremez. Değiştirmeden önce, bir sorun olması halinde geri yükleyebilmek için kayıt defterini yedekleyin. Kayıt defterini değiştirmek kendi sorumluluğunuzdadır.

Geçici çözüm 1

NLS sıralama kuralını sürüm 6.2'ye geri döndür. Bu sürüm Windows 10, sürüm 1909 ve önceki sürümlerde kullanılır. Sistemler arasında veri paylaşmanız gerektiğinde geçici çözümü tutarlı bir şekilde uygulamayı göz önünde bulundurun. Bu geçici çözümü kullanırsanız, birden çok sistemdeki farklı sıralama kuralı sürümlerinin neden olduğu sorunları azaltmak için yeterli test ve değerlendirmeler yapın.

Bu geçici çözümü kullanmak için şu adımları izleyin:

  1. Yönetici olarak bir Komut İstemi penceresi (cmd.exe) açın.

  2. Şu komutu çalıştırın:

    reg add HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\Sorting\Versions /ve /d 0006020F /f

  3. Tam etkiyi görmek için bilgisayarı veya işlemleri yeniden başlatın.

Önemli

Bilgisayara KB4586853 veya daha sonraki bir güncelleştirmeyi yüklemediyseniz, bu kayıt defteri girdisinde geçersiz bir değer ayarlamak bilgisayarın başlatılmasını engelleyebilir.

Geçici çözüm 2

NLS sıralama kuralını sürüm 6.4 olarak ayarlayın. Bu sürüm Windows 11'de kullanılır. Bunu yapmak için KB5014023 veya sonraki bir güncelleştirmeyi uygulamanız ve sürümü 1741 veya sonraki bir sürüme yükseltmeniz gerekir. Bu durumda, sürüm 22H2 zaten uygulanır ve güncelleştirilmesi gerekmez.

  1. Windows 10 sürüm 2004, 20H2, 21H1 ve 21H2 için KB5014023 veya sonraki bir güncelleştirme uygulayın.

  2. Yönetici olarak Komut İstemi penceresini (cmd.exe) açın.

  3. Şu komutu çalıştırın:

    reg add HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\Sorting\Versions /ve /d 00060403 /f

  4. Tam etkiyi görmek için bilgisayarı veya işlemleri yeniden başlatın.