Azure virtual machine (VM) is unavailable for 15 minutes

This article explains why you might receive an alert that states "VM is unavailable for 15 minutes" in either Resource Health or the activity log.

Symptoms

You receive an alert in Resource Health or the activity log that states, "VM is unavailable for 15 minutes."

Cause

You might receive this alert when a virtual machine (VM) is being deleted, stopped, de-allocated, or restarted. Although the notification is sent from the platform, the operation isn't necessarily initiated by the platform. In certain cases, when the operation is finished, the platform continues to report poor health. These reports indicate that the VM was unavailable for more than 15 minutes. For more information about activity log and Resource Health data, see the "Missing VM downtimes in activity log" section of Understand a system reboot for Azure VM.

More information

Microsoft is investing in better platform health coordination and reporting. This investment is part of Project Flash. This project is designed to display highly accurate and actionable VM availability information.

For more information about Azure Resource Health, see Resource Health overview.

Contact us for help

If you have questions or need help, create a support request, or ask Azure community support. You can also submit product feedback to Azure feedback community.