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Unexpected SmartScreen block or warning on website

When you visit a website in Microsoft Edge, Microsoft Defender SmartScreen might block the site or display a warning if it determines that the site is potentially unsafe. This article discusses the criteria that SmartScreen uses to determine whether a site is potentially unsafe, and how to resolve the issue if a site is incorrectly marked as unsafe.

Symptoms

When you visit a website, Microsoft Edge displays a warning page that indicates that the site is reported as unsafe.

View of the SmartScreen block page.

Cause

Microsoft Defender SmartScreen determines whether a site is potentially unsafe based on several factors, as listed in the following table.

Dimension Description
URL Reputation Newly registered domains, malicious history, hosting provider, and traffic volume
Page Content Presence of deceptive forms, malicious scripts, or phishing pages
File Behavior Whether sensitive files are downloaded and their signature status
TLS Security Certificate validity and protocol version
User Feedback Number of reports and trust level
Dynamic Behavior JavaScript activity, redirects, and obfuscation

If a site fails these dimension checks, SmartScreen reports the site as unsafe.

Solution

If you believe the warning or block was incorrectly shown for a safe site, you can report it to Microsoft using the following steps.

If you're the website owner

  1. Select Report that this site doesn't contain (malware/phishing) threats under the More information header on the block page.

    A SmartScreen block page that has the link to 'Report that this site doesn't contain malware threats' highlighted.

  2. Wait for a confirmation email message from the SmartScreen Reputation Group.

  3. If the issue is urgent, or you need a response after the Reputation Group's investigation, reply to the message from the Reputation Group to present your concerns.

If you're not the website owner

  1. Reach out to the website owner, and recommend that they report the issue by using the steps in If you're the website owner.

  2. Both the site owner and you can report the issue by using the WDSI file submission portal. For more detailed information about submitting files for analysis, see Submit files for analysis.

Prevent your site from being blocked

To reduce the likelihood of SmartScreen blocking your site:

  1. Enable HTTPS, and use a valid certificate.
  2. Block iframe from loading unknown third-party content.
  3. Use Content Security Policy (CSP) and other secure response headers.
  4. Regularly scan for WebShells, trojans, and suspicious uploaded files.
  5. Maintain domain reputation and avoid frequent changes to hosting or DNS.