Email路由器无法从 Microsoft Dynamics 发送电子邮件,因为权限
本文提供了Email路由器由于权限而无法从 Microsoft Dynamics 发送电子邮件的问题的解决方案。
适用于:Microsoft Dynamics 365 Customer Engagement Online
原始 KB 编号: 4494727
症状
使用Dynamics 365 Email路由器从Dynamics 365实例发送电子邮件时,电子邮件可能进入“挂起发送”状态,并且永远不会实际发送:
Dynamics Email 路由器异常日志可能会显示以下错误:
检查要处理的传出电子邮件时出错:
https://disco.crm.dynamics.com/\<OrgName>
。 System.ServiceModel.FaultException'1[Microsoft.Xrm.Sdk.OrganizationServiceFault]:用户不具有 send-as 权限。 (故障详细信息等于异常详细信息:ErrorCode: 0x8004480D
消息:用户不具有“发送即发送”权限。
原因
此行为可能已在无需对早期版本的 Dynamics 365 应用程序具有这些权限的情况下起作用。 由于某些版本 8.2.2 和 9.x 迭代中引入了安全模型更改,因此必须显式授予这些权限,以便电子邮件路由器为其他用户发送电子邮件。
解决方案
发送此电子邮件的用户必须允许从其他 Dynamics 用户的个人选项发送电子邮件:
Email路由器使用的帐户还必须在 Dynamics 中具有“以其他用户身份发送Email”权限:
更多信息
反馈
https://aka.ms/ContentUserFeedback。
即将发布:在整个 2024 年,我们将逐步淘汰作为内容反馈机制的“GitHub 问题”,并将其取代为新的反馈系统。 有关详细信息,请参阅:提交和查看相关反馈