尝试在 Microsoft Dynamics 365 中导入解决方案修补程序时出现错误代码80048539
本文提供有关尝试在 Microsoft Dynamics 365 中导入解决方案修补程序时可能发生的错误代码 80048539 的解析。
适用于: Microsoft Dynamics 365
原始 KB 编号: 4471087
症状
尝试在 Microsoft Dynamics 365 中导入解决方案修补程序时,会遇到以下错误:
解决方案的导入:[解决方案修补程序名称]失败。
错误代码80048539。
如果下载日志文件并在 Excel 中打开它,则会看到更多详细信息,例如:
症状 1 详细信息:
故障0x80048539
解决方案清单导入:失败:对于父版本 1.1.0.0,修补程序版本 1.0.1.0 无效
症状 2 详细信息:
故障0x80048539
解决方案清单导入:失败:保留解决方案MyPatchTesting_Upgrade已存在。
原因
注意
如果使用 make.powerapps.com 导入非托管解决方案更新并收到此错误,Microsoft 会意识到此问题并正在进行修复。 若要解决此问题,请打开 “高级 ”设置,并选择“ 更新”选项 (不建议) 。
错误代码 80048539 指示正在导入无效修补程序。 有几个潜在原因,包括:
原因 1
如果看到上述“症状 1 详细信息”部分中提到的错误详细信息:
解决方案修补程序版本低于已安装的解决方案版本。 例如:名为 SolutionA 的解决方案已随版本 1.1.0.0 一起安装,你正在尝试导入版本 1.0.1.0 的修补程序。
原因 2
如果看到上述“症状 2 详细信息”部分中提到的错误详细信息:
如果已为该解决方案导入升级,但尚未应用升级,则可能会发生这种情况。 导入作为现有解决方案升级的解决方案后,解决方案导入的末尾会提供一个用于应用解决方案升级的按钮。 如果在之前导入此解决方案的解决方案升级期间未选择该按钮,则需要在解决方案列表中找到解决方案并选择“ 应用解决方案升级 ”按钮。
解决方案
解决方法 1
如果看到上述“症状 1 详细信息”部分中提到的错误详细信息:
验证尝试导入的解决方案修补程序版本是否比已安装的解决方案版本更高。
解决方法 2
如果看到上述“症状 2 详细信息”部分中提到的错误详细信息:
导航到 “设置”、“ 自定义”,然后选择 “解决方案”。 选择尝试升级的现有已安装解决方案,然后选择 “应用解决方案升级”。
反馈
提交和查看相关反馈