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使用 Microsoft Dynamics 365 App for Outlook 時,無法連線到 Exchange 訊息

本文提供使用 Microsoft Dynamics 365 App for Outlook 時,您收到無法連線到 Exchange 訊息的問題解決方案。

適用於:Microsoft Dynamics 365 Customer Engagement Online
原始 KB 編號: 4534356

徵狀

使用 Microsoft Dynamics 365 App for Outlook 時,您會看到下列訊息:

「無法連線到 Exchange」。

應用程式的其餘部分可能會成功載入,但追蹤專案和使用[關於設定] 的能力可能遺失。

原因

這通常會在使用 Microsoft Exchange 內部部署信箱時發生,可能是下列其中一個原因所造成:

原因 1: Exchange 中未啟用 OAuth 驗證。
原因 2: Exchange 使用的驗證憑證有問題。

解決方案 1:確認已在 Exchange 中啟用 OAuth 驗證

  1. 在 Exchange 伺服器上,開啟 Exchange 管理命令介面

  2. 執行下列命令:

    Get-WebServicesVirtualDirectory | FL server,*auth
    
  3. 確認傳回的結果顯示 OAuthAthentication 設定為 True

  4. 如果 OAuthAthentication 設定為 False,則必須執行下列命令:

    Set-WebServicesVirtualDirectory -Identity "EWS (Default Web Site)" -OAuthAuthentication $true
    

    識別值是可在 Exchange 管理員 中心找到的虛擬目錄名稱,方法是選取伺服器,然後選取虛擬目錄,或執行下列命令並檢閱傳回的 Name 值:

    Get-WebServicesVirtualDirectory | FL
    

    如需此命令的詳細資訊,請參閱 Set-WebServicesVirtualDirectory

    如需允許 Outlook 載入宏 (EWS) 要求進行異步 Exchange Web 服務驗證需求的詳細資訊,請參閱 makeEwsRequestAsync 的驗證和許可權考慮

  5. 執行下列命令:

    Get-OrganizationConfig | FL OAuth2ClientProfileEnabled
    

    如果傳回的值為 False,請執行下列命令:

    Set-OrganizationConfig -OAuth2ClientProfileEnabled:$True
    
  6. 另請確認您的 Exchange 版本具有 2016 年 Exchange Server Exchange Server 2013 中無法透過 makeEwsRequestAsync 從 Outlook/OWA 載入宏存取 EWS 中所述的更新。

解決方法 2:驗證 Exchange 憑證

  1. 在 Exchange 伺服器上,開啟 Exchange 管理命令介面

  2. 執行下列命令:

    Get-AuthConfig | FL

  3. 確認結果顯示 IsValidTrue

  4. 複製針對 CurrentCertificateThumbprint 傳回的值,並在下列命令中使用它:

    Get-ExchangeCertificate -Thumbprint <CurrentCertificateThumbprint Value>| FL
    
  5. 確認結果顯示下列專案:

    狀態 = 有效

    目前的日期是在 NotAfter 和 NotBefore 日期內,表示憑證尚未過期。

    如果先前的命令未成功擷取憑證,這表示憑證組態有問題,可能需要您建立和設定新的憑證。 以下是一些資源,其中包含建立和設定新憑證的步驟:

如果遵循上述步驟之後需要進行任何變更,請關閉並重新開啟 Outlook,以查看問題是否已解決。 如果問題持續發生,且您的 Microsoft Exchange 系統管理員已驗證 OAuth 已啟用且憑證有效,則可能需要連絡 Microsoft 支援服務。