當您設定 Outlook 用戶端的 Microsoft Dynamics CRM 時,對象參考未設定為物件錯誤訊息的實例

本文提供當您設定 Outlook 用戶端 Microsoft Dynamics CRM 時所發生錯誤的解決方案。

適用於:Microsoft Dynamics CRM 2011、Dynamics CRM 2013、Microsoft Dynamics CRM 2013 Service Pack 1、Microsoft CRM client for Microsoft Office Outlook
原始 KB 編號: 2986728

徵狀

當您將 Microsoft Dynamics CRM 2011 或 CRM 2013 for Outlook 用戶端設定為 Microsoft Dynamics CRM Online 實例時,您會收到下列錯誤訊息:

對象參考未設定為 對象的實例

輸入您的認證之後,選擇您的組織,然後選取 [ 確定]

與 Microsoft Dynamics CRM 伺服器通訊時發生問題。 伺服器可能無法使用。 請於稍後再試一次。 如果問題仍然存在,請連絡您的系統管理員。

並未將物件參考設定為物件的執行個體。

at Microsoft.Crm.Passport.IdCrl.OnlineServicesFederationLogOnManager.GetBrowserClientAuthInfo (String redirectEndpoint, String partner, String policy, String& postData)

at Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider'1.SignIn ()

at Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory'1.SignIn (Uri endPoint, Credential credentials, AuthUIMode uiMode, IClientOrganizationContext context, Form parentWindow, Boolean retryOnError)

at Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory'1.GetAuthProvider (Uri endPoint, Credential credentials, AuthUIMode uiMode, Uri webEndPoint, IClientOrganizationContext context, Form parentWindow)

在 Microsoft.Crm.Application.Outlook.Config。ServerInfo.LoadUserId ()

在 Microsoft.Crm.Application.Outlook.Config。ServerInfo.Initialize (Uri discoveryUri, OrganizationDetail selectedOrg, String displayName, Boolean isPrimary)

在 Microsoft.Crm.Application.Outlook.Config。ServerForm.LoadDataToServerInfo ()

在 Microsoft.Crm.Application.Outlook.Config。ServerForm。<InitializeBackgroundWorkers>b__2 (Object sender, DoWorkEventArgs e)

在 System.ComponentModel.BackgroundWorker.OnDoWork (DoWorkEventArgs e)

在 System.ComponentModel.BackgroundWorker.WorkerThreadStart (Object 自變數)

原因

如果您使用的 Microsoft Online Services 登入小幫手版本與 Microsoft Dynamics CRM 2011 或 Microsoft Dynamics CRM 2013 不相容,就會發生此問題。 設定 Outlook 用戶端的 Microsoft Dynamics CRM 並連線到 Microsoft Dynamics CRM Online 實例時,唯一支援的 Microsoft Online Services 登入小幫手版本是 7.250.4259.0、7.250.4287.0 和 7.250.4303.0。

解決方案

若要解決此問題,請遵循下列步驟:

  1. 選取 [開始],輸入 appwiz.cpl,然後按 Enter 鍵以在 控制台 中開啟 [程式和功能] 專案。
  2. 如果 Microsoft Online Services 登入小幫手的版本不符合 7.250.4259.0、7.250.4287.0 或 7.250.4303.0,請將其卸載。
  3. 下載 並重新安裝 7.250.4303.0 版的 Microsoft Online Services 登入小幫手。
  4. 重新啟動您的工作站,並設定 Outlook 用戶端的 Microsoft Dynamics CRM,以確認問題已解決。