在 Microsoft Dynamics 365 中測試和啟用信箱時,出現傳送信箱電子郵件時發生錯誤
本文提供當您嘗試在 Microsoft Dynamics 365 中測試並啟用信箱時所發生錯誤的解決方案。
適用于: Microsoft Dynamics 365
原始 KB 編號: 4092737
徵狀
當您嘗試在 Microsoft Dynamics 365 中測試並啟用信箱時,您會收到下列錯誤:
連線到電子郵件伺服器時,「傳送信箱的電子郵件時發生錯誤」「您的信箱現在已連線到 Dynamics 365」。 已通知相關聯電子郵件伺服器設定檔 < 信箱名稱 > 的擁有者。 系統稍後會嘗試再次傳送電子郵件。
Email伺服器錯誤碼:網頁伺服器傳回 ConnectFailure 例外狀況」。
原因
如果 Dynamics 365 無法連線到您的電子郵件伺服器,就會發生此錯誤。
如果您使用 Dynamics 365 Online 搭配 Exchange 內部部署,如果您的防火牆不允許來自 Dynamics 365 Online 的通訊,就可能發生此情況。
如果您使用 SMTP/POP3 提供者,例如 Gmail,如果電子郵件伺服器設定檔 [進階] 區段內的埠值不正確,就會發生此情況。
解決方案
Dynamics 365 Online 與 Exchange 內部部署
確認您的防火牆允許來自 Dynamics 365 Online 的通訊。 如需 Dynamics 365 可能使用的 IP 位址範圍清單,請參閱Microsoft Dynamics CRM Online IP 位址範圍。
POP3/SMTP 提供者,例如 Gmail
確認已指定正確的埠:
流覽至 [設定],Email組態],然後選取 [Email 伺服器設定檔]。
開啟Email處理此錯誤的信箱所使用的伺服器設定檔。
注意事項
您也可以在錯誤訊息中選取Email伺服器設定檔的名稱。 它會顯示為超連結,這會開啟正確的Email伺服器設定檔記錄。
選取 [進階]。
確認 [ 傳入埠 ] 和 [ 傳出埠 ] 值,然後選取 [ 儲存]。
注意事項
請參閱電子郵件提供者的檔,以取得連線到 SMTP 服務時要使用的正確埠。 針對 Gmail,傳入 POP3 埠為 995,傳出 SMTP 埠為 587。
選取 [信箱] ,然後選取收到錯誤的信箱。
選取 [ 測試 & 啟用信箱] 按鈕。
測試完成之後,開啟信箱記錄,如果結果未顯示為成功,請檢視 [ 警示 ] 區段。