Share via


批次會保留在 Microsoft Dynamics GP 中的 [張貼]、[接收]、[忙碌]、[已標記]、[已鎖定] 或 [已編輯] 狀態中

本文提供錯誤的解決方案,當您嘗試張貼批次並在 Microsoft Dynamics GP 或 Microsoft Business Solutions - Great Analytics 中開啟批次時,就會發生此錯誤。

適用于: Microsoft Dynamics GP
原始 KB 編號: 850289

徵狀

當您嘗試在 Microsoft Dynamics GP 或 Microsoft Business Solutions - Great 擴充中張貼批次之後,批次會被指派下列其中一個狀態:

  • 張貼
  • 接收
  • 忙碌
  • Marked
  • 鎖定
  • 編輯

您無法張貼或取消批次的標記。 當您嘗試開啟批次時,可能會收到下列錯誤訊息:

「Batch 已標示為可供其他用戶張貼。」

原因

發生此問題的原因可能是電源波動或其他問題導致張貼程式停止。

解決方案

注意事項

[解析] 區段中的所有文本都必須在查詢工具中執行。 若要開啟適當的查詢工具,請在 Microsoft SQL Server Management Studio 中執行 語句。 若要開啟 SQL Server Management Studio,請選取 [開始],指向 [程式>] [Microsoft SQL Server (2019) (或您) 的版本,然後選取 [SQL Server Management Studio]。 若要執行文稿,請選取 [追加查詢]

若要解決此問題,請遵循下列步驟:

  1. 請確定您目前擁有公司資料庫的備份,並要求所有用戶結束 Microsoft Dynamics GP。 若要在 Microsoft Dynamics GP 中建立備份,請在所有使用者註銷 Microsoft Dynamics GP 之後,遵循適當的步驟:

    1. 在 [ 檔案] 功能表上,選取 [ 備份]
    2. 在 [ 公司名稱] 列表中,選取您要備份的公司。
    3. 在 [ 選取備份檔] 方塊中,選取黃色資料夾以開啟您要放置備份檔的位置。

    1. 在 物件總管 中,展開您的資料庫,讓您看到想要備份的資料庫。
    2. 以滑鼠右鍵按兩下 [資料庫名稱],移至 [ 工作],然後選取 [ 備份]
    3. 選取 [新增] 按鈕,然後選取您要儲存備份的位置和檔名。
    4. 選取 [確定 ] 以開始備份。
  2. 檢視下表的內容,以確認所有使用者都已註銷: DYNAMICS..ACTIVITYDYNAMICS..SY00800DYNAMICS..SY00801TEMPDB..DEX_LOCKTEMPDB..DEX_SESSION。 若要這樣做,請執行下列腳本。

    SELECT * FROM DYNAMICS..ACTIVITY SELECT * FROM DYNAMICS..SY00800 SELECT * FROM DYNAMICS..SY00801 SELECT * FROM TEMPDB..DEX_LOCK SELECT * FROM TEMPDB..DEX_SESSION
    

    注意事項

    當所有使用者都從 Microsoft Dynamics GP 註銷時,這些數據表中不會有任何記錄。

  3. 如果未傳回任何結果,請移至步驟 4。 否則,請使用下列任何適當的腳本清除停滯的記錄。

    DELETE DYNAMICS..ACTIVITY DELETE DYNAMICS..SY00800 DELETE DYNAMICS..SY00801 DELETE TEMPDB..DEX_LOCK DELETE TEMPDB..DEX_SESSION
    
  4. 針對公司資料庫執行下列腳本。 將 XXX 取代為您嘗試在 Microsoft Dynamics GP 中張貼或選取的批次編號或批次名稱。

    UPDATE SY00500 SET MKDTOPST=0, BCHSTTUS=0 where BACHNUMB='XXX'
    

    注意事項

    BACHNUMB 值與 Microsoft Dynamics GP 中 [批次識別符] 視窗的值相同。

  5. 確認交易的正確性。

  6. 確認您可以編輯並張貼批次。