尝试登录 Microsoft 云服务时出现“AADSTS65005”错误
症状
当你使用公司应用登录到 Microsoft 云服务之一或进行身份验证时,例如 Microsoft 365、Microsoft Intune、Microsoft Dynamics、Microsoft Power BI、Microsoft Azure 或 Microsoft Entra ID Federated Gallery Apps,会收到以下错误消息:
AADSTS65005:客户端应用程序已请求访问资源。 此请求失败,因为客户端未在其 requiredResourceAccess 列表中指定此资源。
原因
出现此问题的原因是公司的应用可能未注册到 Microsoft Entra ID,或者它可能没有应用正确的权限。
解决方案
若要解决此问题,请使用以下资源之一,具体取决于尝试访问的服务:
- Microsoft 365:手动向 Microsoft Entra ID 注册应用,以便它可以访问 Microsoft 365 API
- Dynamics CRM:为 Dynamics CRM 注册应用程序
- 登录到为联合单一登录配置的库应用程序时出现问题
更多信息
有关如何向 Microsoft Entra ID 注册应用的详细信息,请参阅以下 Microsoft 网站: