Outlook 提示输入密码,并且不使用新式身份验证连接到 Microsoft 365

原始 KB 编号: 3126599

症状

请考虑以下应用场景。

场景 1

Microsoft Outlook 使用 RPC 连接到本地 Exchange Server 中的主邮箱,同时还连接到位于 Microsoft 365 中的另一个邮箱。

场景 2

将邮箱从使用 RPC 与 Outlook 连接的 Exchange Server 迁移到 Microsoft 365。

在这些场景中,系统会提示输入凭据,且 Outlook 不会使用新式身份验证连接到 Microsoft 365。 输入凭据后,这些凭据将传输到 Microsoft 365 而不是传输到令牌。

原因

Outlook 将其对身份验证方案的选择限制为 RPC 支持的方案。 但身份验证方案不包括新式身份验证。

解决方案

重要

请仔细遵循本部分中的步骤进行操作。 对注册表修改不当可能会导致严重问题。 修改之前,备份注册表以便在发生问题时进行还原

创建以下注册表项,强制 Outlook 对 Web 服务(如 EWS 和自动发现)使用较新的身份验证方法。 建议用户强制 Outlook 使用新式身份验证。

  1. 退出 Outlook。

  2. 根据你的 Windows 版本,使用以下过程启动注册表编辑器:

    • Windows 10、Windows 8.1 和 Windows 8:按 Windows 键 + R 打开“运行”对话框。 键入“regedit.exe”,然后按 Enter。
    • Windows 7:单击“开始”,在搜索框中键入“regedit.exe”,然后按 Enter。
  3. 在注册表编辑器中,找到并单击下面的注册表子项:

    HKEY_CURRENT_USER\Software\Microsoft\Exchange
    
  4. 在“编辑”菜单上,指向“新建”,然后单击“DWORD 值”

  5. 键入“AlwaysUseMSOAuthForAutoDiscover”,然后按 Enter。

  6. 右键单击“AlwaysUseMSOAuthForAutoDiscover”,然后单击“修改”

  7. 在“数值数据”框中,键入 1,然后单击“确定”

  8. 退出注册表编辑器。

更多信息

如果运行的是 Office 2013,请确保在使用此注册表项之前,Outlook 和 MSO 都已更新到 2015 年 12 月 12 日版本或更高版本。

3114349 2015 年 12 月 8 日,Outlook 2013 更新 (KB3114349)

3114333 2015 年 12 月 8 日,Office 2013 更新 (KB3114333)

注意

Office 2016 不需要更新此注册表项即可正常工作。

有关 RPC 的详细信息,请参阅 Microsoft 365 中的 RPC over HTTP 将于 2017 年 10 月 31 日终止支持