练习:分析数据

已完成

将你学到的一些数据分析原则和技术付诸实践。 在此实验室中,你将使用Excel 网页版分析和可视化数据。

此实验室分析 Rosie 的柠檬水销量,并创建可视化效果,以帮助你从数据中获取见解。

开始前

注意

如果已完成本学习路径中的上一个模块,则可以跳过此“准备工作”部分,直接转到 练习 1:使用数据透视表分析数据。

如果还没有Microsoft 帐户(例如,hotmail.com、live.com 或 outlook.com 帐户),请在 https://signup.live.com 注册一个。

将工作簿上传到 OneDrive

  1. 在 Web 浏览器中,导航到 https://onedrive.live.com 并使用 Microsoft 帐户凭据登录。 应会看到 OneDrive 中的文件和文件夹,如下所示:

    OneDrive“我的文件”文件夹的屏幕截图。

  2. 在“+ 新建”菜单上,选择“文件夹”以创建新文件夹。 可以根据需要进行命名,例如“DAT101”。 显示新文件夹时,选择该文件夹以将其打开。

  3. 在新的空文件夹中,在“⤒ 上传”菜单上,单击“文件”。 然后,当系统提示时,在“文件名”框中,在文件名字段中输入以下地址(可从此处复制并粘贴!):

    https://github.com/MicrosoftLearning/mslearn-data-concepts/raw/main/labfiles/Lemonade_formatted.xlsx
    

    接着,单击“打开”,上传包含 Rosie 的柠檬水数据的 Excel 文件,如下所示:

    将文件上传到 One Drive 的屏幕截图。

    几秒钟后, Lemonade_formatted.xlsx 文件应显示在文件夹中,如下所示:

    OneDrive 中 Lemonade 格式的 x l s x 文件的屏幕截图。

练习 1:使用数据透视表分析数据

数据透视表是切片和切块数据的绝佳方式,可按一个或多个维度汇总数值指标。 在本练习中,你将使用数据透视表查看以各种方式聚合的柠檬水数据。

创建数据透视表

  1. 如果尚未完成,请在 Web 浏览器中导航到 https://onedrive.live.com,并使用 Microsoft 帐户凭据登录。 如果你已完成此学习路径中的上一模块,请打开 Lemonade.xlsx 工作簿,否则请打开你在开始之前部分中上传至相应文件夹内的 Lemonade_formatted.xlsx 文件。 工作簿应如下所示:

    Excel 网页版中的“柠檬水”工作簿的屏幕快照。

  2. 选择数据表中的任意单元格,然后在功能区的“插入”选项卡上单击“数据透视表”,并在新工作表中基于数据表创建数据透视表。 Excel 添加新工作表,其中包含数据透视表,如下所示:

    Excel 网页版中空数据透视表的屏幕截图。

  3. 在“数据透视表字段”窗格中,选择“月份”。 Excel 会自动将“月份”添加到数据透视表的“行”区域,并按时间顺序显示月份名称。

  4. 在“数据透视表字段”窗格中,选择“Sales”。 Excel 自动将“销售总和”添加到数据透视表的“数值”区域,并显示每个月柠檬水销售的总和(总销量),如下所示:

    数据透视表的屏幕截图,显示按月份求和的销售数据。

    现在可以查看按月份聚合的销量,例如,6 月份的销量为 1,056。

添加第二个维度

  1. 在“数据透视表字段”窗格中,选择“日期”。 Excel 会自动将“日期”添加到数据透视表的“行”区域,并显示每个月内每个工作日的柠檬水销售总数(总和),如下所示:

    按月和日分组的销售额数据透视表的截图。

    现在可以看到按工作日聚合的每月销量。 例如,1 月份的销量中有 57 笔是在星期六进行的。 你还可以展开/折叠月份以向上钻取/向下钻取层次结构级别。

  2. 在“数据透视表字段”窗格中,将“日期”从“行”区域拖到“列”区域。 现在,Excel 在行中显示每个月的总销量,在列中显示按工作日细分的销量;如下所示:

    显示按月按行和按日按列分组的销售额的数据透视表的屏幕截图。

    你仍可以看到按工作日细分的每月销量,但也可以看到(在底部行中)全年每个工作日的总销量。 例如,周一总销量为 1,324。

更改聚合

  1. 在“数据透视表字段”窗格的“值”区域中,单击“Sum of Sales”旁边的下拉箭头,然后单击“值字段设置”。

  2. 在“值字段设置”对话框中,选择“平均值”,如下所示:

    设置字段值设置以按平均值汇总值的屏幕截图。

    现在,数据表显示每个月和工作日的平均销量,如下所示:

    显示按月按行和按日按列分组的平均销售额的数据透视表的屏幕截图。

    现在可以按月查看每个工作日的平均销量。 例如,2 月份星期三的平均销量为 19.75。

挑战:数据透视表分析

  1. 修改数据透视表中的字段以查找以下信息:
    • 8 月总收入。
    • 7 月最炎热星期六的温度。
    • 11 月某天分发的最低传单数量。

练习 2:使用图表可视化数据

创建数据可视化效果(如图表)通常更容易识别数据中的趋势和关系。

查看年度销量趋势

  1. 修改上一练习中创建的数据透视表,使其在“行”区域显示“日期”,在“值”区域按顺序显示“销售额”总和和“温度”总和,如下所示:

    显示按日期显示的销售额和温度总计的数据透视表的屏幕截图。

    在继续之前,请确保表类似于显示的表(请注意,日期的格式可能因位置而有所不同)。

  2. 按照以下说明,仅选择包含日期、每日销量和温度值的单元格,但不包括“Date”、“Sum of Sales”和“Sum of Temperature”页眉单元格或“Grand Total”页脚单元格:

    • 单击单元格“A4”,该单元格应包含 2017 年 1 月 1 日的日期值。
    • 然后按 SHIFT + CTRL + ⇨(macOS 上为 SHIFT + ⌘ + ⇨)扩展选择范围以包含销售额和温度值。
    • 然后按 Shift + Ctrl + ⇩(SHIFT + ⌘ + ⇩ 在 macOS 上)选择当前所选内容下方的行。
    • 最后按 SHIFT + ⇧ 取消选择总计。
  3. 在功能区的“主页”选项卡上,单击“复制”按钮 (🗐) 将选定单元格复制到剪贴板。

  4. 在工作表下,单击“新建工作表“按钮 () 向工作簿添加新工作表。

  5. 在新工作表中,选择单元格 A2,然后在“开始”选项卡上单击“粘贴”按钮 (),将复制的单元格粘贴到新工作表中。 你可能需要加宽 A 列才能看到日期。

  6. 在单元格 A1 到 C1 中,添加列标题“日期”、“销售额”和“温度”。 新工作表应如下所示:

    新工作表的屏幕截图,显示按日期统计的销售额和温度总计。

  7. 选择“日期”和“销售”数据,包括表头(但不包括温度数据)。 然后在功能区的“插入”选项卡上,在折线图下拉列表中单击第一个折线图格式。 Excel 插入如下所示的折线图:

    按日期显示销售额的折线图的屏幕截图。

    请注意,折线图显示销量的每日波动,但总体趋势似乎表明,夏季月份销量较高,年初和年底销量较低。

  8. 删除图表,然后选择所有数据和标题(包括“Temperature”),并插入新折线图。 将插入一个这样的图表:

    按日期显示销售额和温度的折线图的屏幕截图。

    此次,图表包含单独的“销售”和“温度”系列。 这两个系列都显示类似模式;在夏季的几个月里,销量和温度似乎都在增加。

  9. 选择图表,然后双击图表标题。 然后在格式选项卡上的图表窗格中,展开图表标题并将图表标题更改为销售和温度。

    在Excel 网页版中编辑图表标题的屏幕截图。

  10. 关闭“图表”窗格。

按工作日查看收入

  1. 返回到包含数据透视表的工作表,并将其修改为在行区域显示“日期”,“收入”平均值如下所示: 结果应如下所示,尽管一周中的天数可能未排序:

    显示每日平均收入的数据透视表的屏幕截图。

  2. 将每日收入值和平均收入值(而不是标题或总计)复制到剪贴板,然后添加新工作表,在单元格 A2 中粘贴复制的数据,并添加“Day”和“AverageRevenue”标题,如下所示:

    显示每日平均收入的新工作表的屏幕截图。

  3. 选择 B 列列标题,然后在功能区“主页”选项卡上,使用 $ 菜单将收入数据格式化为“$ 英语(美国)”,如下所示:

    显示格式为美国货币的每日平均收入的工作表的屏幕截图。

  4. 选择所有数据,包括“日期”和“平均收入”标题,然后在功能区的“插入”选项卡上,在“柱形图”下拉列表中选择第一个柱形图格式。 将创建如下所示的图表:

    显示每日平均收入的柱形图的屏幕截图。

    乍一看,此图表显示一周内不同日子的平均收入之间的一些显著变化:周四的收入远高于周日。 但是,更仔细地查看垂直 (Y) 轴上的刻度 – 差值小于 30 美分。

  5. 选择柱形图,然后在功能区的“图表”选项卡上,在“饼图”下拉列表中选择“二维饼图”格式。 图表将变为如下所示的饼图:

    显示每日平均收入的饼图的屏幕截图。

    请注意,每天饼图段的大小差不多相同。

  6. 选择饼图,然后在“图表”选项卡的“数据标签”下拉列表中选择“居中内部”。 这会在图表中显示实际数据量,如下所示:

    显示带有数据标签的每日平均收入的饼图的屏幕截图。

    现在,很明显,一周不同日的平均收入几乎没有明显变化。

按传单查看销量

  1. 返回到包含数据透视表的工作表,并将其修改为在行区域显示“日期”,“传单”总和和“销售额”总和如下所示:

    按日期显示传单和销售额总计的数据透视表的屏幕截图。

  2. 将日期、传单和销量值(而不是标题或总计)复制到新工作表,并添加标题“Date”、“Flyers”和“Sales”,如下所示:

    新工作表的屏幕截图,显示按日期的传单总数和销售额。

  3. 选择“Flyers”和“Sales”数据和标题(但不选择日期)。 然后在“插入”选项卡上的“散点图”下拉列表中,选择第一个散点图格式。 这会创建如下所示的散点图:

    显示销售额与总飞行量关系的散点图截图。

    注意

    该图表在水平 (X) 轴上显示每天分发的传单数量,在垂直 (Y) 轴上显示每日销量。 该图形成一条大致的对角线(有一些方差),表明销量随传单数量的增加而增加的总体趋势。

查看降雨与销量的关系

  1. 返回到包含数据透视表的工作表,并将其修改为在行区域显示“日期”,“降雨量”总和和“销售额”总和如下所示:

    按日期显示降雨量和销售额总计的数据透视表的屏幕截图。

  2. 将日期、降雨量和销量(而不是标题或总计)复制到新工作表,并添加标题“Date”、“Rainfall”和“Sales”,如下所示:

    按日期显示总降雨量和销售额的新工作表的屏幕截图。

  3. 选择“降雨量”和“销售额”数据及标题(但不包括日期)。 然后在“插入”选项卡上的“散点图”下拉列表中,选择第一个散点图格式。 这会创建如下所示的散点图:

    显示总降雨量与销售额关系的散点图的屏幕截图。

    此图似乎表明降雨与销量之间存在某种关系,随着降雨量的增加,销量下降。 但绘制的图形所形成的线条是曲线。 这通常意味着存在一个非线性的、可能是对数的关系。

  4. 删除图表,这样可以在每日降雨量和销量数据之后看到空的 D 列和 E 列。

  5. 在 D1 中,添加列标题LogRainfall,然后选择单元格 D2,在工作表上方的 fx 框中输入以下公式,以计算降雨量以 10 为底的对数值:

    =log(B2)
    
  6. 将公式复制到“LogRainfall”列中的其他单元格。 执行此操作的最简单方法是选择包含公式的单元格,然后双击所选单元格右下角的小号方形“句柄”(▪)。

  7. 在E1中,添加列标题LogSales,然后选择单元格E2,在工作表上方的fx框中输入以下公式来计算销售值以 10 为底的对数值:

    =log(C2)
    
  8. 将公式复制到“LogSales”列中的其他单元格。

  9. 选择 LogRainfall 和 LogSales 数据及标题。 然后在“插入”选项卡上的“散点图”下拉列表中,选择第一个散点图格式。 这会创建如下所示的散点图:

    按记录销售额显示记录降雨量的散点图的屏幕截图。

    请注意,此图显示了降雨量对数与销量对数之间的线性关系。 这在探索数据中的关系时可能很有用,因为计算将降雨量与销量相关联的线性方程比定义对数方程来执行相同操作更简单。

挑战:可视化数据

  1. 创建一个柱形图,显示一周每天分发的传单总数,并记下分发传单数最高和最低的那一天。
  2. 创建一个散点图,显示每天的温度和降雨量,并检查这些字段之间的明显关系。