错误 (工作区加入期间已达到用户可加入工作区的最大设备数)
本文介绍了尝试执行工作区加入操作时出现“已达到用户可加入工作区的最大设备数”错误的问题。
原始产品版本:Windows Server 2012 R2 Datacenter、Windows Server 2012 R2 Standard、Windows 8.1 企业版、Microsoft Entra ID
原始 KB 编号: 3045379
症状
当用户尝试在 WIndows 设备上执行工作区加入操作时,他们会收到以下消息:
确认你使用的是当前登录信息,并且你的工作场所使用此功能。 此外,与工作区的连接现在可能不起作用。 请稍候,然后重试。
此外,管理员可能会在事件查看器中看到以下事件详细信息。
事件 ID:200
日志名称:Microsoft-Windows-Workplace Join/管理员来源:Microsoft-Windows-Workplace 加入级别:错误说明:已达到用户可加入工作区的最大设备数。
注册服务 URI:https://enterpriseregistration.windows.net/EnrollmentServer/DeviceEnrollmentWebService.svc
原因
出现此问题是因为用户已加入最大设备数并已满足指定的配额。
解决方案
若要解决此问题,检查配额配置。 然后,检查用户以前注册的设备数。 如果达到配额,请按照以下步骤操作,具体取决于适用的方案。
- 如果用户尝试执行工作区加入Microsoft Entra ID
- 删除用户的设备。
- 以公司管理员身份从Microsoft 365 管理中心登录Azure 门户或启动Microsoft Entra ID控制台。
- 移动到用户正在尝试联接的目录。
- 找到 “用户”,然后找到无法执行工作区加入操作的用户。
- 找到 “设备”。
- 查看列表以确定可以删除哪些设备。 然后,单击“ 删除设备”。
- 增加已注册设备配额。
- 以公司管理员身份从Microsoft 365 管理中心登录到Azure 门户或启动Microsoft Entra ID控制台。
- 移动到用户正在尝试联接的目录。
- 找到“设备”,然后找到“设备设置”。
- 将 “每个用户的最大设备数 ”设置更改为更大的值。
- 删除用户的设备。
- 如果用户尝试对本地 Active Directory 站点执行工作区加入
- 删除用户的设备。
- 使用Windows PowerShell脚本来标识设备和删除与用户关联的设备。
- 增加“已注册 设备配额” 值。
登录到 AD FS 服务器。
以提升的管理员身份运行 Windows PowerShell。
运行以下命令以增加配额:
Set-ADFSDeviceRegistration -DevicesPerUser [0 - 1000]
例如,运行以下命令,将用户的设备数设置为 10:
Set-ADFSDeviceRegistration -DevicesPerUser 10
- 删除用户的设备。
还可以通过查看 DRS 事件日志来验证用户是否已达到设备容量。
在 DRS 服务器上打开事件查看器。
浏览到位置:
Applications and Services Logs\Device Registration Service\DRS\Admin
查找事件 ID 125。 它应如下所示:
用户“user@domain.com : GUID”不符合注册“device_type”原因“DeviceCapReached”类型的设备的条件。
更多信息
有关故障排除的详细信息,请参阅 用于排查工作区加入问题的诊断日志记录。
联系我们寻求帮助
如果你有任何疑问或需要帮助,请创建支持请求或联系 Azure 社区支持。 还可以向 Azure 反馈社区提交产品反馈。
反馈
https://aka.ms/ContentUserFeedback。
即将发布:在整个 2024 年,我们将逐步淘汰作为内容反馈机制的“GitHub 问题”,并将其取代为新的反馈系统。 有关详细信息,请参阅:提交和查看相关反馈