Azure 备份服务版本和 Microsoft Azure 恢复服务代理版本不匹配
本文介绍以下两种方案中出现的问题的症状和解决方法:
- 使用 Microsoft Azure 恢复服务代理备份文件和系统状态
- 使用 System Center Data Protection Manager 或 Azure 备份 Server 将数据备份到 Azure
原始产品版本:Azure Site Recovery,Azure 备份
原始 KB 编号: 4096064
症状
以下错误消息显示在“作业详细信息”对话框的“错误”选项卡上,该选项卡对应于 Azure 恢复服务代理控制台、Data Protection Manager 或 azure 恢复服务代理版本号低于 2.0.9083.0 的 Azure 备份 服务器控制台上的失败备份作业。
Azure 备份服务版本与 Microsoft Azure 恢复服务代理不匹配。 请从 Microsoft 下载中心安装最新版本的 Microsoft Azure 恢复服务代理 (https://go.microsoft.com/fwlink/?linkid=225925) 。 如果问题仍然存在,请联系 Microsoft 支持部门 (0x1FBD3) 。
下面是此错误的示例:
原因
出现此问题的原因是 Microsoft Azure 恢复服务代理已过时。
解决方案
若要解决此问题,请按照下列步骤操作:
关闭 Microsoft Azure 恢复服务代理控制台。
重要
如果服务器或服务器的代理具有有限的 Internet 访问,请按照步骤 2 到步骤 4 进行操作。 否则,请转到步骤 5。
若要配置前面提到的防火墙设置,请从提升的命令提示符运行以下命令:
net stop obengine
确保服务器或代理上的防火墙设置配置为允许适用于你正在使用的 Azure 云的 URL。
从提升的命令提示符运行以下命令:
net start obengine
将最新版本的 Azure 备份 代理下载到有问题的服务器。
运行安装程序。 此时会打开 Microsoft Azure 恢复服务代理升级向导。
单击下一个。
单击“ 升级”。
最终确认屏幕指示已成功更新Azure 备份代理。
关闭向导。
打开 MARS 代理控制台。
在控制台右侧,单击“操作”**** 窗格中的“立即备份”,然后检查备份是否成功运行。
后续步骤
备份环境中可能还有其他服务器包含早于版本 2.0.9083.0 的 Azure 恢复服务代理,并且可能面临类似的问题。 按照更新Azure 备份代理中的指南来标识和更新 Azure 恢复服务代理。
联系我们寻求帮助
如果你有任何疑问或需要帮助,请创建支持请求或联系 Azure 社区支持。 还可以向 Azure 反馈社区提交产品反馈。