由于权限,电子邮件路由器无法从 Microsoft Dynamics 发送电子邮件

本文提供了电子邮件路由器因权限而无法从 Microsoft Dynamics 发送电子邮件的问题的解决方案。

适用于: Microsoft Dynamics 365 Customer Engagement Online
原始 KB 数: 4494727

现象

使用Dynamics 365电子邮件路由器从Dynamics 365实例发送电子邮件时,电子邮件可能进入挂起的发送状态,并且永远不会实际发送:

屏幕截图显示了处于“挂起发送”状态的电子邮件。

Dynamics Email Router 异常日志可能显示以下错误:

检查要处理的传出电子邮件时出错: https://disco.crm.dynamics.com/\<OrgName>。 System.ServiceModel.FaultException'1[Microsoft.Xrm.Sdk.OrganizationServiceFault]:用户没有作为发送权限。 (错误详细信息等于异常详细信息:

ErrorCode:0x8004480D
消息:用户没有作为发送权限。

原因

此行为可能已正常工作,而无需对早期版本的 Dynamics 365 应用程序具有这些权限。 由于在版本 8.2.2 和 9.x 的某些迭代中引入安全模型更改,因此必须显式授予这些权限,以便电子邮件路由器为其他用户发送电子邮件。

解决方法

发送此电子邮件的用户必须允许在其个人选项中从其他 Dynamics 用户发送电子邮件:

选择“允许其他Microsoft Dynamics 365用户代表你发送电子邮件”选项的屏幕截图。

电子邮件路由器正在使用该帐户还必须在 Dynamics 中将 “发送电子邮件”作为其他用户 权限:

“以其他用户身份发送电子邮件”权限的屏幕截图。

详细信息