使用 Microsoft Dynamics 365 App for Outlook 时,无法连接到你的 Microsoft Dynamics 365 服务器错误

本文提供了由于无法连接到 Microsoft Dynamics 365 服务器错误而无法使用 Microsoft Dynamics 365 App for Outlook 的问题的解决方案。

适用于:Microsoft Dynamics 365
原始 KB 编号: 4341413

症状

尝试使用 Microsoft Dynamics 365 App for Outlook 时,会收到以下消息:

“我们无法连接到你的 Microsoft Dynamics 365 服务器。 请尝试关闭并重新打开应用。”

如果选择“ 显示更多”,可能会看到以下消息:

“客户端加载程序超时”

如果在 Outlook Web Access (OWA) 中使用该应用,你可能会在屏幕底部看到以下提示:

“是否允许 dynamics.com 在计算机上使用其他存储?”

如果清除 Internet Explorer 浏览器缓存,则此错误可能看起来已解决,但最终会返回。

原因

Microsoft 注意到此错误可能发生的问题,因为 Internet Explorer 配置为限制可缓存的数据量。 如果使用 Internet Explorer 查看应用,则可能是导致错误的原因。 如果使用 Outlook 桌面版时遇到此错误,则 Outlook 始终使用 Internet Explorer 显示应用。

解决方案

Microsoft 正在进行更改以避免此问题。 在此期间,可以使用以下步骤作为可能的解决方法:

选项 1 - 提高 Internet Explorer 选项中的数据库限制

根据操作系统的版本,可以在 Internet Explorer 设置中更改限制。 如果使用 Windows 10,则不会显示此选项,可以改用选项 2。

  1. 打开 Internet Explorer。
  2. 在右上角,选择齿轮图标,然后选择 “Internet 选项”。
  3. 在“浏览历史记录”部分中的“常规”选项卡上,选择“设置”。
  4. 选择“ 缓存和数据库 ”选项卡。
  5. 如果看到 “当网站缓存或数据库超过时通知我 ”选项,请将值更改为 200 ,然后选择“ 确定”。 或者,可以从 dynamics.com 网站列表中选择,然后选择“ 超出限制”。 如果未显示这些选项,请继续执行选项 2。
  6. 清除 Internet Explorer 历史记录和缓存。 有关详细步骤,请参阅 在 Internet Explorer 中查看和删除浏览历史记录

选项 2 - 提高注册表中的数据库限制

重要

本部分包含介绍如何修改注册表的步骤。 但是,注册表修改不当可能会出现严重问题。 因此,请务必严格按照这些步骤操作。 为了加强保护,应先备份注册表,再进行修改。 如果出现问题,可以还原注册表。 有关如何备份和还原注册表的详细信息,请参阅如何备份和还原 Windows 中的注册表

若要提高允许的缓存限制,请创建以下注册表项:

子项:HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\BrowserStorage\IndexedDBValue
名称:MaxTrustedDomainLimitInMB
类型:REG_DWORD
数据: 200

若要创建此注册表项,请执行以下步骤:

  1. 依次选择“开始”、“运行”,键入 regedit,然后选择“确定”

  2. 找到并选择以下注册表子项。 如果此位置的路径不存在,则可能需要创建上述密钥:

    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\BrowserStorage\IndexedDBValue

  3. 右键单击“ IndexedDBValue”,指向 “新建”,然后选择“ DWORD 值”。

  4. 在“ 新建值 #1 ”框中,键入 MaxTrustedDomainLimitInMB,然后按 Enter。

  5. 右键单击“ MaxTrustedDomainLimitInMB”,然后选择“ 修改”。

  6. 选择“ 小数”,键入 200 ,然后选择“ 确定”。

  7. 退出注册表编辑器,然后重新启动计算机。

  8. 清除 Internet Explorer 历史记录和缓存。 有关详细步骤,请参阅 在 Internet Explorer 中查看和删除浏览历史记录

更多信息

此错误有多种可能的原因。 如果这不能解决问题,请参阅以下文章,了解其他可能的解决方案:

使用 Dynamics 365 App for Outlook 时出现错误“我们无法连接到你的 Microsoft Dynamics 365服务器”